summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 03:33:03 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 03:33:03 +0000
commitb1560dad189ce2b107c03ce6afc20081a07c4979 (patch)
tree24751ccd78f3fa895d818efd6bd43947884c8497 /media-gfx
parentAdded yet another game, it's a dirty job but someone has to do it :-) (diff)
downloadgentoo-2-b1560dad189ce2b107c03ce6afc20081a07c4979.tar.gz
gentoo-2-b1560dad189ce2b107c03ce6afc20081a07c4979.tar.bz2
gentoo-2-b1560dad189ce2b107c03ce6afc20081a07c4979.zip
*** empty log message ***
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/autotrace/autotrace-0.26.ebuild5
-rw-r--r--media-gfx/imagemagick/files/digest-imagemagick-5.3.41
-rw-r--r--media-gfx/imagemagick/imagemagick-5.3.4.ebuild50
3 files changed, 53 insertions, 3 deletions
diff --git a/media-gfx/autotrace/autotrace-0.26.ebuild b/media-gfx/autotrace/autotrace-0.26.ebuild
index c079f4632729..135f43a710db 100644
--- a/media-gfx/autotrace/autotrace-0.26.ebuild
+++ b/media-gfx/autotrace/autotrace-0.26.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/autotrace/autotrace-0.26.ebuild,v 1.2 2001/05/01 18:29:05 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/autotrace/autotrace-0.26.ebuild,v 1.3 2001/06/04 03:33:03 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,8 +9,7 @@ DESCRIPTION="Converts Bitmaps to vector-grahics"
SRC_URI="http://homepages.go.com/homepages/m/a/r/martweb/${A}"
HOMEPAGE="http://homepages.go.com/homepages/m/a/r/martweb/AutoTrace.htm"
-DEPEND=">=sys-libs/glibc-2.1.3
- >=dev-libs/glib-1.2.8
+DEPEND="virtual/glibc
>=x11-libs/gtkDPS-0.3.3
>=x11-libs/gtk+-1.2.8"
diff --git a/media-gfx/imagemagick/files/digest-imagemagick-5.3.4 b/media-gfx/imagemagick/files/digest-imagemagick-5.3.4
new file mode 100644
index 000000000000..26c4b41c70aa
--- /dev/null
+++ b/media-gfx/imagemagick/files/digest-imagemagick-5.3.4
@@ -0,0 +1 @@
+MD5 39c762e1a492798bf119b3814d653518 ImageMagick-5.3.4.tar.gz
diff --git a/media-gfx/imagemagick/imagemagick-5.3.4.ebuild b/media-gfx/imagemagick/imagemagick-5.3.4.ebuild
new file mode 100644
index 000000000000..6943ff7f0022
--- /dev/null
+++ b/media-gfx/imagemagick/imagemagick-5.3.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-5.3.4.ebuild,v 1.1 2001/06/04 03:33:03 achim Exp $
+
+P=ImageMagick-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A collection of tools and libraries for many image formats"
+SRC_URI="ftp://ftp.fifi.org/pub/ImageMagick/${A}"
+HOMEPAGE="http://www.imagemagick.org"
+
+DEPEND=">=app-text/dgs-0.5.9.1
+ perl? ( >=sys-devel/perl-5 )
+ >=sys-apps/bzip2-1
+ >=media-libs/freetype-2.0
+ >=media-libs/tiff-3.5.5
+ >=media-libs/libpng-1.0.7
+ virtual/x11
+ virtual/lpr"
+
+RDEPEND=">app-text/dgs-0.5.9.1
+ >=sys-apps/bzip2-1
+ >=media-libs/jpeg-6b
+ >=media-libs/freetype-2.0
+ >=media-libs/libpng-1.0.7"
+
+src_compile() {
+ local myconf
+ if [ -z "`use perl`" ] ; then
+ myconf="--without-perl"
+ fi
+ try ./configure \
+ --prefix=/usr/X11R6 --build=${CHOST} --enable-shared --enable-static \
+ --without-xml --without-lcms --enable-lzw --with-ttf --without-fpx \
+ --without-gslib --without-hdf --without-jbig --without-wmf
+ --enable-shared --with-threads --mandir=/usr/X11R6/man $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr/X11R6 PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ mandir=${D}/usr/X11R6/man install
+
+}
+