summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-06 19:33:45 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-06 19:33:45 +0000
commita19173d311b3ec23d85289aa2a8a46f9542725c7 (patch)
tree3bf81c912f68483e3e29ca59a47730b5942abace /media-gfx
parentinitial import wrt #144283 (diff)
downloadgentoo-2-a19173d311b3ec23d85289aa2a8a46f9542725c7.tar.gz
gentoo-2-a19173d311b3ec23d85289aa2a8a46f9542725c7.tar.bz2
gentoo-2-a19173d311b3ec23d85289aa2a8a46f9542725c7.zip
initial import wrt #144283
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xpaint/ChangeLog13
-rw-r--r--media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch91
-rw-r--r--media-gfx/xpaint/files/xpaint-2.9.9.4-QA2.patch67
-rw-r--r--media-gfx/xpaint/files/xpaint-2.9.9.4-autoreconf.patch24
-rw-r--r--media-gfx/xpaint/files/xpaint-2.9.9.4-parallel-make.patch25
-rw-r--r--media-gfx/xpaint/files/xpaint-2.9.9.4-submake.patch29
-rw-r--r--media-gfx/xpaint/metadata.xml33
-rw-r--r--media-gfx/xpaint/xpaint-2.9.9.4.ebuild73
8 files changed, 355 insertions, 0 deletions
diff --git a/media-gfx/xpaint/ChangeLog b/media-gfx/xpaint/ChangeLog
new file mode 100644
index 000000000000..aa9a9b6e2d14
--- /dev/null
+++ b/media-gfx/xpaint/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-gfx/xpaint
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xpaint/ChangeLog,v 1.17 2013/10/06 19:33:45 hasufell Exp $
+
+*xpaint-2.9.9.4 (06 Oct 2013)
+
+ 06 Oct 2013; Julian Ospald <hasufell@gentoo.org> +xpaint-2.9.9.4.ebuild,
+ +files/xpaint-2.9.9.4-QA1.patch, +files/xpaint-2.9.9.4-QA2.patch,
+ +files/xpaint-2.9.9.4-autoreconf.patch,
+ +files/xpaint-2.9.9.4-parallel-make.patch,
+ +files/xpaint-2.9.9.4-submake.patch, +metadata.xml:
+ initial import wrt #144283
+
diff --git a/media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch b/media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch
new file mode 100644
index 000000000000..31e3a38ba005
--- /dev/null
+++ b/media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch
@@ -0,0 +1,91 @@
+From 2987bfa203a8467a697efffa211b90b12858b40b Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 6 Oct 2013 20:37:28 +0200
+Subject: [PATCH] respect flags, add WITH_PGF option, fix echo
+
+---
+ util/Makefile | 56 +++++++++++++++++++++++++++++++++++---------------------
+ 1 file changed, 35 insertions(+), 21 deletions(-)
+
+diff --git a/util/Makefile b/util/Makefile
+index e6af415..21a0d17 100644
+--- a/util/Makefile
++++ b/util/Makefile
+@@ -1,39 +1,53 @@
+-GCC = gcc
+-CPP = g++ -fpermissive
++# set to anything but "no" to enable
++WITH_PGF=no
+
++ifneq ($(WITH_PGF),no)
+ all: pdfconcat ppmtops pgf2pnm
++else
++all: pdfconcat ppmtops
++endif
+
+ pdfconcat:
+- $(GCC) -O3 -s -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat
++ $(CC) $(CFLAGS) -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat $(LDFLAGS)
+
+ ppmtops:
+- $(GCC) ppmtops.c -o ppmtops
++ $(CC) $(CFLAGS) ppmtops.c -o ppmtops $(LDFLAGS)
+
++ifneq ($(WITH_PGF),no)
+ pgf2pnm: main.cpp pnm.cpp
+ @if [ -x /usr/include/libpgf ] ; then \
+- $(CPP) -c main.cpp -o main.o -I/usr/include/libpgf ; \
+- $(CPP) -c pnm.cpp -o pnm.o -I/usr/include/libpgf ; \
+- $(CPP) -o pgf2pnm main.o pnm.o -lpgf ; \
++ $(CXX) $(CXXFLAGS) -fpermissive -c main.cpp -o main.o -I/usr/include/libpgf ; \
++ $(CXX) $(CXXFLAGS) -fpermissive -c pnm.cpp -o pnm.o -I/usr/include/libpgf ; \
++ $(CXX) $(CXXFLAGS) -fpermissive -o pgf2pnm main.o pnm.o $(LDFLAGS) -lpgf ; \
+ else \
+- @echo "libpgf not installed !!" ; \
++ echo "libpgf not installed !!" ; \
+ fi
++endif
+
+-install:
++install-common:
+ @if [ -x pdfconcat ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c pdfconcat $(DESTDIR)/usr/bin ; \
+- echo "install -c pdfconcat $(DESTDIR)/usr/bin" ; \
+- mkdir -p $(DESTDIR)/usr/share/man/man1 ; \
+- install -c -m 644 pdfconcat.1 $(DESTDIR)/usr/share/man/man1 ; \
+- echo "install -c pdfconcat.1 $(DESTDIR)/usr/share/man/man1" ; fi
++ mkdir -p "$(DESTDIR)"/usr/bin ; \
++ install -c pdfconcat "$(DESTDIR)"/usr/bin ; \
++ echo "install -c pdfconcat "$(DESTDIR)"/usr/bin" ; \
++ mkdir -p "$(DESTDIR)"/usr/share/man/man1 ; \
++ install -c -m 644 pdfconcat.1 "$(DESTDIR)"/usr/share/man/man1 ; \
++ echo "install -c pdfconcat.1 "$(DESTDIR)"/usr/share/man/man1" ; fi
+ @if [ -x ppmtops ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c ppmtops $(DESTDIR)/usr/bin ; \
+- echo "install -c ppmtops $(DESTDIR)/usr/bin" ; fi
++ mkdir -p "$(DESTDIR)"/usr/bin ; \
++ install -c ppmtops "$(DESTDIR)"/usr/bin ; \
++ echo "install -c ppmtops "$(DESTDIR)"/usr/bin" ; fi
++
++install-pgf:
+ @if [ -x pgf2pnm ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c pgf2pnm $(DESTDIR)/usr/bin ; \
+- echo "install -c pgf2pnm $(DESTDIR)/usr/bin" ; fi
++ mkdir -p "$(DESTDIR)"/usr/bin ; \
++ install -c pgf2pnm "$(DESTDIR)"/usr/bin ; \
++ echo "install -c pgf2pnm "$(DESTDIR)"/usr/bin" ; fi
++
++ifneq ($(WITH_PGF),no)
++install: install-common install-pgf
++else
++install: install-common
++endif
+
+ clean:
+ rm -f core *~ *.o pdfconcat ppmtops pgf2pnm
+--
+1.8.3.2
+
diff --git a/media-gfx/xpaint/files/xpaint-2.9.9.4-QA2.patch b/media-gfx/xpaint/files/xpaint-2.9.9.4-QA2.patch
new file mode 100644
index 000000000000..03b35f81f37b
--- /dev/null
+++ b/media-gfx/xpaint/files/xpaint-2.9.9.4-QA2.patch
@@ -0,0 +1,67 @@
+From 08bdf5f5d0c64384b2be16bd8ac68244675388d5 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 6 Oct 2013 21:13:51 +0200
+Subject: [PATCH] respect CFLAGS
+
+---
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ rw/Makefile.am | 2 +-
+ rw/configure.ac | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 4cf1753..414597f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -26,7 +26,7 @@ EXTERN_VIEWER = display
+ ## -D_BSD_SOURCE -D_SVID_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 \
+ ## -DFUNCPROTO=15 -DNARROWPROTO
+
+-ARCH_DEFINES = -g -O2 -fno-strict-aliasing -fPIC
++ARCH_DEFINES = -fno-strict-aliasing -fPIC
+
+ ##
+ ## Specific xpaint options
+diff --git a/configure.ac b/configure.ac
+index e058529..3979075 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -29,7 +29,7 @@ AC_TYPE_UINT16_T
+ AC_TYPE_UINT32_T
+ AC_TYPE_UINT64_T
+
+-CFLAGS="-I/usr/include -I/usr/include/X11 -I/usr/include/X11/Xaw3dxft"
++CFLAGS="$CFLAGS -I/usr/include -I/usr/include/X11 -I/usr/include/X11/Xaw3dxft"
+ LIBS="$LIBS -lm"
+ echo "VERSION = $VERSION" > .version
+
+diff --git a/rw/Makefile.am b/rw/Makefile.am
+index d91d5d5..2f50253 100644
+--- a/rw/Makefile.am
++++ b/rw/Makefile.am
+@@ -10,7 +10,7 @@ SHAREDIR = $(prefix)/share/xpaint
+ ## -D_BSD_SOURCE -D_SVID_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 \
+ ## -DFUNCPROTO=15 -DNARROWPROTO
+
+-ARCH_DEFINES = -g -O2 -fno-strict-aliasing -fPIC
++ARCH_DEFINES = -fno-strict-aliasing -fPIC
+
+ ##
+ ## Specific xpaint options
+diff --git a/rw/configure.ac b/rw/configure.ac
+index fb4f3d4..d9c7601 100644
+--- a/rw/configure.ac
++++ b/rw/configure.ac
+@@ -29,7 +29,7 @@ AC_TYPE_UINT16_T
+ AC_TYPE_UINT32_T
+ AC_TYPE_UINT64_T
+
+-CFLAGS="-I/usr/include -I/usr/include/X11 -I/usr/include/X11/Xaw3dxft"
++CFLAGS="$CFLAGS -I/usr/include -I/usr/include/X11 -I/usr/include/X11/Xaw3dxft"
+ LIBS="$LIBS -lm"
+
+ dnl check X11
+--
+1.8.3.2
+
diff --git a/media-gfx/xpaint/files/xpaint-2.9.9.4-autoreconf.patch b/media-gfx/xpaint/files/xpaint-2.9.9.4-autoreconf.patch
new file mode 100644
index 000000000000..4342d4f4fa78
--- /dev/null
+++ b/media-gfx/xpaint/files/xpaint-2.9.9.4-autoreconf.patch
@@ -0,0 +1,24 @@
+From e22a3c15aea7d734f433370130458d97d6490d8a Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 6 Oct 2013 20:27:49 +0200
+Subject: [PATCH] add missing macros
+
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index 169419e..e058529 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,6 +15,7 @@ AC_CONFIG_MACRO_DIR([m4])
+ AM_INIT_AUTOMAKE([-Wall -Werror])
+
+ AC_LANG_C
++AM_PROG_AR
+
+ ## basic types
+
+--
+1.8.3.2
+
diff --git a/media-gfx/xpaint/files/xpaint-2.9.9.4-parallel-make.patch b/media-gfx/xpaint/files/xpaint-2.9.9.4-parallel-make.patch
new file mode 100644
index 000000000000..250f634f9973
--- /dev/null
+++ b/media-gfx/xpaint/files/xpaint-2.9.9.4-parallel-make.patch
@@ -0,0 +1,25 @@
+From ae11f5cb975749bd8d6ffda48301eb4aadfee35d Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 6 Oct 2013 21:02:12 +0200
+Subject: [PATCH] fix parallel make
+
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index b2285a0..4cf1753 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -112,7 +112,7 @@ XPaint.ad: app-defaults
+ XPaint.ad.h: substads XPaint.ad
+ ./substads -ad2c XPaint.ad $@
+
+-xpaint.1: xpaint.1.in version.h
++xpaint.1: substads xpaint.1.in version.h
+ ./substads -single xpaint.1.in xpaint.1 XPAINT_VERSION $(PACKAGE_VERSION)
+
+ install-exec-hook:
+--
+1.8.3.2
+
diff --git a/media-gfx/xpaint/files/xpaint-2.9.9.4-submake.patch b/media-gfx/xpaint/files/xpaint-2.9.9.4-submake.patch
new file mode 100644
index 000000000000..e218eb4c75e9
--- /dev/null
+++ b/media-gfx/xpaint/files/xpaint-2.9.9.4-submake.patch
@@ -0,0 +1,29 @@
+From 11b369b69c4637431b139960391bded531a9f652 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 6 Oct 2013 20:25:14 +0200
+Subject: [PATCH] don't run submake
+
+---
+ Makefile.am | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 5b2caec..b2285a0 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -139,11 +139,6 @@ install-exec-hook:
+ mkdir -p $(DESTDIR)$(SHAREDIR)/messages
+ cd share/messages ; $(RM) -f *~ ; cp -f Messages* $(DESTDIR)$(SHAREDIR)/messages
+ chmod -R a+r $(DESTDIR)$(SHAREDIR)/
+- cd util ; make ; make install DESTDIR=$(DESTDIR)$
+
+ clean-local:
+ rm -f xaw_incdir
+- cd util ; make clean
+-
+-distclean-local:
+- cd util ; make distclean
+\ No newline at end of file
+--
+1.8.3.2
+
diff --git a/media-gfx/xpaint/metadata.xml b/media-gfx/xpaint/metadata.xml
new file mode 100644
index 000000000000..3b89377220b0
--- /dev/null
+++ b/media-gfx/xpaint/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <longdescription lang="en">
+ XPaint is an X Window System color image bitmap editing program.
+ It also supports advanced features, such as image processing
+ algorithms, scripting and batch jobs. XPaint allows the edition
+ of multiple images simultaneously and supports a wide variety of
+ image formats, including: GIF, JPG, PNG, PPM, TIFF, XBM, XPM,
+ etc.
+
+ xpaint is now fully UTF8 compliant, and is capable of using
+ antialiased truetype fonts in its operations and in the menus
+ (in particular, translating to oriental languages should now be
+ quite easy - also the X core font protocol is no longer used
+ anywhere.)
+
+ xpaint also offers optional editing features based on
+ programmable filters and user defined procedures written as
+ scripts in plain C. The package includes a substantial list of
+ examples and some support for batch processing.
+ </longdescription>
+ <use>
+ <flag name="pgf">Support for loading PGF images</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">sf-xpaint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/xpaint/xpaint-2.9.9.4.ebuild b/media-gfx/xpaint/xpaint-2.9.9.4.ebuild
new file mode 100644
index 000000000000..1db201279afd
--- /dev/null
+++ b/media-gfx/xpaint/xpaint-2.9.9.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xpaint/xpaint-2.9.9.4.ebuild,v 1.1 2013/10/06 19:33:45 hasufell Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="XPaint image editor with tiff, jpeg and png support"
+HOMEPAGE="http://sf-xpaint.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg2k pgf tiff"
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:0
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw3dXft
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ sys-libs/zlib
+ virtual/jpeg
+ jpeg2k? ( media-libs/openjpeg:0 )
+ pgf? ( media-libs/libpgf )
+ tiff? ( media-libs/tiff:0 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{QA1,QA2,submake,autoreconf,parallel-make}.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tiff) \
+ $(use_enable jpeg2k libopenjpeg)
+}
+
+src_compile() {
+ default
+ emake \
+ WITH_PGF="$(usex pgf "yes" "no")" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ -C util
+}
+
+src_install() {
+ default
+ emake \
+ WITH_PGF="$(usex pgf "yes" "no")" \
+ DESTDIR="${ED}" \
+ -C util install
+}
+
+pkg_postinst() {
+ elog "optional dependencies:"
+ elog " app-text/gv (external viewer for PostScript outpu)"
+ elog " media-gfx/imagemagick (external viewer for pixel graphics)"
+ elog " net-print/cups (printing)"
+}