summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-09-21 07:16:19 +0000
committerNed Ludd <solar@gentoo.org>2008-09-21 07:16:19 +0000
commit7e09793f65d1e2de34798b24ca7bc6da361d707f (patch)
treee6cf5db9c03a541f39fa47fe5bfba0e647c45a5c /media-gfx
parentAvoid running dodoc on dirs #234096 by Doug Goldstein. (diff)
downloadgentoo-2-7e09793f65d1e2de34798b24ca7bc6da361d707f.tar.gz
gentoo-2-7e09793f65d1e2de34798b24ca7bc6da361d707f.tar.bz2
gentoo-2-7e09793f65d1e2de34798b24ca7bc6da361d707f.zip
- Make cross compile aware. Avoid calls to built_with_use when doing x-compiles
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/splashutils/ChangeLog5
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4.2.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index d212ef9ad4d3..346b8d048913 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.144 2008/09/13 10:23:34 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.145 2008/09/21 07:16:19 solar Exp $
+
+ 21 Sep 2008; <solar@gentoo.org> splashutils-1.5.4.2.ebuild:
+ - Make cross compile aware. Avoid calls to built_with_use when doing x-compiles
13 Sep 2008; nixnut <nixnut@gentoo.org> splashutils-1.5.4.2.ebuild:
Stable on ppc wrt bug 237000
diff --git a/media-gfx/splashutils/splashutils-1.5.4.2.ebuild b/media-gfx/splashutils/splashutils-1.5.4.2.ebuild
index 7a602e755e8e..c16ce4af4509 100644
--- a/media-gfx/splashutils/splashutils-1.5.4.2.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.2.ebuild,v 1.3 2008/09/13 10:23:34 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.2.ebuild,v 1.4 2008/09/21 07:16:19 solar Exp $
EAPI="1"
@@ -33,7 +33,7 @@ SRC_URI="mirror://berlios/fbsplash/${PN}-lite-${PV}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="amd64 ppc x86 ~arm"
RDEPEND="gpm? ( sys-libs/gpm )
truetype? ( >=media-libs/freetype-2 )
png? ( >=media-libs/libpng-1.2.7 )
@@ -71,7 +71,7 @@ src_unpack() {
cd "${S}"
ln -sf "${S}/src" "${WORKDIR}/core"
- if built_with_use sys-devel/gcc vanilla ; then
+ if ! tc-is-cross-compiler && built_with_use sys-devel/gcc vanilla; then
ewarn "Your GCC was built with the 'vanilla' flag set. If you can't compile"
ewarn "splashutils, you're on your own, as this configuration is not supported."
else
@@ -85,8 +85,9 @@ src_unpack() {
}
src_compile() {
+ tc-export CC
cd "${SM}"
- emake LIB=$(get_libdir) STRIP=true || die "failed to build miscsplashutils"
+ emake CC="${CC}" LIB=$(get_libdir) STRIP=true || die "failed to build miscsplashutils"
cd "${S}"
econf \
@@ -101,7 +102,7 @@ src_compile() {
--with-lpng-src=${LPNGSRC} \
--with-zlib-src=${ZLIBSRC} || die "failed to configure splashutils"
- emake -j1 || die "failed to build splashutils"
+ emake -j1 KLCC="${CC}" CC="${CC}" || die "failed to build splashutils"
if has_version ">=sys-apps/baselayout-1.13.99"; then
cd "${SG}"