summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 17:35:32 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 17:35:32 +0000
commit799ff6c6e042b3f9c7d2461e5e90d875c76226ca (patch)
tree6adabe9595a9c8d8d768b066a216343338c7f9e3 /media-gfx
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-799ff6c6e042b3f9c7d2461e5e90d875c76226ca.tar.gz
gentoo-2-799ff6c6e042b3f9c7d2461e5e90d875c76226ca.tar.bz2
gentoo-2-799ff6c6e042b3f9c7d2461e5e90d875c76226ca.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog/ChangeLog7
-rw-r--r--media-gfx/eog/eog-3.8.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index 6e5b5de89d3f..fb3295a88844 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/eog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.302 2013/02/02 22:44:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.303 2013/03/28 17:35:32 pacho Exp $
+
+*eog-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +eog-3.8.0.ebuild:
+ Version bump for Gnome 3.8
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> eog-3.6.2.ebuild:
Add ~arm, wrt bug #449220
diff --git a/media-gfx/eog/eog-3.8.0.ebuild b/media-gfx/eog/eog-3.8.0.ebuild
new file mode 100644
index 000000000000..5710a5dc0eac
--- /dev/null
+++ b/media-gfx/eog/eog-3.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-3.8.0.ebuild,v 1.1 2013/03/28 17:35:32 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="http://www.gnome.org/projects/eog/"
+
+LICENSE="GPL-2+"
+SLOT="1"
+IUSE="+exif +introspection +jpeg lcms +svg tiff xmp"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+REQUIRED_USE="exif? ( jpeg )"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.5.4:3[introspection,X]
+ >=dev-libs/glib-2.31:2
+ >=dev-libs/libxml2-2:2
+ >=dev-libs/libpeas-0.7.4:=[gtk]
+ >=gnome-base/gnome-desktop-2.91.2:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=x11-misc/shared-mime-info-0.20
+
+ x11-libs/gdk-pixbuf:2[jpeg?,tiff?]
+ x11-libs/libX11
+
+ exif? ( >=media-libs/libexif-0.6.14 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ svg? ( >=gnome-base/librsvg-2.36.2:2 )
+ xmp? ( media-libs/exempi:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_with jpeg libjpeg)
+ $(use_with exif libexif)
+ $(use_with lcms cms)
+ $(use_with xmp)
+ $(use_with svg librsvg)
+ ITSTOOL=$(type -P true)"
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+ gnome2_src_configure
+}