summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2007-03-07 13:19:12 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2007-03-07 13:19:12 +0000
commit784ffd7b0a97f511042c85c6854c3b1f0391fc2d (patch)
treef4388cd4c649aa6a430f67ed1b497cfeba4ccf95 /media-gfx
parentEnough testing for quilt .. (diff)
downloadgentoo-2-784ffd7b0a97f511042c85c6854c3b1f0391fc2d.tar.gz
gentoo-2-784ffd7b0a97f511042c85c6854c3b1f0391fc2d.tar.bz2
gentoo-2-784ffd7b0a97f511042c85c6854c3b1f0391fc2d.zip
Adding desktop entry (bug #160264) + a little version bump.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xsane/ChangeLog10
-rw-r--r--media-gfx/xsane/files/digest-xsane-0.9943
-rw-r--r--media-gfx/xsane/xsane-0.991.ebuild6
-rw-r--r--media-gfx/xsane/xsane-0.994.ebuild82
4 files changed, 97 insertions, 4 deletions
diff --git a/media-gfx/xsane/ChangeLog b/media-gfx/xsane/ChangeLog
index 7928130389d0..1e45e8692091 100644
--- a/media-gfx/xsane/ChangeLog
+++ b/media-gfx/xsane/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/xsane
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.54 2006/11/01 11:35:59 phosphan Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.55 2007/03/07 13:19:12 phosphan Exp $
+
+*xsane-0.994 (07 Mar 2007)
+
+ 07 Mar 2007; Patrick Kursawe <phosphan@gentoo.org> xsane-0.991.ebuild,
+ +xsane-0.994.ebuild:
+ Adding desktop entry (bug #160264) + a little version bump.
01 Nov 2006; Patrick Kursawe <phosphan@gentoo.org> xsane-0.991.ebuild:
Adding missing pkgconfig dependency, bug #153070
diff --git a/media-gfx/xsane/files/digest-xsane-0.994 b/media-gfx/xsane/files/digest-xsane-0.994
new file mode 100644
index 000000000000..0c69b6211d6a
--- /dev/null
+++ b/media-gfx/xsane/files/digest-xsane-0.994
@@ -0,0 +1,3 @@
+MD5 7d02656026797a46a84bda63006f5668 xsane-0.994.tar.gz 3303013
+RMD160 5ce83791e16a0c805b2850bb17092092264a3ce1 xsane-0.994.tar.gz 3303013
+SHA256 67d72b8b76a44f106bf758db319c490d2c6c9edf9a269544e71e5c783a58ad0a xsane-0.994.tar.gz 3303013
diff --git a/media-gfx/xsane/xsane-0.991.ebuild b/media-gfx/xsane/xsane-0.991.ebuild
index c9b4bfca45d5..28f2519dcdc0 100644
--- a/media-gfx/xsane/xsane-0.991.ebuild
+++ b/media-gfx/xsane/xsane-0.991.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.991.ebuild,v 1.9 2006/11/01 11:35:59 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.991.ebuild,v 1.10 2007/03/07 13:19:12 phosphan Exp $
inherit eutils
@@ -61,6 +61,8 @@ src_install() {
dodir "${plugindir}"
dosym /usr/bin/xsane "${plugindir}"
fi
+ newicon src/xsane-48x48.png ${PN}.png
+ make_desktop_entry xsane "X-Sane" ${PN}
}
pkg_postinst() {
diff --git a/media-gfx/xsane/xsane-0.994.ebuild b/media-gfx/xsane/xsane-0.994.ebuild
new file mode 100644
index 000000000000..040f609eae57
--- /dev/null
+++ b/media-gfx/xsane/xsane-0.994.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.994.ebuild,v 1.1 2007/03/07 13:19:12 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="graphical scanning frontend"
+HOMEPAGE="http://www.xsane.org/"
+SRC_URI="http://www.xsane.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls jpeg png tiff gimp lcms"
+
+RDEPEND="media-gfx/sane-backends
+ >=x11-libs/gtk+-2.0
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ gimp? ( media-gfx/gimp )
+ lcms? ( media-libs/lcms )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ export OLDXSANE
+ if has_version '<=media-gfx/xsane-0.93'; then
+ OLDXSANE="yes"
+ else
+ OLDXSANE="no"
+ fi
+}
+
+src_compile() {
+ local extraCPPflags
+ if use lcms; then
+ extraCPPflags="-I /usr/include/lcms"
+ fi
+ CPPFLAGS="${CPPFLAGS} ${extraCPPflags}" econf --enable-gtk2 \
+ $(use_enable nls) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_enable gimp) \
+ $(use_enable lcms) \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc xsane.[A-Z]*
+ dohtml -r doc
+
+ # link xsane so it is seen as a plugin in gimp
+ if use gimp; then
+ local plugindir
+ if [ -x /usr/bin/gimptool ]; then
+ plugindir="$(gimptool --gimpplugindir)/plug-ins"
+ elif [ -x /usr/bin/gimptool-2.0 ]; then
+ plugindir="$(gimptool-2.0 --gimpplugindir)/plug-ins"
+ else
+ die "Can't find GIMP plugin directory."
+ fi
+ dodir "${plugindir}"
+ dosym /usr/bin/xsane "${plugindir}"
+ fi
+ newicon src/xsane-48x48.png ${PN}.png
+ make_desktop_entry xsane "X-Sane" ${PN}
+}
+
+pkg_postinst() {
+ if [ x${OLDXSANE} = 'xyes' ]; then
+ einfo ""
+ ewarn "If you are upgrading from <=xsane-0.93, please make sure to"
+ ewarn "remove ~/.sane/xsane/xsane.rc _before_ you start xsane for"
+ ewarn "the first time."
+ einfo ""
+ fi
+}