summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 17:36:19 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 17:36:19 +0000
commit538a9df4b46dae9378317b4ebe5ded1cce9b7d12 (patch)
tree4ec53d8927ed4bc616bcc46ad19fefeb9c082a89 /media-gfx
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-538a9df4b46dae9378317b4ebe5ded1cce9b7d12.tar.gz
gentoo-2-538a9df4b46dae9378317b4ebe5ded1cce9b7d12.tar.bz2
gentoo-2-538a9df4b46dae9378317b4ebe5ded1cce9b7d12.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog-plugins/ChangeLog10
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.8.0.ebuild65
2 files changed, 72 insertions, 3 deletions
diff --git a/media-gfx/eog-plugins/ChangeLog b/media-gfx/eog-plugins/ChangeLog
index 92f1d0c72501..0a3a69ef4f70 100644
--- a/media-gfx/eog-plugins/ChangeLog
+++ b/media-gfx/eog-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/eog-plugins
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/ChangeLog,v 1.3 2012/12/26 22:03:15 eva Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/ChangeLog,v 1.4 2013/03/28 17:36:19 pacho Exp $
+
+*eog-plugins-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +eog-plugins-3.8.0.ebuild:
+ Version bump for Gnome 3.8
*eog-plugins-3.6.1-r1 (26 Dec 2012)
@@ -21,4 +26,3 @@
+eog-plugins-3.4.0.ebuild, +metadata.xml:
New package with official eog plugins (bug #389413, thanks to Christian
Strahl for reporting).
-
diff --git a/media-gfx/eog-plugins/eog-plugins-3.8.0.ebuild b/media-gfx/eog-plugins/eog-plugins-3.8.0.ebuild
new file mode 100644
index 000000000000..178f82138887
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.8.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/eog-plugins-3.8.0.ebuild,v 1.1 2013/03/28 17:36:19 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://live.gnome.org/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +flickr map +picasa +python"
+REQUIRED_USE="map? ( exif )"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.5.5
+ >=x11-libs/gtk+-3.3.8:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ flickr? ( media-gfx/postr )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use flickr && plugins="${plugins},postr"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder"
+ G2CONF="${G2CONF}
+ $(use_enable python)
+ --with-plugins=${plugins}"
+ gnome2_src_configure
+}