summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-10-04 22:21:40 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-10-04 22:21:40 +0000
commit468f351e78b3366473d6d691121f9399b729bb6e (patch)
tree05635f912b1253f66832f4141618eee73c562e7d /media-gfx/zphoto/zphoto-1.2-r2.ebuild
parentquoting (diff)
downloadgentoo-2-468f351e78b3366473d6d691121f9399b729bb6e.tar.gz
gentoo-2-468f351e78b3366473d6d691121f9399b729bb6e.tar.bz2
gentoo-2-468f351e78b3366473d6d691121f9399b729bb6e.zip
depricated gtk2 USE flag. Bug #106560.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-gfx/zphoto/zphoto-1.2-r2.ebuild')
-rw-r--r--media-gfx/zphoto/zphoto-1.2-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-gfx/zphoto/zphoto-1.2-r2.ebuild b/media-gfx/zphoto/zphoto-1.2-r2.ebuild
new file mode 100644
index 000000000000..14db6c695f8c
--- /dev/null
+++ b/media-gfx/zphoto/zphoto-1.2-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r2.ebuild,v 1.1 2005/10/04 22:21:40 matsuu Exp $
+
+IUSE="wxwindows"
+
+DESCRIPTION="A zooming photo album generator in Flash"
+SRC_URI="http://namazu.org/~satoru/zphoto/${P}.tar.gz"
+HOMEPAGE="http://namazu.org/~satoru/zphoto/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=media-libs/ming-0.2a
+ || ( >=media-libs/imlib2-1.1.0 >=media-gfx/imagemagick-5.5.7 )
+ >=media-video/avifile-0.7.34
+ app-arch/zip
+ >=dev-libs/popt-1.6.3
+ wxwindows? ( >=x11-libs/wxGTK-2.4.2-r2 )"
+
+src_compile() {
+
+ local myconf
+
+ if use wxwindows ; then
+ if has_version '>=x11-libs/wxGTK-2.6' ; then
+ wx_config="/usr/bin/wx-config-2.6"
+ sed -i -e 's@\($WXCONFIG --cflags\)@\1 --unicode=no@' \
+ -e 's@\($WXCONFIG --libs\)@\1 --unicode=no@' \
+ configure || die
+ sed -i -e 's@FALSE@false@g' wxzphoto.cpp || die
+ else
+ wx_config="/usr/bin/wxgtk2-2.4-config"
+ fi
+ myconf="--with-wx-config=$wx_config"
+ else
+ myconf="--disable-wx"
+ fi
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ einstall || die
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}