summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-11-27 05:03:52 +0000
committerTim Harder <radhermit@gentoo.org>2014-11-27 05:03:52 +0000
commit0a2355e9b467b129bad1b0793b6513466ae8f3a3 (patch)
tree0e421d99beb946b2212776f47252a4aad10d5acc /media-gfx/wkhtmltopdf
parentBump scala to 2.11.4 (diff)
downloadgentoo-2-0a2355e9b467b129bad1b0793b6513466ae8f3a3.tar.gz
gentoo-2-0a2355e9b467b129bad1b0793b6513466ae8f3a3.tar.bz2
gentoo-2-0a2355e9b467b129bad1b0793b6513466ae8f3a3.zip
Version bump (bug #513164).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/wkhtmltopdf')
-rw-r--r--media-gfx/wkhtmltopdf/ChangeLog10
-rw-r--r--media-gfx/wkhtmltopdf/files/wkhtmltopdf-0.12.1.2-manpages.patch24
-rw-r--r--media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.1.2.ebuild40
3 files changed, 72 insertions, 2 deletions
diff --git a/media-gfx/wkhtmltopdf/ChangeLog b/media-gfx/wkhtmltopdf/ChangeLog
index 38bd113d27d2..fd87f57affa0 100644
--- a/media-gfx/wkhtmltopdf/ChangeLog
+++ b/media-gfx/wkhtmltopdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/wkhtmltopdf
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wkhtmltopdf/ChangeLog,v 1.3 2013/03/02 21:41:29 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wkhtmltopdf/ChangeLog,v 1.4 2014/11/27 05:03:51 radhermit Exp $
+
+*wkhtmltopdf-0.12.1.2 (27 Nov 2014)
+
+ 27 Nov 2014; Tim Harder <radhermit@gentoo.org> +wkhtmltopdf-0.12.1.2.ebuild,
+ +files/wkhtmltopdf-0.12.1.2-manpages.patch:
+ Version bump (bug #513164).
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org>
wkhtmltopdf-0.10.0_rc2.ebuild, wkhtmltopdf-0.11.0_rc1.ebuild:
diff --git a/media-gfx/wkhtmltopdf/files/wkhtmltopdf-0.12.1.2-manpages.patch b/media-gfx/wkhtmltopdf/files/wkhtmltopdf-0.12.1.2-manpages.patch
new file mode 100644
index 000000000000..962647121402
--- /dev/null
+++ b/media-gfx/wkhtmltopdf/files/wkhtmltopdf-0.12.1.2-manpages.patch
@@ -0,0 +1,24 @@
+Fix install paths and don't precompress man pages.
+
+--- wkhtmltopdf-0.12.1.2/src/image/image.pro
++++ wkhtmltopdf-0.12.1.2/src/image/image.pro
+@@ -25,7 +25,7 @@
+
+ unix {
+ man.path=$$INSTALLBASE/share/man/man1
+- man.extra=LD_LIBRARY_PATH=../../bin/ ../../bin/wkhtmltoimage --manpage | gzip > $(INSTALL_ROOT)/share/man/man1/wkhtmltoimage.1.gz
++ man.extra=LD_LIBRARY_PATH=../../bin/ ../../bin/wkhtmltoimage --manpage > $(INSTALL_ROOT)$$INSTALLBASE/share/man/man1/wkhtmltoimage.1
+
+ QMAKE_EXTRA_TARGETS += man
+ INSTALLS += man
+--- wkhtmltopdf-0.12.1.2/src/pdf/pdf.pro
++++ wkhtmltopdf-0.12.1.2/src/pdf/pdf.pro
+@@ -25,7 +25,7 @@
+
+ unix {
+ man.path=$$INSTALLBASE/share/man/man1
+- man.extra=LD_LIBRARY_PATH=../../bin/ ../../bin/wkhtmltopdf --manpage | gzip > $(INSTALL_ROOT)/share/man/man1/wkhtmltopdf.1.gz
++ man.extra=LD_LIBRARY_PATH=../../bin/ ../../bin/wkhtmltopdf --manpage > $(INSTALL_ROOT)$$INSTALLBASE/share/man/man1/wkhtmltopdf.1
+
+ QMAKE_EXTRA_TARGETS += man
+ INSTALLS += man
diff --git a/media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.1.2.ebuild b/media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.1.2.ebuild
new file mode 100644
index 000000000000..14d13371101c
--- /dev/null
+++ b/media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.1.2.ebuild,v 1.1 2014/11/27 05:03:51 radhermit Exp $
+
+EAPI=5
+
+inherit qt4-r2 multilib eutils
+
+DESCRIPTION="Convert html to pdf (and various image formats) using webkit"
+HOMEPAGE="http://wkhtmltopdf.org/ https://github.com/wkhtmltopdf/wkhtmltopdf/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtcore:4
+ dev-qt/qtsvg:4
+ dev-qt/qtxmlpatterns:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # fix install paths and don't precompress man pages
+ epatch "${FILESDIR}"/${P}-manpages.patch
+
+ sed -i "s:\(INSTALLBASE/\)lib:\1$(get_libdir):" src/lib/lib.pro || die
+}
+
+src_configure() {
+ eqmake4 INSTALLBASE=/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc AUTHORS CHANGELOG* README.md
+ use examples && dodoc -r examples
+}