summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-10-24 03:30:29 +0000
committerTim Harder <radhermit@gentoo.org>2012-10-24 03:30:29 +0000
commit2a9bfadafa2e13f0c6e54eb2ac06072d7948ca4b (patch)
tree725657ef0d9eb8e43aef5600d48e89d612e63354 /media-gfx/sxiv
parentVersion bump. (diff)
downloadgentoo-2-2a9bfadafa2e13f0c6e54eb2ac06072d7948ca4b.tar.gz
gentoo-2-2a9bfadafa2e13f0c6e54eb2ac06072d7948ca4b.tar.bz2
gentoo-2-2a9bfadafa2e13f0c6e54eb2ac06072d7948ca4b.zip
Revbump to properly respect CFLAGS (bug #439456) and use verbose build output.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/sxiv')
-rw-r--r--media-gfx/sxiv/ChangeLog9
-rw-r--r--media-gfx/sxiv/files/sxiv-1.0-makefile.patch40
-rw-r--r--media-gfx/sxiv/sxiv-1.0-r1.ebuild34
3 files changed, 82 insertions, 1 deletions
diff --git a/media-gfx/sxiv/ChangeLog b/media-gfx/sxiv/ChangeLog
index e9151b5e3b16..cfe03819b876 100644
--- a/media-gfx/sxiv/ChangeLog
+++ b/media-gfx/sxiv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/sxiv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sxiv/ChangeLog,v 1.9 2012/06/24 03:14:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sxiv/ChangeLog,v 1.10 2012/10/24 03:30:29 radhermit Exp $
+
+*sxiv-1.0-r1 (24 Oct 2012)
+
+ 24 Oct 2012; Tim Harder <radhermit@gentoo.org> +sxiv-1.0-r1.ebuild,
+ +files/sxiv-1.0-makefile.patch:
+ Revbump to properly respect CFLAGS (bug #439456) and use verbose build
+ output.
24 Jun 2012; Tim Harder <radhermit@gentoo.org> -sxiv-0.9-r1.ebuild:
Remove old.
diff --git a/media-gfx/sxiv/files/sxiv-1.0-makefile.patch b/media-gfx/sxiv/files/sxiv-1.0-makefile.patch
new file mode 100644
index 000000000000..783f0a522971
--- /dev/null
+++ b/media-gfx/sxiv/files/sxiv-1.0-makefile.patch
@@ -0,0 +1,40 @@
+--- sxiv-1.0/Makefile
++++ sxiv-1.0/Makefile
+@@ -1,8 +1,8 @@
+ VERSION = 1.0
+
+-CC = gcc
+-CFLAGS = -ansi -Wall -pedantic -O2
+-LDFLAGS =
++CC ?= gcc
++CFLAGS += -ansi -Wall -pedantic
++LDFLAGS +=
+ LIBS = -lX11 -lImlib2
+
+ PREFIX = /usr/local
+@@ -21,21 +21,18 @@
+ @echo "PREFIX = $(PREFIX)"
+
+ .c.o:
+- @echo "CC $<"
+- @$(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<
++ $(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<
+
+ $(OBJ) config: Makefile config.h
+
+ config: config.c
+- @$(CC) $(CFLAGS) -o $@ $@.c
++ $(CC) $(CFLAGS) -o $@ $@.c
+
+ config.h:
+- @echo "creating $@ from config.def.h"
+- @cp config.def.h $@
++ cp config.def.h $@
+
+ sxiv: $(OBJ) config
+- @echo "CC -o $@"
+- @$(CC) $(LDFLAGS) -o $@ $(OBJ) $(LIBS) $$(./config -l)
++ $(CC) $(LDFLAGS) -o $@ $(OBJ) $(LIBS) $$(./config -l)
+
+ clean:
+ @echo "cleaning"
diff --git a/media-gfx/sxiv/sxiv-1.0-r1.ebuild b/media-gfx/sxiv/sxiv-1.0-r1.ebuild
new file mode 100644
index 000000000000..efe054ffddef
--- /dev/null
+++ b/media-gfx/sxiv/sxiv-1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sxiv/sxiv-1.0-r1.ebuild,v 1.1 2012/10/24 03:30:29 radhermit Exp $
+
+EAPI=4
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="Simple (or small or suckless) X Image Viewer"
+HOMEPAGE="https://github.com/muennich/sxiv/"
+SRC_URI="mirror://github/muennich/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ tc-export CC
+
+ restore_config config.h
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ dodoc README.md
+
+ save_config config.h
+}