summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2012-08-03 22:14:14 +0000
committerMatthew Marlowe <mattm@gentoo.org>2012-08-03 22:14:14 +0000
commit419d1a6e32513b9424859933767c2689e18b37b8 (patch)
tree2673c0b5ad9c5872ddcd204656920b76e50ab9d8 /media-gfx/replicatorg
parentkeyword amd64-linux x86-linux (diff)
downloadgentoo-2-419d1a6e32513b9424859933767c2689e18b37b8.tar.gz
gentoo-2-419d1a6e32513b9424859933767c2689e18b37b8.tar.bz2
gentoo-2-419d1a6e32513b9424859933767c2689e18b37b8.zip
Fixes for some minor perm issues.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/replicatorg')
-rw-r--r--media-gfx/replicatorg/ChangeLog7
-rw-r--r--media-gfx/replicatorg/replicatorg-37-r1.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/media-gfx/replicatorg/ChangeLog b/media-gfx/replicatorg/ChangeLog
index 5ca03265a734..4b3295db99a5 100644
--- a/media-gfx/replicatorg/ChangeLog
+++ b/media-gfx/replicatorg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/replicatorg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/replicatorg/ChangeLog,v 1.1 2012/08/02 12:55:44 mattm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/replicatorg/ChangeLog,v 1.2 2012/08/03 22:14:14 mattm Exp $
+
+*replicatorg-37-r1 (03 Aug 2012)
+
+ 03 Aug 2012; Matthew Marlowe <mattm@gentoo.org> +replicatorg-37-r1.ebuild:
+ Fixes for some minor permissions issues.
*replicatorg-37 (02 Aug 2012)
diff --git a/media-gfx/replicatorg/replicatorg-37-r1.ebuild b/media-gfx/replicatorg/replicatorg-37-r1.ebuild
new file mode 100644
index 000000000000..f0f2bd3828b5
--- /dev/null
+++ b/media-gfx/replicatorg/replicatorg-37-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/replicatorg/replicatorg-37-r1.ebuild,v 1.1 2012/08/03 22:14:14 mattm Exp $
+
+EAPI="3"
+
+inherit eutils versionator
+
+MY_P="${PN}-00${PV}"
+
+DESCRIPTION="ReplicatorG is a simple, open source 3D printing program"
+HOMEPAGE="http://replicat.org/start"
+SRC_URI="http://replicatorg.googlecode.com/files/${MY_P}-linux.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+COMMON_DEPEND="dev-java/sun-jre-bin"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup replicator
+}
+
+pkg_postinst() {
+ elog "Replicatorg requires Sun/Oracle JRE and will not work with OpenJDK."
+ elog
+ elog "Ensure that your user account has permissions to access serial port,"
+ elog "if you plan to connect directly to a 3d printer rather than using"
+ elog "a flash card. Printing directly from replicatorg is preferred."
+ elog
+ elog "The replicator printer will likely show up in /dev as ttyACM0."
+ elog "You may want to autoload the cdc_acm kernel module."
+ elog
+ elog "Note that replicatorg includes its own version of skeinforge."
+ elog "There doesn't seem to be a simple way to depend on an external"
+ elog "version."
+ elog
+ elog "Replicatorg users should add themselves to the replicator group"
+ elog "to avoid upstream warnings about not being able to modify shared"
+ elog "skeinforge scripts."
+ elog
+ chmod -R g+w "${ROOT}"/opt/replicatorg
+ chown -R root:replicator "${ROOT}"/opt/replicatorg
+ chmod 0755 /opt/replicatorg
+}
+
+src_install() {
+ dodir \
+ /opt/replicatorg \
+ /usr/share/replicatorg
+
+ keepdir \
+ /opt/replicatorg \
+ /usr/share/replicatorg
+
+ dobin "${FILESDIR}"/replicatorg
+
+ /bin/cp -R --preserve=mode \
+ docs \
+ examples \
+ lib \
+ lib-i686 \
+ lib-x86_64 \
+ machines \
+ scripts \
+ replicatorg \
+ skein_engines \
+ tools \
+ "${D}"/opt/replicatorg/
+
+ insinto /usr/share/replicatorg
+ doins -r \
+ contributors.txt \
+ license.txt \
+ readme.txt \
+ todo.txt
+
+}