summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-11 08:30:28 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-11 08:30:28 +0000
commit97c0e573aa276aa108d46fa00804211604a54662 (patch)
tree2c2813e367e34b95d3a7489de80d2845df88e2a2 /media-gfx/rawtherapee
parentFix fdisk compile failure on Alpha (diff)
downloadgentoo-2-97c0e573aa276aa108d46fa00804211604a54662.tar.gz
gentoo-2-97c0e573aa276aa108d46fa00804211604a54662.tar.bz2
gentoo-2-97c0e573aa276aa108d46fa00804211604a54662.zip
Version bump (bug #506424).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/ChangeLog7
-rw-r--r--media-gfx/rawtherapee/rawtherapee-4.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-gfx/rawtherapee/ChangeLog b/media-gfx/rawtherapee/ChangeLog
index 6c67f8dcf737..b1de5e06e4c5 100644
--- a/media-gfx/rawtherapee/ChangeLog
+++ b/media-gfx/rawtherapee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/rawtherapee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v 1.15 2014/01/24 08:34:02 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v 1.16 2014/06/11 08:30:28 radhermit Exp $
+
+*rawtherapee-4.1 (11 Jun 2014)
+
+ 11 Jun 2014; Tim Harder <radhermit@gentoo.org> +rawtherapee-4.1.ebuild:
+ Version bump (bug #506424).
*rawtherapee-4.0.12 (24 Jan 2014)
diff --git a/media-gfx/rawtherapee/rawtherapee-4.1.ebuild b/media-gfx/rawtherapee/rawtherapee-4.1.ebuild
new file mode 100644
index 000000000000..7c1dee350a27
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/rawtherapee-4.1.ebuild,v 1.1 2014/06/11 08:30:28 radhermit Exp $
+
+EAPI=5
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="http://www.rawtherapee.com/"
+SRC_URI="http://rawtherapee.com/shared/source/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 openmp"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ >=x11-libs/gtk+-2.24.18:2
+ >=dev-cpp/gtkmm-2.12:2.4
+ >=dev-cpp/glibmm-2.16:2
+ dev-libs/expat
+ dev-libs/libsigc++:2
+ media-libs/libcanberra[gtk]
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/libiptcdata
+ media-libs/lcms:2
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use openmp OPTION_OMP)
+ $(cmake-utils_use_with bzip2 BZIP)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ )
+ cmake-utils_src_configure
+}