summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2004-01-31 09:58:47 +0000
committerMike Gardiner <obz@gentoo.org>2004-01-31 09:58:47 +0000
commit6cd1af3eafc1a78d7a618767a711315de45a9241 (patch)
tree6c2db4aadc8ad4e9c2644491f14e30cfecf2325d /media-gfx/pstoedit
parentInitial import. Thanks to Gour <gour@mail.inet.hr> for submitting the ebuild ... (diff)
downloadgentoo-2-6cd1af3eafc1a78d7a618767a711315de45a9241.tar.gz
gentoo-2-6cd1af3eafc1a78d7a618767a711315de45a9241.tar.bz2
gentoo-2-6cd1af3eafc1a78d7a618767a711315de45a9241.zip
Now installs all documentation, and a man page. Removed -pedantic flag which causes errors with libEMF
Diffstat (limited to 'media-gfx/pstoedit')
-rw-r--r--media-gfx/pstoedit/ChangeLog9
-rw-r--r--media-gfx/pstoedit/pstoedit-3.32.ebuild17
-rw-r--r--media-gfx/pstoedit/pstoedit-3.33.ebuild17
3 files changed, 33 insertions, 10 deletions
diff --git a/media-gfx/pstoedit/ChangeLog b/media-gfx/pstoedit/ChangeLog
index a050724a09b0..4d651bb0da94 100644
--- a/media-gfx/pstoedit/ChangeLog
+++ b/media-gfx/pstoedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/pstoedit
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.7 2003/12/09 17:49:35 lanius Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.8 2004/01/31 09:58:47 obz Exp $
+
+ 31 Jan 2004; Mike Gardiner <obz@gentoo.org> pstoedit-3.32.ebuild,
+ pstoedit-3.33.ebuild:
+ Now installs all documentation, and a man page. Removed -pedantic flag which
+ causes errors with libEMF
09 Dec 2003; Heinrich Wendel <lanius@gentoo.org> pstoedit-3.32.ebuild,
pstoedit-3.33.ebuild:
diff --git a/media-gfx/pstoedit/pstoedit-3.32.ebuild b/media-gfx/pstoedit/pstoedit-3.32.ebuild
index 3d97b9bdacee..7ea2ee6a95c2 100644
--- a/media-gfx/pstoedit/pstoedit-3.32.ebuild
+++ b/media-gfx/pstoedit/pstoedit-3.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.32.ebuild,v 1.7 2003/12/09 17:49:35 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.32.ebuild,v 1.8 2004/01/31 09:58:47 obz Exp $
inherit libtool
@@ -22,6 +22,14 @@ DEPEND="media-libs/libpng
RDEPEND="${DEPEND}
virtual/ghostscript"
+src_unpack() {
+
+ unpack ${A}; cd ${S}
+ # remove the -pedantic flag, see bug #39575
+ sed -i -e "s/\-pedantic//" configure
+
+}
+
src_compile() {
elibtoolize
econf
@@ -29,7 +37,10 @@ src_compile() {
}
src_install () {
+
make DESTDIR=${D} install || die "make install failed"
dodoc readme.txt copying
- dodoc changelog.htm
+ dohtml changelog.htm index.html doc/pstoedit.htm
+ doman doc/pstoedit.1
+
}
diff --git a/media-gfx/pstoedit/pstoedit-3.33.ebuild b/media-gfx/pstoedit/pstoedit-3.33.ebuild
index 629bb346165f..c6295ac16112 100644
--- a/media-gfx/pstoedit/pstoedit-3.33.ebuild
+++ b/media-gfx/pstoedit/pstoedit-3.33.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.33.ebuild,v 1.4 2003/12/09 17:49:35 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.33.ebuild,v 1.5 2004/01/31 09:58:47 obz Exp $
inherit libtool
@@ -19,17 +19,23 @@ KEYWORDS="x86 ~ppc"
DEPEND="media-libs/libpng
sys-libs/zlib"
-
# flash? ( media-libs/ming )"
RDEPEND="${DEPEND}
virtual/ghostscript"
+src_unpack() {
+
+ unpack ${A}; cd ${S}
+ # need to remove the pedantic flag, see bug #39557
+ sed -i -e "s/\-pedantic//" configure
+
+}
+
src_compile() {
local myconf=""
# checking if libemf is previously installed, bug #29724
- # <obz@gentoo.org>
[ -f /usr/include/libEMF/emf.h ] \
&& myconf="${myconf} --with-libemf-include=/usr/include/libEMF"
@@ -43,6 +49,7 @@ src_install () {
make DESTDIR=${D} install || die "make install failed"
dodoc readme.txt copying
- dodoc changelog.htm
+ dohtml changelog.htm index.htm doc/pstoedit.htm
+ doman doc/pstoedit.1
}