summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-10-27 16:19:07 +0000
committerDaniel Goller <morfic@gentoo.org>2004-10-27 16:19:07 +0000
commit0eb1a893f815313be1fccfb24236cab55bbe9968 (patch)
treee6c7c6bb5af997ae0660aaca8647329e92c41913 /media-gfx/povray/povray-3.6.1-r1.ebuild
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-0eb1a893f815313be1fccfb24236cab55bbe9968.tar.gz
gentoo-2-0eb1a893f815313be1fccfb24236cab55bbe9968.tar.bz2
gentoo-2-0eb1a893f815313be1fccfb24236cab55bbe9968.zip
Added dep on >=tiff-3.6.1 to close bug 67783
Diffstat (limited to 'media-gfx/povray/povray-3.6.1-r1.ebuild')
-rw-r--r--media-gfx/povray/povray-3.6.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/povray/povray-3.6.1-r1.ebuild b/media-gfx/povray/povray-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..f359423de516
--- /dev/null
+++ b/media-gfx/povray/povray-3.6.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.6.1-r1.ebuild,v 1.1 2004/10/27 16:19:07 morfic Exp $
+
+DESCRIPTION="The Persistence Of Vision Ray Tracer"
+SRC_URI="ftp://ftp.povray.org/pub/povray/Official/Unix/povray-3.6.tar.bz2"
+HOMEPAGE="http://www.povray.org/"
+
+SLOT="0"
+LICENSE="povlegal-3.6"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64"
+IUSE="X svga"
+
+DEPEND="media-libs/libpng
+ >=media-libs/tiff-3.6.1
+ media-libs/jpeg
+ sys-libs/zlib
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )"
+
+
+src_compile() {
+ local myconf
+
+ use X && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"\
+ CFLAGS="${CFLAGS} -DX_DISPLAY_MISSING"
+ use svga || myconf="${myconf} --without-svga"
+
+ econf COMPILED_BY="${USER} (on `uname -n`)" ${myconf} || die
+
+ # Copy the user configuration into /etc/skel
+ cp Makefile Makefile.orig
+ sed -e "s:^povconfuser = .*:povconfuser = ${D}etc/skel/.povray/3.6/:" Makefile.orig >Makefile
+
+ einfo Building povray
+ emake || die "build failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+}