summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-30 01:51:05 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-30 01:51:05 +0000
commit2542a35b619a8e8b710e5fd89eb9959cf80b164a (patch)
tree24084e9117676f3ccd43df7b0a14b1961ed87b41 /media-gfx/pixie/files
parentYet another gcc2 fix closing bug #49427. Thanks again Tristan. (Manifest rec... (diff)
downloadgentoo-2-2542a35b619a8e8b710e5fd89eb9959cf80b164a.tar.gz
gentoo-2-2542a35b619a8e8b710e5fd89eb9959cf80b164a.tar.bz2
gentoo-2-2542a35b619a8e8b710e5fd89eb9959cf80b164a.zip
Initial ebuild by me.
Diffstat (limited to 'media-gfx/pixie/files')
-rw-r--r--media-gfx/pixie/files/digest-pixie-1.3.51
-rw-r--r--media-gfx/pixie/files/pixie-1.3.5-Makefile.patch26
-rw-r--r--media-gfx/pixie/files/pixie-1.3.5-math.patch47
3 files changed, 74 insertions, 0 deletions
diff --git a/media-gfx/pixie/files/digest-pixie-1.3.5 b/media-gfx/pixie/files/digest-pixie-1.3.5
new file mode 100644
index 000000000000..fbafc3db7e82
--- /dev/null
+++ b/media-gfx/pixie/files/digest-pixie-1.3.5
@@ -0,0 +1 @@
+MD5 244a168fe7942d449566c8ad15e6caf9 Pixie-src-1.3.5.tgz 4269413
diff --git a/media-gfx/pixie/files/pixie-1.3.5-Makefile.patch b/media-gfx/pixie/files/pixie-1.3.5-Makefile.patch
new file mode 100644
index 000000000000..688f9c931a11
--- /dev/null
+++ b/media-gfx/pixie/files/pixie-1.3.5-Makefile.patch
@@ -0,0 +1,26 @@
+--- Makefile.am.orig 2004-04-29 16:49:45.000000000 -0700
++++ Makefile.am 2004-04-29 17:06:12.000000000 -0700
+@@ -1,9 +1,5 @@
+ SUBDIRS = src
+
+-topdir = $(prefix)
+-
+-top_DATA = README AUTHORS LICENSE COPYING
+-
+ EXTRA_DIST = Pixie.dsw Pixie.ncb Pixie.opt DEVNOTES LICENSE makeclean.bat makeinst.bat tutorials win32inst
+
+ dist-hook:
+@@ -11,11 +7,6 @@
+ cp -rf $(srcdir)/shaders $(distdir)
+
+ install-data-local:
+- cp -rf $(srcdir)/doc $(prefix)
+- cp -rf $(srcdir)/shaders $(prefix)
+-
+-
+-
+-
+-
++ @INSTALL@ -d $(DESTDIR)$(datadir)/doc/pixie && cp -rf $(srcdir)/doc/. $(DESTDIR)$(datadir)/doc/pixie
++ @INSTALL@ -d $(DESTDIR)$(libdir)/shaders && cp -rf $(srcdir)/shaders/. $(DESTDIR)$(libdir)/shaders
+
diff --git a/media-gfx/pixie/files/pixie-1.3.5-math.patch b/media-gfx/pixie/files/pixie-1.3.5-math.patch
new file mode 100644
index 000000000000..18366104e2fc
--- /dev/null
+++ b/media-gfx/pixie/files/pixie-1.3.5-math.patch
@@ -0,0 +1,47 @@
+--- src/common/global.h.orig 2004-04-29 17:30:45.000000000 -0700
++++ src/common/global.h 2004-04-29 17:33:40.000000000 -0700
+@@ -47,6 +47,8 @@
+ #ifndef GLOBAL_H
+ #define GLOBAL_H
+
++#include <math.h>
++
+ // The Pixie version
+ #define VERSION_RELEASE 1
+ #define VERSION_BETA 3
+@@ -54,21 +56,33 @@
+
+ // Come constant definitions
+ // Math constants
++#ifndef INFINITY
+ #define INFINITY (float) 1e30
+-#define EPSILON (float) 1e-6
++#endif
+
++#define EPSILON (float) 1e-6
+
+ // The most famous number
+ #ifndef PI
++#ifdef M_PI
++#define PI M_PI
++#else
+ #define PI (float) 3.141592653589793238462643383279502884197169399375105820974944592308
++#endif
++#endif
++
++#ifndef DOUBLE_PI
++#ifdef M_PIl
++#define DOUBLE_PI M_PIl
++#else
+ #define DOUBLE_PI 3.141592653589793238462643383279502884197169399375105820974944592308
+ #endif
++#endif
+
+ // Logic constants
+ #define TRUE 1
+ #define FALSE 0
+
+-
+ // Misc Options and Attributes constants
+ #ifdef min
+ #undef min