summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-06-11 17:23:10 +0000
committerTim Harder <radhermit@gentoo.org>2012-06-11 17:23:10 +0000
commitca3d58b7712085ee243e9950aae3aab262fbd44a (patch)
treef6f913ec86785a1aa638d8a2e3ad5eb87ce68de9 /media-gfx/photoprint
parentManifest fix (diff)
downloadgentoo-2-ca3d58b7712085ee243e9950aae3aab262fbd44a.tar.gz
gentoo-2-ca3d58b7712085ee243e9950aae3aab262fbd44a.tar.bz2
gentoo-2-ca3d58b7712085ee243e9950aae3aab262fbd44a.zip
Fix gettext regeneration issue (bug #420365) and fix build with glib-2.32.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/photoprint')
-rw-r--r--media-gfx/photoprint/ChangeLog6
-rw-r--r--media-gfx/photoprint/files/photoprint-0.4.2_pre2-glib-2.32.patch21
-rw-r--r--media-gfx/photoprint/photoprint-0.4.2_pre2.ebuild9
3 files changed, 31 insertions, 5 deletions
diff --git a/media-gfx/photoprint/ChangeLog b/media-gfx/photoprint/ChangeLog
index 46e43ce237af..a5480640ea92 100644
--- a/media-gfx/photoprint/ChangeLog
+++ b/media-gfx/photoprint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/photoprint
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoprint/ChangeLog,v 1.3 2012/05/05 07:00:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoprint/ChangeLog,v 1.4 2012/06/11 17:23:09 radhermit Exp $
+
+ 11 Jun 2012; Tim Harder <radhermit@gentoo.org> photoprint-0.4.2_pre2.ebuild,
+ +files/photoprint-0.4.2_pre2-glib-2.32.patch:
+ Fix gettext regeneration issue (bug #420365) and fix build with glib-2.32.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> photoprint-0.4.2_pre2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-gfx/photoprint/files/photoprint-0.4.2_pre2-glib-2.32.patch b/media-gfx/photoprint/files/photoprint-0.4.2_pre2-glib-2.32.patch
new file mode 100644
index 000000000000..1d54ba9b77d1
--- /dev/null
+++ b/media-gfx/photoprint/files/photoprint-0.4.2_pre2-glib-2.32.patch
@@ -0,0 +1,21 @@
+--- photoprint-0.4.2-pre2/gp_cppsupport/gprinter.cpp
++++ photoprint-0.4.2-pre2/gp_cppsupport/gprinter.cpp
+@@ -22,8 +22,6 @@
+ #include <gutenprint/gutenprint.h>
+
+ #include <glib.h>
+-#include <glib/gstrfuncs.h>
+-#include <glib/gprintf.h>
+
+ #include "../imagesource/imagesource.h"
+ #include "../imagesource/imagesource_flatten.h"
+--- photoprint-0.4.2-pre2/gp_cppsupport/gprintersettings.cpp
++++ photoprint-0.4.2-pre2/gp_cppsupport/gprintersettings.cpp
+@@ -13,7 +13,6 @@
+
+ #include <string.h>
+ #include <glib.h>
+-#include <glib/gprintf.h>
+
+ #include "stp_support/stputil.h"
+ #include "gprintersettings.h"
diff --git a/media-gfx/photoprint/photoprint-0.4.2_pre2.ebuild b/media-gfx/photoprint/photoprint-0.4.2_pre2.ebuild
index 4b3239bb83aa..b6ebc2b418f9 100644
--- a/media-gfx/photoprint/photoprint-0.4.2_pre2.ebuild
+++ b/media-gfx/photoprint/photoprint-0.4.2_pre2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoprint/photoprint-0.4.2_pre2.ebuild,v 1.3 2012/05/05 07:00:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoprint/photoprint-0.4.2_pre2.ebuild,v 1.4 2012/06/11 17:23:09 radhermit Exp $
EAPI=4
@@ -30,16 +30,17 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}"/${P}-cups-automagic.patch \
"${FILESDIR}"/${P}-tests.patch \
- "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-underlinking.patch \
+ "${FILESDIR}"/${P}-glib-2.32.patch
# Ships with po/Makefile.in.in from gettext-0.17
# which fails with >=gettext-0.18
- cp "${EROOT}"/usr/share/gettext/po/Makefile.in.in po/
+ sed -i -e "/AM_GNU_GETTEXT_VERSION/s/17/18/" configure.ac || die
eautoreconf
}