summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-10-07 16:36:00 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-10-07 16:36:00 +0000
commitda1770f06e5474afd3c1f0a54078bab024e918e0 (patch)
tree6e07eb9a16b6e27aa7e955c3d50187a560f55da1 /media-gfx/optipng/optipng-0.4.8-r1.ebuild
parentDon't assume GNU ld. Remove src_compile as it falls back to the default. (diff)
downloadgentoo-2-da1770f06e5474afd3c1f0a54078bab024e918e0.tar.gz
gentoo-2-da1770f06e5474afd3c1f0a54078bab024e918e0.tar.bz2
gentoo-2-da1770f06e5474afd3c1f0a54078bab024e918e0.zip
fix #108404, mark stable on x86
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-gfx/optipng/optipng-0.4.8-r1.ebuild')
-rw-r--r--media-gfx/optipng/optipng-0.4.8-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/optipng/optipng-0.4.8-r1.ebuild b/media-gfx/optipng/optipng-0.4.8-r1.ebuild
new file mode 100644
index 000000000000..682b48e8f3b4
--- /dev/null
+++ b/media-gfx/optipng/optipng-0.4.8-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/optipng-0.4.8-r1.ebuild,v 1.1 2005/10/07 16:36:00 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="Find the optimal compression settings for your png files"
+SRC_URI="http://www.cs.toronto.edu/~cosmin/pngtech/optipng/${P}.tar.gz"
+HOMEPAGE="http://www.cs.toronto.edu/~cosmin/pngtech/optipng/"
+
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's!-O2!${CFLAGS}!' scripts/gcc.mak
+ epatch ${FILESDIR}/optipng-zlib-security.diff
+}
+
+src_compile() {
+ emake -C ${S}/src -f ${S}/src/scripts/gcc.mak optipng \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin ${S}/src/optipng
+ dodoc ${S}/doc/{CAVEAT,DESIGN,FEATURES,HISTORY,LICENSE,TODO,USAGE}
+ dohtml ${S}/doc/index.html
+}