summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-24 04:56:49 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-24 04:56:49 +0000
commitab5720158897be6dc8179ca99363617b4b9b4a6d (patch)
tree6d34a8d7ae8f7cb8ff16ecb939408cd796150e80 /media-gfx/inkscape
parent2.2.0_alpha132 version bump. This includes all of the fixes in 2.1.11.21. (diff)
downloadgentoo-2-ab5720158897be6dc8179ca99363617b4b9b4a6d.tar.gz
gentoo-2-ab5720158897be6dc8179ca99363617b4b9b4a6d.tar.bz2
gentoo-2-ab5720158897be6dc8179ca99363617b4b9b4a6d.zip
Move G2CONF to src_configure and fix build with >=boost-1.50.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/ChangeLog5
-rw-r--r--media-gfx/inkscape/inkscape-0.48.3.1.ebuild29
2 files changed, 20 insertions, 14 deletions
diff --git a/media-gfx/inkscape/ChangeLog b/media-gfx/inkscape/ChangeLog
index d458a45795f6..61baeeb387c7 100644
--- a/media-gfx/inkscape/ChangeLog
+++ b/media-gfx/inkscape/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/inkscape
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.184 2012/08/08 16:31:42 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.185 2012/09/24 04:56:49 radhermit Exp $
+
+ 24 Sep 2012; Tim Harder <radhermit@gentoo.org> inkscape-0.48.3.1.ebuild:
+ Move G2CONF to src_configure and fix build with >=boost-1.50.
08 Aug 2012; Andreas K. Huettel <dilfridge@gentoo.org>
inkscape-0.48.2.ebuild, inkscape-0.48.3.1.ebuild:
diff --git a/media-gfx/inkscape/inkscape-0.48.3.1.ebuild b/media-gfx/inkscape/inkscape-0.48.3.1.ebuild
index ee6c292a17e9..cd108546b39a 100644
--- a/media-gfx/inkscape/inkscape-0.48.3.1.ebuild
+++ b/media-gfx/inkscape/inkscape-0.48.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.48.3.1.ebuild,v 1.12 2012/08/08 16:31:43 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.48.3.1.ebuild,v 1.13 2012/09/24 04:56:49 radhermit Exp $
EAPI=4
@@ -9,7 +9,7 @@ PYTHON_USE_WITH="xml"
GCONF_DEBUG=no
-inherit autotools eutils flag-o-matic gnome2 python
+inherit autotools eutils flag-o-matic gnome2 python boost-utils
MY_P="${P/_/}"
S="${WORKDIR}/${MY_P}"
@@ -72,17 +72,7 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
>=dev-util/intltool-0.29"
-pkg_setup() {
- G2CONF="${G2CONF} --without-perl"
- G2CONF="${G2CONF} --enable-poppler-cairo"
- G2CONF="${G2CONF} $(use_with gnome gnome-vfs)"
- G2CONF="${G2CONF} $(use_with inkjar)"
- G2CONF="${G2CONF} $(use_enable lcms)"
- G2CONF="${G2CONF} $(use_enable nls)"
- G2CONF="${G2CONF} $(use_with spell aspell)"
- G2CONF="${G2CONF} $(use_with spell gtkspell)"
- DOCS="AUTHORS ChangeLog NEWS README*"
-}
+DOCS="AUTHORS ChangeLog NEWS README*"
src_prepare() {
gnome2_src_prepare
@@ -96,6 +86,19 @@ src_prepare() {
}
src_configure() {
+ G2CONF="${G2CONF}
+ --without-perl
+ --enable-poppler-cairo
+ $(use_with gnome gnome-vfs)
+ $(use_with inkjar)
+ $(use_enable lcms)
+ $(use_enable nls)
+ $(use_with spell aspell)
+ $(use_with spell gtkspell)"
+
+ # support building with >=boost-1.50
+ append-cppflags -I$(boost-utils_get_includedir)
+
# aliasing unsafe wrt #310393
append-flags -fno-strict-aliasing
gnome2_src_configure