summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Walls <malverian@gentoo.org>2003-03-24 11:48:06 +0000
committerPhilip Walls <malverian@gentoo.org>2003-03-24 11:48:06 +0000
commit0edd8e306fe1aa03c8b6ba1578f71490b8c9db91 (patch)
tree08d263b8dff8616c3c8beda41bfc0052ba8a6644 /media-gfx/gimp
parentdep fix (diff)
downloadgentoo-2-0edd8e306fe1aa03c8b6ba1578f71490b8c9db91.tar.gz
gentoo-2-0edd8e306fe1aa03c8b6ba1578f71490b8c9db91.tar.bz2
gentoo-2-0edd8e306fe1aa03c8b6ba1578f71490b8c9db91.zip
New gimp 1.3 release
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/ChangeLog10
-rw-r--r--media-gfx/gimp/files/digest-gimp-1.3.131
-rw-r--r--media-gfx/gimp/gimp-1.3.13.ebuild94
3 files changed, 104 insertions, 1 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index c0ae919cd501..8245e37d223b 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/gimp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.27 2003/03/10 12:01:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.28 2003/03/24 11:48:06 malverian Exp $
+
+*gimp-1.3.13 (24 Mar 2003)
+
+ 24 Mar 2003; Philip Walls <malverian@gentoo.org> gimp-1.3.13.ebuild,
+ files/digest-gimp-1.3.13 :
+
+ Version bump, check for perl in USE, re-enable gnome-desktop
+ functionality.
*gimp-1.3.12 (24 Feb 2003)
diff --git a/media-gfx/gimp/files/digest-gimp-1.3.13 b/media-gfx/gimp/files/digest-gimp-1.3.13
new file mode 100644
index 000000000000..ff07135424e8
--- /dev/null
+++ b/media-gfx/gimp/files/digest-gimp-1.3.13
@@ -0,0 +1 @@
+MD5 fdc6a57cae53b7f3d01516e6205bdaaf gimp-1.3.13.tar.bz2 10310077
diff --git a/media-gfx/gimp/gimp-1.3.13.ebuild b/media-gfx/gimp/gimp-1.3.13.ebuild
new file mode 100644
index 000000000000..7dbb26bfa63e
--- /dev/null
+++ b/media-gfx/gimp/gimp-1.3.13.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.13.ebuild,v 1.1 2003/03/24 11:48:06 malverian Exp $
+
+IUSE="doc python aalib"
+
+inherit debug flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Development series of Gimp"
+SRC_URI="ftp://ftp.gimp.org/pub/gimp/v1.3/v${PV}/${P}.tar.bz2"
+HOMEPAGE="http://www.gimp.org/"
+SLOT="1.4"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+replace-flags -Os -O2
+
+#libglade
+RDEPEND=">=x11-libs/gtk+-2
+ >=x11-libs/pango-1
+ >=dev-libs/glib-2
+ >=gnome-extra/libgtkhtml-2
+
+ >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/tiff-3.5.7
+ >=media-libs/libart_lgpl-2.3.8-r1
+
+ aalib? ( media-libs/aalib )
+ python? ( >=dev-lang/python-2.2
+ >=dev-python/pygtk-1.99.13 )
+
+ perl? ( dev-lang/perl )"
+
+# media-libs/xpm
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+src_compile() {
+
+ # Strip out -fomit-frame-pointer for k6's
+ is-flag "-march=k6-3" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && strip-flags "-fomit-frame-pointer"
+
+
+ local myconf
+
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+ use python \
+ && myconf="${myconf} --enable-python" \
+ || myconf="${myconf} --disable-python"
+ use perl \
+ && myconf="${myconf} --enable-perl" \
+ || myconf="${myconf} --disable-perl"
+
+ myconf="${myconf} --disable-print"
+
+ #econf --disable-perl --with-gnome-datadir=${D}/usr/share ${myconf} || die
+ #econf --disable-perl ${myconf} --without-gnome-desktop || die
+ # disable gnome-desktop since it breaks sandboxing
+
+ econf ${myconf} || die
+
+ # hack for odd make break
+ touch plug-ins/common/${P}.tar.bz2
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ localstatedir=/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeL* HACKING INSTALL MAINTAINERS NEWS PLUGIN_MAINTAINERS README* TODO*
+}
+
+pkg_postinst() {
+ ewarn "There have been changes to the gtkrc file."
+ ewarn
+ ewarn "You are strongly advised to remove the ~/.gimp-1.3 directory"
+ ewarn "and perform a fresh user installation if you have been"
+ ewarn "running a gimp-1.3 below minor version 11"
+}