summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-13 21:18:58 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-13 21:18:58 +0000
commitf6e2167fc780ed7c7d424e0b85b7d2370029edc1 (patch)
tree98416d77463ac1737f7da1309da43f9c02765eb5 /media-gfx/eog
parentversion bump, remove old (diff)
downloadgentoo-2-f6e2167fc780ed7c7d424e0b85b7d2370029edc1.tar.gz
gentoo-2-f6e2167fc780ed7c7d424e0b85b7d2370029edc1.tar.bz2
gentoo-2-f6e2167fc780ed7c7d424e0b85b7d2370029edc1.zip
Version bump
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx/eog')
-rw-r--r--media-gfx/eog/ChangeLog7
-rw-r--r--media-gfx/eog/eog-3.8.2.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index ddf9795e23e3..c62764d93c9e 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/eog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.304 2013/03/29 23:02:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.305 2013/05/13 21:18:58 pacho Exp $
+
+*eog-3.8.2 (13 May 2013)
+
+ 13 May 2013; Pacho Ramos <pacho@gentoo.org> +eog-3.8.2.ebuild:
+ Version bump
29 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> -eog-3.4.3-r1.ebuild,
-files/eog-3.4.3-libm.patch, -files/eog-3.4.3-require-librsvg-2.36.2.patch,
diff --git a/media-gfx/eog/eog-3.8.2.ebuild b/media-gfx/eog/eog-3.8.2.ebuild
new file mode 100644
index 000000000000..42557e8645fb
--- /dev/null
+++ b/media-gfx/eog/eog-3.8.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-3.8.2.ebuild,v 1.1 2013/05/13 21:18:58 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="http://projects.gnome.org/eog/"
+
+LICENSE="GPL-2+"
+SLOT="1"
+IUSE="+exif +introspection +jpeg lcms +svg tiff xmp"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+REQUIRED_USE="exif? ( jpeg )"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.5.4:3[introspection,X]
+ >=dev-libs/glib-2.31:2
+ >=dev-libs/libxml2-2:2
+ >=dev-libs/libpeas-0.7.4:=[gtk]
+ >=gnome-base/gnome-desktop-2.91.2:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=x11-misc/shared-mime-info-0.20
+
+ x11-libs/gdk-pixbuf:2[jpeg?,tiff?]
+ x11-libs/libX11
+
+ exif? ( >=media-libs/libexif-0.6.14 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ svg? ( >=gnome-base/librsvg-2.36.2:2 )
+ xmp? ( media-libs/exempi:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_with jpeg libjpeg) \
+ $(use_with exif libexif) \
+ $(use_with lcms cms) \
+ $(use_with xmp) \
+ $(use_with svg librsvg) \
+ ITSTOOL=$(type -P true)
+}