summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2004-09-28 21:43:53 +0000
committerScott W Taylor <swtaylor@gentoo.org>2004-09-28 21:43:53 +0000
commitd986a4c0d5249cea9402c451d9438f42101df9d5 (patch)
treea44decb8297c0a004da97558e0e85c251b71d058 /media-gfx/eog
parentBump revision to carry out mozilla.eclass change: don't use typeaheadfind on ... (diff)
downloadgentoo-2-d986a4c0d5249cea9402c451d9438f42101df9d5.tar.gz
gentoo-2-d986a4c0d5249cea9402c451d9438f42101df9d5.tar.bz2
gentoo-2-d986a4c0d5249cea9402c451d9438f42101df9d5.zip
plays nicely with libexif-0.6
Diffstat (limited to 'media-gfx/eog')
-rw-r--r--media-gfx/eog/ChangeLog6
-rw-r--r--media-gfx/eog/eog-2.6.1.ebuild10
-rw-r--r--media-gfx/eog/files/eog-2.6.1-libexif-0.6.patch24
3 files changed, 37 insertions, 3 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index a895a37f81b1..11d60f228cb4 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/eog
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.71 2004/09/17 11:52:11 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.72 2004/09/28 21:43:53 swtaylor Exp $
+
+ 28 Sep 2004; Scott W Taylor <swtaylor@gentoo.org>
+ +files/eog-2.6.1-libexif-0.6.patch, eog-2.6.1.ebuild:
+ now happy with libexif-0.6, same type fix as in 13463
*eog-2.8.0 (17 Sep 2004)
diff --git a/media-gfx/eog/eog-2.6.1.ebuild b/media-gfx/eog/eog-2.6.1.ebuild
index 80777f2c723a..2d1f17463795 100644
--- a/media-gfx/eog/eog-2.6.1.ebuild
+++ b/media-gfx/eog/eog-2.6.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.6.1.ebuild,v 1.8 2004/08/22 19:03:58 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.6.1.ebuild,v 1.9 2004/09/28 21:43:53 swtaylor Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="Eye Of Gnome, an image viewer"
HOMEPAGE="http://www.gnome.org/"
@@ -35,3 +35,9 @@ DEPEND="${RDEPEND}
G2CONF="${G2CONF} $(use_with jpeg libjpeg) $(use_with jpeg libexif)"
DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS HACKING DEPENDS THANKS TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ has_version '>=media-libs/libexif-0.6' && epatch ${FILESDIR}/${P}-libexif-0.6.patch
+}
diff --git a/media-gfx/eog/files/eog-2.6.1-libexif-0.6.patch b/media-gfx/eog/files/eog-2.6.1-libexif-0.6.patch
new file mode 100644
index 000000000000..d8ce462efdca
--- /dev/null
+++ b/media-gfx/eog/files/eog-2.6.1-libexif-0.6.patch
@@ -0,0 +1,24 @@
+--- libeog/eog-info-view.c.orig 2004-09-28 13:41:23.987814033 -0600
++++ libeog/eog-info-view.c 2004-09-28 13:43:09.522474289 -0600
+@@ -246,6 +246,7 @@
+ EogInfoView *view;
+ EogInfoViewPrivate *priv;
+ char *path;
++ char b[1024];
+
+ view = EOG_INFO_VIEW (data);
+ priv = view->priv;
+@@ -255,11 +256,11 @@
+ path = g_hash_table_lookup (priv->id_path_hash, GINT_TO_POINTER (entry->tag));
+
+ if (path != NULL) {
+- set_row_data (store, path, exif_tag_get_name (entry->tag), exif_entry_get_value (entry));
++ set_row_data (store, path, exif_tag_get_name (entry->tag), exif_entry_get_value (entry, b, sizeof(b)));
+ }
+ else {
+ path = set_row_data (store, NULL,
+- exif_tag_get_name (entry->tag), exif_entry_get_value (entry));
++ exif_tag_get_name (entry->tag), exif_entry_get_value (entry, b, sizeof(b)));
+
+ g_hash_table_insert (priv->id_path_hash,
+ GINT_TO_POINTER (entry->tag),