summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-09 16:58:12 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-09 16:58:12 +0000
commit2986564ea8c2cf33eefba0418a44532b037ddb0f (patch)
tree3e8a252ebd23554f9b8299df26fdea37e114f8bc /media-gfx/dawn
parentRemove KDE_MINIMAL not to confuse it with kde4-base eclass variable (diff)
downloadgentoo-2-2986564ea8c2cf33eefba0418a44532b037ddb0f.tar.gz
gentoo-2-2986564ea8c2cf33eefba0418a44532b037ddb0f.tar.bz2
gentoo-2-2986564ea8c2cf33eefba0418a44532b037ddb0f.zip
Respect CXX and LDFLAGS. Fixes bug 331857. Thanks to Diego for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/dawn')
-rw-r--r--media-gfx/dawn/ChangeLog7
-rw-r--r--media-gfx/dawn/dawn-3.88a.ebuild20
2 files changed, 16 insertions, 11 deletions
diff --git a/media-gfx/dawn/ChangeLog b/media-gfx/dawn/ChangeLog
index 9cb9a29e9720..d9aae42e2a31 100644
--- a/media-gfx/dawn/ChangeLog
+++ b/media-gfx/dawn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/dawn
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dawn/ChangeLog,v 1.8 2009/07/06 21:50:56 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dawn/ChangeLog,v 1.9 2010/08/09 16:58:12 xarthisius Exp $
+
+ 09 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org> dawn-3.88a.ebuild:
+ Respect CXX and LDFLAGS. Fixes bug 331857. Thanks to Diego for report.
06 Jul 2009; Jeroen Roovers <jer@gentoo.org> dawn-3.88a.ebuild:
Stable for HPPA too.
diff --git a/media-gfx/dawn/dawn-3.88a.ebuild b/media-gfx/dawn/dawn-3.88a.ebuild
index d88dff629232..621ced95d56a 100644
--- a/media-gfx/dawn/dawn-3.88a.ebuild
+++ b/media-gfx/dawn/dawn-3.88a.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dawn/dawn-3.88a.ebuild,v 1.8 2009/07/06 21:50:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dawn/dawn-3.88a.ebuild,v 1.9 2010/08/09 16:58:12 xarthisius Exp $
#EAPI=0
-inherit eutils versionator
+inherit eutils toolchain-funcs versionator
MYP=${PN}_$(replace_version_separator 1 _)
@@ -31,26 +31,28 @@ src_unpack() {
tar xfz "${DISTDIR}"/${MYP}.taz
cd "${S}"
epatch "${FILESDIR}"/${P}-no-interactive.patch
- sed -i -e '/strip/d' Makefile*in || die "sed Makefile failed"
+ sed -i -e "s/\$(LIB_DIR)/\$(LDFLAGS) &/" \
+ -e '/strip/d' Makefile*in || die
}
src_compile() {
+ tc-export CXX
emake clean
emake guiclean
if ! use X && ! use opengl; then
- ./configure_min || die "configure failed"
+ ./configure_min || die
elif ! use opengl; then
- ./configure_xwin || die "configure_xwin failed"
+ ./configure_xwin || die
else
- ./configure || die "configure failed"
+ ./configure || die
fi
einfo "Compiling"
- emake || die "emake failed"
+ emake || die
}
src_install() {
dodir /usr/bin
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
dodoc README.txt
if use doc; then
pdflatex DOC/G4PRIM_FORMAT_24.tex || die "pdf generation failed"