summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2013-05-22 06:56:32 +0000
committerSlawek Lis <slis@gentoo.org>2013-05-22 06:56:32 +0000
commitf63d06b29b244982ffc50ec52046d93f9da288be (patch)
tree7e26bc96f84134a6ec454acdd65c5a286f9ed900 /media-gfx/assimp/assimp-3.0.1270.ebuild
parentReadding python-3.3 to python_targets (diff)
downloadgentoo-2-f63d06b29b244982ffc50ec52046d93f9da288be.tar.gz
gentoo-2-f63d06b29b244982ffc50ec52046d93f9da288be.tar.bz2
gentoo-2-f63d06b29b244982ffc50ec52046d93f9da288be.zip
Added assimp package (bug #470098)
(Portage version: 2.1.12.1/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'media-gfx/assimp/assimp-3.0.1270.ebuild')
-rw-r--r--media-gfx/assimp/assimp-3.0.1270.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/assimp/assimp-3.0.1270.ebuild b/media-gfx/assimp/assimp-3.0.1270.ebuild
new file mode 100644
index 000000000000..0ae45042d12c
--- /dev/null
+++ b/media-gfx/assimp/assimp-3.0.1270.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/assimp/assimp-3.0.1270.ebuild,v 1.1 2013/05/22 06:56:32 slis Exp $
+
+EAPI=5
+
+inherit cmake-utils versionator
+
+DESCRIPTION="Importer library to import assets from 3D files"
+HOMEPAGE="http://assimp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}--${PV}-source-only.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="+boost samples static tools"
+SLOT="0"
+
+DEPEND="
+ boost? ( dev-libs/boost )
+ samples? ( x11-libs/libX11 virtual/opengl media-libs/freeglut )
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}--${PV}-source-only
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build samples ASSIMP_SAMPLES) \
+ $(cmake-utils_use_build tools ASSIMP_TOOLS) \
+ $(cmake-utils_use_build static STATIC_LIB) \
+ $(cmake-utils_use_enable !boost BOOST_WORKAROUND)
+ )
+
+ cmake-utils_src_configure
+} \ No newline at end of file