summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-02-28 01:06:25 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-02-28 01:06:25 +0000
commitb9bd1a2d4e8a6b3d5e4896b7f558faeab575dc82 (patch)
treef566fef371782639bf594159782183a5d27d607e /mate-base
parentMask mate-base/mate-menus for MATE introduction. (diff)
downloadgentoo-2-b9bd1a2d4e8a6b3d5e4896b7f558faeab575dc82.tar.gz
gentoo-2-b9bd1a2d4e8a6b3d5e4896b7f558faeab575dc82.tar.bz2
gentoo-2-b9bd1a2d4e8a6b3d5e4896b7f558faeab575dc82.zip
New ebuild for mate-base/mate-menus, MATE menu system, implementing the F.D.O cross-desktop spec; imported from the mate-overlay, reviewed and adjusted.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-menus/ChangeLog10
-rw-r--r--mate-base/mate-menus/files/10-xdg-menu-mate6
-rw-r--r--mate-base/mate-menus/mate-menus-1.6.0.ebuild88
-rw-r--r--mate-base/mate-menus/metadata.xml8
4 files changed, 112 insertions, 0 deletions
diff --git a/mate-base/mate-menus/ChangeLog b/mate-base/mate-menus/ChangeLog
new file mode 100644
index 000000000000..2de0815aba1f
--- /dev/null
+++ b/mate-base/mate-menus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for mate-base/mate-menus
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-menus/ChangeLog,v 1.1 2014/02/28 01:06:25 tomwij Exp $
+
+*mate-menus-1.6.0 (28 Feb 2014)
+
+ 28 Feb 2014; Tom Wijsman <TomWij@gentoo.org> +files/10-xdg-menu-mate,
+ +mate-menus-1.6.0.ebuild, +metadata.xml:
+ New ebuild for mate-base/mate-menus, MATE menu system, implementing the F.D.O
+ cross-desktop spec; imported from the mate-overlay, reviewed and adjusted.
diff --git a/mate-base/mate-menus/files/10-xdg-menu-mate b/mate-base/mate-menus/files/10-xdg-menu-mate
new file mode 100644
index 000000000000..06a6a91368e2
--- /dev/null
+++ b/mate-base/mate-menus/files/10-xdg-menu-mate
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if [ -z "$XDG_MENU_PREFIX" ] && [ "$DESKTOP_SESSION" = "mate" ]
+then
+ export XDG_MENU_PREFIX=mate-
+fi
diff --git a/mate-base/mate-menus/mate-menus-1.6.0.ebuild b/mate-base/mate-menus/mate-menus-1.6.0.ebuild
new file mode 100644
index 000000000000..bb285daca1fd
--- /dev/null
+++ b/mate-base/mate-menus/mate-menus-1.6.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-menus/mate-menus-1.6.0.ebuild,v 1.1 2014/02/28 01:06:25 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit autotools gnome2 python-r1
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="debug +introspection python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.15.2:2
+ sys-libs/glibc:2.2
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )
+ python? (
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40:0
+ >=mate-base/mate-common-${MATE_BRANCH}:0
+ sys-devel/gettext:0
+ virtual/pkgconfig:0"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+my_command() {
+ if use python ; then
+ python_foreach_impl run_in_build_dir $@
+ else
+ $@
+ fi
+}
+
+src_configure() {
+ G2CONF="${G2CONF} \
+ $(use_enable python) \
+ $(use_enable introspection)"
+
+ # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
+ # usage checks.
+ if ! use debug ; then
+ G2CONF="${G2CONF} --enable-debug=minimum"
+ fi
+
+ if use python ; then
+ python_copy_sources
+ fi
+
+ my_command gnome2_src_configure
+}
+
+src_compile() {
+ my_command gnome2_src_compile
+}
+
+src_test() {
+ my_command emake check
+}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_install() {
+ my_command gnome2_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/10-xdg-menu-mate"
+}
diff --git a/mate-base/mate-menus/metadata.xml b/mate-base/mate-menus/metadata.xml
new file mode 100644
index 000000000000..dca1781cb290
--- /dev/null
+++ b/mate-base/mate-menus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+</pkgmetadata>