summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2010-09-24 20:35:57 +0000
committerAlin Năstac <mrness@gentoo.org>2010-09-24 20:35:57 +0000
commit74767acd7773a3493b0d2613a3488b416c786cb2 (patch)
tree9e23c8ca8efe965ea7f6f9ed13d933bede72d87b /mail-filter
parentDisable parallel installation until bug #253862 is solved. (diff)
downloadgentoo-2-74767acd7773a3493b0d2613a3488b416c786cb2.tar.gz
gentoo-2-74767acd7773a3493b0d2613a3488b416c786cb2.tar.bz2
gentoo-2-74767acd7773a3493b0d2613a3488b416c786cb2.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/milter-regex/ChangeLog10
-rw-r--r--mail-filter/milter-regex/files/milter-regex-1.8-gentoo.patch129
-rw-r--r--mail-filter/milter-regex/files/milter-regex-1.8-rules.patch12
-rw-r--r--mail-filter/milter-regex/milter-regex-1.8.ebuild63
4 files changed, 212 insertions, 2 deletions
diff --git a/mail-filter/milter-regex/ChangeLog b/mail-filter/milter-regex/ChangeLog
index d6343f605e3a..43d855f98217 100644
--- a/mail-filter/milter-regex/ChangeLog
+++ b/mail-filter/milter-regex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/milter-regex
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/milter-regex/ChangeLog,v 1.7 2009/08/22 23:10:29 mrness Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/milter-regex/ChangeLog,v 1.8 2010/09/24 20:35:56 mrness Exp $
+
+*milter-regex-1.8 (24 Sep 2010)
+
+ 24 Sep 2010; Alin Năstac <mrness@gentoo.org> +milter-regex-1.8.ebuild,
+ +files/milter-regex-1.8-gentoo.patch, +files/milter-regex-1.8-rules.patch:
+ Version bump.
*milter-regex-1.7-r2 (22 Aug 2009)
diff --git a/mail-filter/milter-regex/files/milter-regex-1.8-gentoo.patch b/mail-filter/milter-regex/files/milter-regex-1.8-gentoo.patch
new file mode 100644
index 000000000000..27caafb654c3
--- /dev/null
+++ b/mail-filter/milter-regex/files/milter-regex-1.8-gentoo.patch
@@ -0,0 +1,129 @@
+diff -Nru milter-regex-1.8.orig/Makefile.linux milter-regex-1.8/Makefile.linux
+--- milter-regex-1.8.orig/Makefile.linux 2007-01-11 16:49:52.000000000 +0100
++++ milter-regex-1.8/Makefile.linux 2010-09-24 22:33:19.000000000 +0200
+@@ -6,13 +6,12 @@
+ # see milter-regex.init for an init script for RedHat/Fedora
+ # (contributed by admin@2ka.mipt.ru)
+
+-CFLAGS= -g
+-LDFLAGS= -lmilter -lpthread
++LIBS= -lmilter -lpthread
+
+ all: milter-regex milter-regex.cat8
+
+-milter-regex: milter-regex.o eval.o strlcpy.o y.tab.o
+- gcc -o milter-regex milter-regex.o eval.o strlcpy.o y.tab.o $(LDFLAGS)
++milter-regex: milter-regex.o eval.o strlcpy.o strlcat.o y.tab.o
++ gcc $(LDFLAGS) -o milter-regex milter-regex.o eval.o strlcpy.o strlcat.o y.tab.o $(LIBS)
+
+ milter-regex.o: milter-regex.c eval.h
+ gcc $(CFLAGS) -c milter-regex.c
+@@ -22,7 +21,10 @@
+
+ strlcpy.o: strlcpy.c
+ gcc $(CFLAGS) -c strlcpy.c
+-
++
++strlcat.o: strlcat.c
++ gcc $(CFLAGS) -c strlcat.c
++
+ y.tab.o: y.tab.c
+ gcc $(CFLAGS) -c y.tab.c
+
+diff -Nru milter-regex-1.8.orig/parse.y milter-regex-1.8/parse.y
+--- milter-regex-1.8.orig/parse.y 2007-01-11 16:49:52.000000000 +0100
++++ milter-regex-1.8/parse.y 2010-09-24 22:33:19.000000000 +0200
+@@ -71,6 +71,7 @@
+ } v;
+ int lineno;
+ } YYSTYPE;
++#define YYSTYPE_IS_DECLARED 1
+
+ %}
+
+@@ -481,9 +482,9 @@
+ *r = rs;
+ return (0);
+ }
+-#ifdef __linux__
+- (void)&yyrcsid; /* warning about yyrcsid declared but unused */
+-#endif
++//#ifdef __linux__
++// (void)&yyrcsid; /* warning about yyrcsid declared but unused */
++//#endif
+ }
+
+ static int
+diff -Nru milter-regex-1.8.orig/strlcat.c milter-regex-1.8/strlcat.c
+--- milter-regex-1.8.orig/strlcat.c 1970-01-01 01:00:00.000000000 +0100
++++ milter-regex-1.8/strlcat.c 2010-09-24 22:34:31.000000000 +0200
+@@ -0,0 +1,69 @@
++/* $OpenBSD: strlcat.c,v 1.2 1999/06/17 16:28:58 millert Exp $ */
++
++/*-
++ * Copyright (c) 1998 Todd C. Miller <Todd.Miller@courtesan.com>
++ * All rights reserved.
++ *
++ * Redistribution and use in source and binary forms, with or without
++ * modification, are permitted provided that the following conditions
++ * are met:
++ * 1. Redistributions of source code must retain the above copyright
++ * notice, this list of conditions and the following disclaimer.
++ * 2. Redistributions in binary form must reproduce the above copyright
++ * notice, this list of conditions and the following disclaimer in the
++ * documentation and/or other materials provided with the distribution.
++ * 3. The name of the author may not be used to endorse or promote products
++ * derived from this software without specific prior written permission.
++ *
++ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES,
++ * INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
++ * AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
++ * THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
++ * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
++ * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
++ * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
++ * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
++ * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
++ * ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
++ */
++
++#include <sys/types.h>
++#include <string.h>
++
++/*
++ * Appends src to string dst of size siz (unlike strncat, siz is the
++ * full size of dst, not space left). At most siz-1 characters
++ * will be copied. Always NUL terminates (unless siz <= strlen(dst)).
++ * Returns strlen(src) + MIN(siz, strlen(initial dst)).
++ * If retval >= siz, truncation occurred.
++ */
++size_t
++strlcat(dst, src, siz)
++ char *dst;
++ const char *src;
++ size_t siz;
++{
++ char *d = dst;
++ const char *s = src;
++ size_t n = siz;
++ size_t dlen;
++
++ /* Find the end of dst and adjust bytes left but don't go past end */
++ while (n-- != 0 && *d != '\0')
++ d++;
++ dlen = d - dst;
++ n = siz - dlen;
++
++ if (n == 0)
++ return(dlen + strlen(s));
++ while (*s != '\0') {
++ if (n != 1) {
++ *d++ = *s;
++ n--;
++ }
++ s++;
++ }
++ *d = '\0';
++
++ return(dlen + (s - src)); /* count does not include NUL */
++}
diff --git a/mail-filter/milter-regex/files/milter-regex-1.8-rules.patch b/mail-filter/milter-regex/files/milter-regex-1.8-rules.patch
new file mode 100644
index 000000000000..7103e7e6c59e
--- /dev/null
+++ b/mail-filter/milter-regex/files/milter-regex-1.8-rules.patch
@@ -0,0 +1,12 @@
+diff -Nru milter-regex-1.8.orig/rules milter-regex-1.8/rules
+--- milter-regex-1.8.orig/rules 2007-01-11 16:49:52.000000000 +0100
++++ milter-regex-1.8/rules 2010-09-24 22:11:46.000000000 +0200
+@@ -21,7 +21,7 @@
+ header /From/ /ebay\.com/i
+ header /From/ /sabresfc11@aol\.com/i
+ header /From/ /ictp\.ch/i
+-header /From/ /(sgi.org.uk/ei
++header /From/ /(sgi.org.uk)/ei
+ header /From/ /tera-byte/i
+ header /From/ /google\.com/i
+ header /Subject/ /item/i
diff --git a/mail-filter/milter-regex/milter-regex-1.8.ebuild b/mail-filter/milter-regex/milter-regex-1.8.ebuild
new file mode 100644
index 000000000000..5e2d8e36f6e6
--- /dev/null
+++ b/mail-filter/milter-regex/milter-regex-1.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/milter-regex/milter-regex-1.8.ebuild,v 1.1 2010/09/24 20:35:56 mrness Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A milter-based regular expression filter"
+HOMEPAGE="http://www.benzedrine.cx/milter-regex.html"
+SRC_URI="http://www.benzedrine.cx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )"
+DEPEND="|| ( sys-devel/bison dev-util/yacc )
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-rules.patch # fix a typo in upstream sample rules
+}
+
+src_compile() {
+ emake -f Makefile.linux milter-regex || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe milter-regex
+
+ keepdir /var/run/milter-regex
+
+ insinto /etc/mail
+ newins rules milter-regex.conf
+
+ newconfd "${FILESDIR}"/milter-regex-conf milter-regex
+ newinitd "${FILESDIR}"/milter-regex-init milter-regex
+
+ doman *.8
+}
+
+pkg_preinst() {
+ enewgroup milter
+ # mail-milter/spamass-milter creates milter user with this home directory
+ # For consistency reasons, milter user must be created here with this home directory
+ # even though this package doesn't need a home directory for this user (#280571)
+ enewuser milter -1 -1 /var/lib/milter milter
+
+ fowners milter:milter /var/run/milter-regex
+}
+
+pkg_postinst() {
+ elog "If you're using Sendmail, you'll need to add this to your sendmail.mc:"
+ elog " INPUT_MAIL_FILTER(\`milter-regex', \`S=unix:/var/run/milter-regex/milter-regex.sock, T=S:30s;R:2m')"
+ elog
+ elog "If you are using Postfix, you'll need to add this to your main.cf:"
+ elog " smtpd_milters = unix:/var/run/milter-regex/milter-regex.sock"
+ elog " non_smtpd_milters = unix:/var/run/milter-regex/milter-regex.sock"
+}