summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-09-29 17:26:28 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-09-29 17:26:28 +0000
commit1c46974f0d50f7f2cc5ed93e745f81e6cb89d019 (patch)
tree89b86cb387e6389b49f20f418c854093eb91d7e0 /mail-filter/tmda
parentVersion bumped. Added ~ppc64 which existed in 0.160.0. Removed old ebuild. (M... (diff)
downloadgentoo-2-1c46974f0d50f7f2cc5ed93e745f81e6cb89d019.tar.gz
gentoo-2-1c46974f0d50f7f2cc5ed93e745f81e6cb89d019.tar.bz2
gentoo-2-1c46974f0d50f7f2cc5ed93e745f81e6cb89d019.zip
Revision bump. Fix multipart-handling patch indentation. Closes #65753.
Diffstat (limited to 'mail-filter/tmda')
-rw-r--r--mail-filter/tmda/ChangeLog10
-rw-r--r--mail-filter/tmda/files/digest-tmda-1.0.3-r21
-rw-r--r--mail-filter/tmda/files/tmda-1.0-multipart-handling.patch2
-rw-r--r--mail-filter/tmda/tmda-1.0.3-r2.ebuild60
4 files changed, 71 insertions, 2 deletions
diff --git a/mail-filter/tmda/ChangeLog b/mail-filter/tmda/ChangeLog
index 29f93f294e22..59a1ebdcc733 100644
--- a/mail-filter/tmda/ChangeLog
+++ b/mail-filter/tmda/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-filter/tmda
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/ChangeLog,v 1.8 2004/09/25 19:25:26 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/ChangeLog,v 1.9 2004/09/29 17:26:28 ticho Exp $
+
+*tmda-1.0.3-r2 (29 Sep 2004)
+
+ 29 Sep 2004; Andrej Kacian <ticho@gentoo.org>
+ files/tmda-1.0-multipart-handling.patch, +tmda-1.0.3-r2.ebuild:
+ Revision bump. Fix multipart-handling patch indentation, so it applies
+ cleanly. Thanks to Jesse D. Guardiani <jesse@wingnet.net> for fixing this.
+ Closes 65753.
25 Sep 2004; Andrej Kacian <ticho@gentoo.org>
+files/tmda-1.0-multipart-handling.patch,
diff --git a/mail-filter/tmda/files/digest-tmda-1.0.3-r2 b/mail-filter/tmda/files/digest-tmda-1.0.3-r2
new file mode 100644
index 000000000000..ceb38dfa04d8
--- /dev/null
+++ b/mail-filter/tmda/files/digest-tmda-1.0.3-r2
@@ -0,0 +1 @@
+MD5 e5710270586d52444f5d94ecbb0f318f tmda-1.0.3.tgz 392608
diff --git a/mail-filter/tmda/files/tmda-1.0-multipart-handling.patch b/mail-filter/tmda/files/tmda-1.0-multipart-handling.patch
index cfd6362e222a..8651385bf072 100644
--- a/mail-filter/tmda/files/tmda-1.0-multipart-handling.patch
+++ b/mail-filter/tmda/files/tmda-1.0-multipart-handling.patch
@@ -11,7 +11,7 @@
+ if type(payload) == type([]) and msg.is_multipart():
+ return self._handle_multipart(msg)
+ else:
-+ raise TypeError, 'string payload expected: %s' % type(payload)
++ raise TypeError, 'string payload expected: %s' % type(payload)
+ # AGW end
if self._mangle_from_:
payload = fcre.sub('>From ', payload)
diff --git a/mail-filter/tmda/tmda-1.0.3-r2.ebuild b/mail-filter/tmda/tmda-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..aefe74a515e7
--- /dev/null
+++ b/mail-filter/tmda/tmda-1.0.3-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/tmda-1.0.3-r2.ebuild,v 1.1 2004/09/29 17:26:28 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.2
+ virtual/mta"
+
+SRC_URI="http://www.tmda.net/releases/stable/${P}.tgz"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+src_compile () {
+ # Fix multipart mail handling. (See bug #60367) -ticho
+ epatch ${FILESDIR}/tmda-1.0-multipart-handling.patch
+
+ ./compileall || die "tmda compilation failed"
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+ dohtml -r htdocs/img
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe collectaddys def2html printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins ChangeLog sample.config tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+}