summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-01-06 20:56:59 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-01-06 20:56:59 +0000
commit9ef6af60e4fd27bd0b4769d21d4c2eedad97db2c (patch)
tree6e363750124294cfe25202ac12e40b0a43a46b56 /mail-filter/spamprobe
parentCreated new ebuilds that will replace jdbc3-postgresql package (diff)
downloadgentoo-2-9ef6af60e4fd27bd0b4769d21d4c2eedad97db2c.tar.gz
gentoo-2-9ef6af60e4fd27bd0b4769d21d4c2eedad97db2c.tar.bz2
gentoo-2-9ef6af60e4fd27bd0b4769d21d4c2eedad97db2c.zip
Version bump. Add gif, jpeg and png USE flags.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'mail-filter/spamprobe')
-rw-r--r--mail-filter/spamprobe/ChangeLog9
-rw-r--r--mail-filter/spamprobe/files/digest-spamprobe-1.4d3
-rw-r--r--mail-filter/spamprobe/spamprobe-1.4d.ebuild36
3 files changed, 46 insertions, 2 deletions
diff --git a/mail-filter/spamprobe/ChangeLog b/mail-filter/spamprobe/ChangeLog
index e5d6b5db4686..40879596b05e 100644
--- a/mail-filter/spamprobe/ChangeLog
+++ b/mail-filter/spamprobe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/spamprobe
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/ChangeLog,v 1.19 2006/04/20 18:11:17 slarti Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/ChangeLog,v 1.20 2007/01/06 20:56:59 ticho Exp $
+
+*spamprobe-1.4d (06 Jan 2007)
+
+ 06 Jan 2007; Andrej Kacian <ticho@gentoo.org> +spamprobe-1.4d.ebuild:
+ Version bump. Add gif, jpeg and png USE flags.
20 Apr 2006; Tom Martin <slarti@gentoo.org> spamprobe-1.4b.ebuild:
Marked ~amd64.
diff --git a/mail-filter/spamprobe/files/digest-spamprobe-1.4d b/mail-filter/spamprobe/files/digest-spamprobe-1.4d
new file mode 100644
index 000000000000..95f114788f15
--- /dev/null
+++ b/mail-filter/spamprobe/files/digest-spamprobe-1.4d
@@ -0,0 +1,3 @@
+MD5 5554d6d097346632b16123452283c969 spamprobe-1.4d.tar.gz 262761
+RMD160 4a9e098b92e6900d8b03d7ed5e8d052f2b2e8c56 spamprobe-1.4d.tar.gz 262761
+SHA256 217ce47dcc6f58d8201fbb0a5e2dc38b5b06349fadb1378fb3647ad8a3f44d68 spamprobe-1.4d.tar.gz 262761
diff --git a/mail-filter/spamprobe/spamprobe-1.4d.ebuild b/mail-filter/spamprobe/spamprobe-1.4d.ebuild
new file mode 100644
index 000000000000..2a09d744b252
--- /dev/null
+++ b/mail-filter/spamprobe/spamprobe-1.4d.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/spamprobe-1.4d.ebuild,v 1.1 2007/01/06 20:56:59 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="Fast, intelligent, automatic spam detector using Paul Graham style Bayesian analysis of word counts in spam and non-spam emails."
+HOMEPAGE="http://spamprobe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="berkdb gif jpeg png"
+DEPEND="berkdb? ( >=sys-libs/db-3.2 )
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )"
+
+src_compile() {
+ econf \
+ $(use_with gif) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc README.txt ChangeLog LICENSE.txt
+ emake DESTDIR=${D} install || die
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/*
+}