summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-08-06 23:29:21 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-08-06 23:29:21 +0000
commitc67c4e5d0d1be7d5c0d889b65f92bb65f8e28246 (patch)
tree0a729d4671e370d64bb49c592180197d0f830e0d /mail-filter/postgrey
parentStable on SPARC wrt bug #138779. Also add a patch to fix display corruption ... (diff)
downloadgentoo-2-c67c4e5d0d1be7d5c0d889b65f92bb65f8e28246.tar.gz
gentoo-2-c67c4e5d0d1be7d5c0d889b65f92bb65f8e28246.tar.bz2
gentoo-2-c67c4e5d0d1be7d5c0d889b65f92bb65f8e28246.zip
Version bump. Closes bug #142894, reported by Wolfram Schlich <wschlich at gentoo.org>.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'mail-filter/postgrey')
-rw-r--r--mail-filter/postgrey/ChangeLog8
-rw-r--r--mail-filter/postgrey/files/digest-postgrey-1.232
-rw-r--r--mail-filter/postgrey/files/digest-postgrey-1.273
-rw-r--r--mail-filter/postgrey/postgrey-1.27.ebuild74
4 files changed, 86 insertions, 1 deletions
diff --git a/mail-filter/postgrey/ChangeLog b/mail-filter/postgrey/ChangeLog
index c1621d189431..35cf3dda1bc4 100644
--- a/mail-filter/postgrey/ChangeLog
+++ b/mail-filter/postgrey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/postgrey
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/postgrey/ChangeLog,v 1.19 2006/03/27 06:17:37 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/postgrey/ChangeLog,v 1.20 2006/08/06 23:29:21 ticho Exp $
+
+*postgrey-1.27 (06 Aug 2006)
+
+ 06 Aug 2006; Andrej Kacian <ticho@gentoo.org> +postgrey-1.27.ebuild:
+ Version bump. Closes bug #142894, reported by Wolfram Schlich <wschlich at
+ gentoo.org>.
27 Mar 2006; <ticho@gentoo.org> -postgrey-1.21.ebuild,
-postgrey-1.21-r1.ebuild, postgrey-1.24.ebuild:
diff --git a/mail-filter/postgrey/files/digest-postgrey-1.23 b/mail-filter/postgrey/files/digest-postgrey-1.23
index c71a0382aa83..f838d20a8dff 100644
--- a/mail-filter/postgrey/files/digest-postgrey-1.23
+++ b/mail-filter/postgrey/files/digest-postgrey-1.23
@@ -1 +1,3 @@
MD5 d5214a0dbca6872c5be426d0ffde534d postgrey-1.23.tar.gz 26622
+RMD160 dd24186716b429db044ebdf221f4309f3596bb53 postgrey-1.23.tar.gz 26622
+SHA256 065adc72d30b6d1110bd5f77efcfb480343461c81f5fdd048650d19a640332ea postgrey-1.23.tar.gz 26622
diff --git a/mail-filter/postgrey/files/digest-postgrey-1.27 b/mail-filter/postgrey/files/digest-postgrey-1.27
new file mode 100644
index 000000000000..13470f424f07
--- /dev/null
+++ b/mail-filter/postgrey/files/digest-postgrey-1.27
@@ -0,0 +1,3 @@
+MD5 df3a8b4a0c6ab7e8e5bb5be0de096c47 postgrey-1.27.tar.gz 29221
+RMD160 2e738800c3575e4d54c26e6166781abe44d79b7b postgrey-1.27.tar.gz 29221
+SHA256 b29f9e6a0648ea8cddd6c96ea827bb33b8346605f6d45d6ebb33a1af8470ce42 postgrey-1.27.tar.gz 29221
diff --git a/mail-filter/postgrey/postgrey-1.27.ebuild b/mail-filter/postgrey/postgrey-1.27.ebuild
new file mode 100644
index 000000000000..24aaf16952c9
--- /dev/null
+++ b/mail-filter/postgrey/postgrey-1.27.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/postgrey/postgrey-1.27.ebuild,v 1.1 2006/08/06 23:29:21 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="Postgrey is a Postfix policy server implementing greylisting"
+SRC_URI="http://isg.ee.ethz.ch/tools/${PN}/pub/${P}.tar.gz
+ http://isg.ee.ethz.ch/tools/${PN}/pub/old/${P}.tar.gz"
+HOMEPAGE="http://isg.ee.ethz.ch/tools/postgrey/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/net-server
+ dev-perl/IO-Multiplex
+ dev-perl/BerkeleyDB
+ dev-perl/Net-DNS
+ >=sys-libs/db-4.1
+ >=mail-mta/postfix-2.1.0"
+
+KEYWORDS="~alpha ~amd64 ~x86"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_install () {
+ cd ${S}
+
+ # postgrey data/DB in /var
+ diropts -m0770 -o ${PN} -g ${PN}
+ dodir /var/spool/postfix/${PN}
+ keepdir /var/spool/postfix/${PN}
+ fowners postgrey:postgrey /var/spool/postfix/${PN}
+ fperms 0770 /var/spool/postfix/${PN}
+
+ # postgrey binary
+ dosbin ${PN}
+ dosbin contrib/postgreyreport
+
+ # postgrey data in /etc/postfix
+ insinto /etc/postfix
+ insopts -o root -g ${PN} -m 0640
+ doins postgrey_whitelist_clients postgrey_whitelist_recipients
+
+ # documentation
+ dodoc Changes README
+
+ # init.d + conf.d files
+ newinitd ${FILESDIR}/${PN}.rc.new ${PN}
+ newconfd ${FILESDIR}/${PN}.conf.new ${PN}
+}
+
+pkg_postinst() {
+ echo
+ einfo "To make use of greylisting, please update your postfix config:"
+ einfo
+
+ einfo "In order to start using postgrey, edit /etc/conf.d/postgrey, add following lines"
+ einfo "to smtpd_recipient restrictions setting in your /etc/postfix/main.cf:"
+ einfo "\t\"check_policy_service inet:127.0.0.1:10030\", if you're using TCP socket"
+ einfo "\t\"check_policy_service unix:private/postgrey\", if you're using UNIX socket"
+ einfo "Then, start postgrey and restart postfix."
+
+ einfo "Also remember to make the daemon start durig system boot:"
+ einfo " rc-update add postgrey default"
+ echo
+ ewarn "Read postgrey documentation for more info (perldoc postgrey)."
+ echo
+ epause 5
+}