summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-11-28 09:52:35 +0000
committerTim Harder <radhermit@gentoo.org>2010-11-28 09:52:35 +0000
commite45e6e34eec9ef05e60d019a5126508b386ac080 (patch)
treed5e9719005ebc2c733ae836cc2f34013b2b9cebe /mail-client
parentmask syslog-ng-2 for removal (diff)
downloadgentoo-2-e45e6e34eec9ef05e60d019a5126508b386ac080.tar.gz
gentoo-2-e45e6e34eec9ef05e60d019a5126508b386ac080.tar.bz2
gentoo-2-e45e6e34eec9ef05e60d019a5126508b386ac080.zip
Version bump to new beta release. Drop unused depend.apache eclass.
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/ChangeLog7
-rw-r--r--mail-client/roundcube/roundcube-0.5_beta.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index 2edebc4d9d69..67d756e2afaf 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.34 2010/11/21 13:31:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.35 2010/11/28 09:52:35 radhermit Exp $
+
+*roundcube-0.5_beta (28 Nov 2010)
+
+ 28 Nov 2010; Tim Harder <radhermit@gentoo.org> +roundcube-0.5_beta.ebuild:
+ Version bump to new beta release. Drop unused depend.apache eclass.
21 Nov 2010; Markos Chandras <hwoarang@gentoo.org> roundcube-0.4.2.ebuild:
Stable on amd64 wrt bug #345931
diff --git a/mail-client/roundcube/roundcube-0.5_beta.ebuild b/mail-client/roundcube/roundcube-0.5_beta.ebuild
new file mode 100644
index 000000000000..26eb195cc56d
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.5_beta.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.5_beta.ebuild,v 1.1 2010/11/28 09:52:35 radhermit Exp $
+
+EAPI="2"
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV/_/-}"
+
+inherit webapp depend.php
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap mysql postgres ssl spell"
+
+DEPEND=""
+RDEPEND="|| ( <dev-lang/php-5.3[crypt,iconv,ldap?,pcre,postgres?,session,spl,ssl?,unicode]
+ >=dev-lang/php-5.3[crypt,iconv,ldap?,postgres?,session,ssl?,unicode] )
+ !postgres? ( !mysql? ( dev-lang/php[sqlite] ) )
+ spell? ( dev-lang/php[curl,spell] )
+ dev-php/PEAR-PEAR"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use mysql && require_php_with_any_use mysql mysqli
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ cp config/db.inc.php{.dist,}
+ cp config/main.inc.php{.dist,}
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}