summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Longland <redhatter@gentoo.org>2006-09-23 02:14:20 +0000
committerStuart Longland <redhatter@gentoo.org>2006-09-23 02:14:20 +0000
commit836b497725f2ae8a31e0f6675532d9df2cdaae6b (patch)
tree4df1f34eb96095cd583b6f3c49f9a5685a4c3a0f /mail-client
parentuse mask pcsc-lite (bug #148402) and openct (bug #148405) to allow patch in b... (diff)
downloadgentoo-2-836b497725f2ae8a31e0f6675532d9df2cdaae6b.tar.gz
gentoo-2-836b497725f2ae8a31e0f6675532d9df2cdaae6b.tar.bz2
gentoo-2-836b497725f2ae8a31e0f6675532d9df2cdaae6b.zip
Tweak to language pack installation logic. Fixes bug #147829.
(Portage version: 2.1-r2)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mozilla-thunderbird/ChangeLog7
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.7.ebuild14
2 files changed, 13 insertions, 8 deletions
diff --git a/mail-client/mozilla-thunderbird/ChangeLog b/mail-client/mozilla-thunderbird/ChangeLog
index 662503852f0c..b714b8066017 100644
--- a/mail-client/mozilla-thunderbird/ChangeLog
+++ b/mail-client/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/mozilla-thunderbird
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.131 2006/09/21 14:46:47 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.132 2006/09/23 02:14:20 redhatter Exp $
+
+ 23 Sep 2006; Stuart Longland <redhatter@gentoo.org>
+ mozilla-thunderbird-1.5.0.7.ebuild:
+ Tweak to language pack installation logic. Fixes bug #147829.
+ Thanks to Fabrice Delliaux for the ebuild update.
21 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org>
mozilla-thunderbird-1.5.0.7.ebuild:
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.7.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.7.ebuild
index d9b72bb40024..9963859137b5 100644
--- a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.7.ebuild
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.7.ebuild,v 1.2 2006/09/21 14:46:47 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.7.ebuild,v 1.3 2006/09/23 02:14:20 redhatter Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
-inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib autotools
+inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib autotools mozextension
LANGS="bg ca cs da de el en-GB es-AR es-ES eu fi fr ga-IE gu-IN he hu it ja ko lt mk nb-NO nl pa-IN pl pt-BR ru sk sl sv-SE tr zh-CN"
SHORTLANGS="es-ES ga-IE nb-NO sv-SE"
@@ -34,7 +34,7 @@ RDEPEND=">=www-client/mozilla-launcher-1.39
>=dev-libs/nspr-4.6.1
~sys-devel/autoconf-2.13"
-PDEPEND="crypt? ( x11-plugins/enigmail ) "
+PDEPEND="crypt? ( x11-plugins/enigmail )"
S=${WORKDIR}/mozilla
@@ -72,14 +72,14 @@ linguas() {
}
src_unpack() {
- unpack ${A}
- cd ${S} || die "cd failed"
+ unpack thunderbird-${PV}-source.tar.bz2 ${P}-patches-${PVER}.tar.bz2
linguas
for X in ${linguas}; do
[[ ${X} != en ]] && xpi_unpack thunderbird-${X}-${PV}.xpi
done
+ cd ${S} || die "cd failed"
# Apply our patches
EPATCH_SUFFIX="patch" \
EPATCH_FORCE="yes" \
@@ -184,8 +184,8 @@ src_install() {
if [[ ${LANG} != "" && ${LANG} != "en" ]]; then
ebegin "Setting default locale to ${LANG}"
sed -i "s:pref(\"general.useragent.locale\", \"en-US\"):pref(\"general.useragent.locale\", \"${LANG}\"):" \
- ${D}${MOZILLA_FIVE_HOME}/defaults/pref/thunderbird.js \
- ${D}${MOZILLA_FIVE_HOME}/defaults/pref/thunderbird-l10n.js
+ ${D}${MOZILLA_FIVE_HOME}/defaults/pref/all-thunderbird.js \
+ ${D}${MOZILLA_FIVE_HOME}/defaults/pref/all-l10n.js
eend $? || die "sed failed to change locale"
fi