summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-08 21:25:45 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-08 21:25:45 +0000
commit649f5a73c638270e3a72c0ff24d2417809f5645f (patch)
tree56af7d277787eb893f7d77f6da5afa8658d8effd /mail-client
parentImprove sys-libs/zlib handling. (diff)
downloadgentoo-2-649f5a73c638270e3a72c0ff24d2417809f5645f.tar.gz
gentoo-2-649f5a73c638270e3a72c0ff24d2417809f5645f.tar.bz2
gentoo-2-649f5a73c638270e3a72c0ff24d2417809f5645f.zip
Drop connman support for version to be stabilized as it cannot go to stable yet, remove .la files, drop old.
(Portage version: 2.1.10.22/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/evolution/ChangeLog9
-rw-r--r--mail-client/evolution/evolution-2.32.3-r1.ebuild (renamed from mail-client/evolution/evolution-2.32.2.ebuild)60
-rw-r--r--mail-client/evolution/evolution-2.32.3.ebuild23
3 files changed, 43 insertions, 49 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index 563c584ddeb1..adc55798f47c 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/evolution
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.344 2011/10/05 17:49:25 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.345 2011/10/08 21:25:44 pacho Exp $
+
+*evolution-2.32.3-r1 (08 Oct 2011)
+
+ 08 Oct 2011; Pacho Ramos <pacho@gentoo.org> -evolution-2.32.2.ebuild,
+ evolution-2.32.3.ebuild, +evolution-2.32.3-r1.ebuild:
+ Drop connman support for version to be stabilized as it cannot go to stable
+ yet, remove .la files, drop old.
05 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org>
evolution-2.32.2-r3.ebuild:
diff --git a/mail-client/evolution/evolution-2.32.2.ebuild b/mail-client/evolution/evolution-2.32.3-r1.ebuild
index 8a347d8807d8..7e47aeb01c0e 100644
--- a/mail-client/evolution/evolution-2.32.2.ebuild
+++ b/mail-client/evolution/evolution-2.32.3-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.32.2.ebuild,v 1.9 2011/07/01 17:28:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.32.3-r1.ebuild,v 1.1 2011/10/08 21:25:44 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="python? 2:2.4"
inherit autotools flag-o-matic gnome2 python versionator
@@ -13,12 +14,12 @@ MY_MAJORV=$(get_version_component_range 1-2)
DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
HOMEPAGE="http://www.gnome.org/projects/evolution/"
+SRC_URI="${SRC_URI} http://dev.gentoo.org/~pacho/gnome/${P}-patches.tar.xz"
+
LICENSE="GPL-2 LGPL-2 OPENLDAP"
SLOT="2.0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-# connman is not ready to be stabilized, bug #353440
-IUSE="clutter crypt doc gstreamer kerberos ldap networkmanager python ssl"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="clutter connman crypt doc gstreamer kerberos ldap networkmanager python ssl"
# We need a graphical pinentry frontend to be able to ask for the GPG
# password from inside evolution, bug 160302
@@ -39,7 +40,7 @@ RDEPEND=">=dev-libs/glib-2.25.12:2
>=gnome-extra/gtkhtml-3.31.90:3.14
>=gnome-base/gconf-2:2
dev-libs/atk
- >=dev-libs/libxml2-2.7.3
+ >=dev-libs/libxml2-2.7.3:2
>=net-libs/libsoup-2.4:2.4
>=media-gfx/gtkimageview-1.6
>=x11-misc/shared-mime-info-0.22
@@ -47,6 +48,7 @@ RDEPEND=">=dev-libs/glib-2.25.12:2
>=dev-libs/libgdata-0.4
clutter? ( media-libs/clutter:1.0[gtk] )
+ connman? ( net-misc/connman )
crypt? ( || (
( >=app-crypt/gnupg-2.0.1-r2
${PINENTRY_DEPEND} )
@@ -62,7 +64,6 @@ RDEPEND=">=dev-libs/glib-2.25.12:2
>=dev-libs/nss-3.11 )
!<gnome-extra/evolution-exchange-2.32"
-# connman? ( net-misc/connman )
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.16
@@ -91,7 +92,7 @@ pkg_setup() {
$(use_enable ssl nss)
$(use_enable ssl smime)
$(use_enable networkmanager nm)
- --disable-connman
+ $(use_enable connman)
$(use_enable gstreamer audio-inline)
--disable-profiling
--disable-pst-import
@@ -121,10 +122,10 @@ pkg_setup() {
fi
# NM and connman support cannot coexist
-# if use networkmanager && use connman ; then
-# ewarn "It is not possible to enable both ConnMan and NetworkManager, disabling connman..."
-# G2CONF="${G2CONF} --disable-connman"
-# fi
+ if use networkmanager && use connman ; then
+ ewarn "It is not possible to enable both ConnMan and NetworkManager, disabling connman..."
+ G2CONF="${G2CONF} --disable-connman"
+ fi
python_set_active_version 2
}
@@ -137,6 +138,15 @@ src_prepare() {
# Fix invalid use of la file in contact-editor, upstream bug #635002
epatch "${FILESDIR}/${PN}-2.32.0-wrong-lafile-usage.patch"
+ # Fix compilation with --disable-smime, bug #356471
+ epatch "${FILESDIR}/${PN}-2.32.2-smime-fix.patch"
+
+ # Fix desktop file to work with latest glib
+ epatch "${FILESDIR}/${PN}-2.32.2-mime-handler.patch"
+
+ # Apply multiple backports from master fixing important bugs
+ epatch "${WORKDIR}/${P}-patches"/*.patch
+
# Use NSS/NSPR only if 'ssl' is enabled.
if use ssl ; then
sed -e 's|mozilla-nss|nss|' \
@@ -145,10 +155,6 @@ src_prepare() {
fi
# Fix compilation flags crazyness
- sed -e 's/CFLAGS="$CFLAGS $WARNING_FLAGS"//' \
- -i configure.ac configure || die "sed 1 failed"
-
- # Fix compilation flags crazyness
sed -e 's/-D.*_DISABLE_DEPRECATED//' \
-i configure.ac configure || die "sed 1 failed"
@@ -156,23 +162,19 @@ src_prepare() {
eautoreconf
}
-src_install() {
- gnome2_src_install
-
- find "${ED}"/usr/$(get_libdir)/evolution/${MY_MAJORV}/plugins \
- -name "*.la" -delete || die "la files removal failed 1"
- find "${ED}"/usr/$(get_libdir)/evolution/${MY_MAJORV}/modules \
- -name "*.la" -delete || die "la files removal failed 2"
-}
-
pkg_postinst() {
gnome2_pkg_postinst
- elog "To change the default browser if you are not using GNOME, do:"
- elog "gconftool-2 --set /desktop/gnome/url-handlers/http/command -t string 'firefox %s'"
- elog "gconftool-2 --set /desktop/gnome/url-handlers/https/command -t string 'firefox %s'"
+ elog "To change the default browser if you are not using GNOME, edit"
+ elog "~/.local/share/applications/mimeapps.list so it includes the"
+ elog "following content:"
+ elog ""
+ elog "[Default Applications]"
+ elog "x-scheme-handler/http=firefox.desktop"
+ elog "x-scheme-handler/https=firefox.desktop"
elog ""
- elog "Replace 'firefox %s' with which ever browser you use."
+ elog "(replace firefox.desktop with the name of the appropriate .desktop"
+ elog "file from /usr/share/applications if you use a different browser)."
elog ""
elog "Junk filters are now a run-time choice. You will get a choice of"
elog "bogofilter or spamassassin based on which you have installed"
diff --git a/mail-client/evolution/evolution-2.32.3.ebuild b/mail-client/evolution/evolution-2.32.3.ebuild
index b4009e092e30..b23837980db4 100644
--- a/mail-client/evolution/evolution-2.32.3.ebuild
+++ b/mail-client/evolution/evolution-2.32.3.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.32.3.ebuild,v 1.1 2011/06/19 21:35:48 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.32.3.ebuild,v 1.2 2011/10/08 21:25:45 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="python? 2:2.4"
inherit autotools flag-o-matic gnome2 python versionator
@@ -18,7 +19,7 @@ SRC_URI="${SRC_URI} http://dev.gentoo.org/~pacho/gnome/${P}-patches.tar.xz"
LICENSE="GPL-2 LGPL-2 OPENLDAP"
SLOT="2.0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="clutter connman crypt doc gstreamer kerberos ldap networkmanager python ssl"
+IUSE="clutter crypt doc gstreamer kerberos ldap networkmanager python ssl"
# We need a graphical pinentry frontend to be able to ask for the GPG
# password from inside evolution, bug 160302
@@ -47,7 +48,6 @@ RDEPEND=">=dev-libs/glib-2.25.12:2
>=dev-libs/libgdata-0.4
clutter? ( media-libs/clutter:1.0[gtk] )
- connman? ( net-misc/connman )
crypt? ( || (
( >=app-crypt/gnupg-2.0.1-r2
${PINENTRY_DEPEND} )
@@ -91,7 +91,7 @@ pkg_setup() {
$(use_enable ssl nss)
$(use_enable ssl smime)
$(use_enable networkmanager nm)
- $(use_enable connman)
+ --disable-connman
$(use_enable gstreamer audio-inline)
--disable-profiling
--disable-pst-import
@@ -120,12 +120,6 @@ pkg_setup() {
--without-nss-includes"
fi
- # NM and connman support cannot coexist
- if use networkmanager && use connman ; then
- ewarn "It is not possible to enable both ConnMan and NetworkManager, disabling connman..."
- G2CONF="${G2CONF} --disable-connman"
- fi
-
python_set_active_version 2
}
@@ -161,15 +155,6 @@ src_prepare() {
eautoreconf
}
-src_install() {
- gnome2_src_install
-
- find "${ED}"/usr/$(get_libdir)/evolution/${MY_MAJORV}/plugins \
- -name "*.la" -delete || die "la files removal failed 1"
- find "${ED}"/usr/$(get_libdir)/evolution/${MY_MAJORV}/modules \
- -name "*.la" -delete || die "la files removal failed 2"
-}
-
pkg_postinst() {
gnome2_pkg_postinst