summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-09-11 08:08:54 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-09-11 08:08:54 +0000
commit5a81f808ac8e8edc95e2cd2eebb3afd76dc6148e (patch)
tree6e4ffd51efab6b6740b130725389af3823c53dbf /mail-client
parentVersion bump. (diff)
downloadgentoo-2-5a81f808ac8e8edc95e2cd2eebb3afd76dc6148e.tar.gz
gentoo-2-5a81f808ac8e8edc95e2cd2eebb3afd76dc6148e.tar.bz2
gentoo-2-5a81f808ac8e8edc95e2cd2eebb3afd76dc6148e.zip
Add a patch to fix mutt with dev-libs/cyrus-sasl-2.1.22. Fixes bug #146696. Thanks to Sebastian <sebastian_ml@gmx.net>
(Portage version: 2.1.1)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt/ChangeLog9
-rw-r--r--mail-client/mutt/files/digest-mutt-1.5.13-r16
-rw-r--r--mail-client/mutt/files/mutt-1.5.13-sasl.patch74
-rw-r--r--mail-client/mutt/mutt-1.5.13-r1.ebuild161
4 files changed, 249 insertions, 1 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index b720001b0ae4..a887d4a4d603 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/mutt
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.88 2006/09/04 08:52:41 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.89 2006/09/11 08:08:54 ferdy Exp $
+
+*mutt-1.5.13-r1 (11 Sep 2006)
+
+ 11 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org>
+ +files/mutt-1.5.13-sasl.patch, +mutt-1.5.13-r1.ebuild:
+ Add a patch to fix mutt with dev-libs/cyrus-sasl-2.1.22. Fixes bug #146696.
+ Thanks to Sebastian <sebastian_ml@gmx.net>
04 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org> -mutt-1.5.11.ebuild:
Remove mutt-1.5.11 wrt bug #140514
diff --git a/mail-client/mutt/files/digest-mutt-1.5.13-r1 b/mail-client/mutt/files/digest-mutt-1.5.13-r1
new file mode 100644
index 000000000000..d0fb93f3637b
--- /dev/null
+++ b/mail-client/mutt/files/digest-mutt-1.5.13-r1
@@ -0,0 +1,6 @@
+MD5 b4fccb735c0277bc6c659eb287d65b13 mutt-1.5.13-gentoo-patches.tar.bz2 53418
+RMD160 67274bef651c1c78d1e6878d8bb17316abf9d30e mutt-1.5.13-gentoo-patches.tar.bz2 53418
+SHA256 b0a8737ab8ec42b5f071eb08356a2572c49f98c73c3bf42396fd481c4650ef1d mutt-1.5.13-gentoo-patches.tar.bz2 53418
+MD5 456a138680a6726f14983cb3e9ff4e22 mutt-1.5.13.tar.gz 3442681
+RMD160 9327b7f928aad78a20c2395629113ac2519bb945 mutt-1.5.13.tar.gz 3442681
+SHA256 e0481690c0caf23b5c88359b2dbac70308f8f138663e8fee482b163562fe8da9 mutt-1.5.13.tar.gz 3442681
diff --git a/mail-client/mutt/files/mutt-1.5.13-sasl.patch b/mail-client/mutt/files/mutt-1.5.13-sasl.patch
new file mode 100644
index 000000000000..7cefa2ee1a85
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.13-sasl.patch
@@ -0,0 +1,74 @@
+
+# HG changeset patch
+# User Brendan Cully <brendan@kublai.com>
+# Date 1157736633 0
+# Node ID 4b8ef24b823e8295d58f599cb1d7014270dec064
+# Parent 6fd5fb51a9dc102a1b39dcda26201c60215ee954
+Don't send protocol garbage to sasl_decode64 during POP authentication.
+Also enable SASL plaintext: $foo_authenticators is a more general solution.
+
+--- a/mutt_sasl.c Fri Sep 08 15:45:57 2006 +0000
++++ b/mutt_sasl.c Fri Sep 08 17:30:33 2006 +0000
+@@ -221,15 +221,10 @@ int mutt_sasl_client_new (CONNECTION* co
+ return -1;
+ }
+
+- /* set security properties. We use NOPLAINTEXT globally, since we can
+- * just fall back to LOGIN in the IMAP case anyway. If that doesn't
+- * work for POP, we can make it a flag or move this code into
+- * imap/auth_sasl.c */
+ memset (&secprops, 0, sizeof (secprops));
+ /* Work around a casting bug in the SASL krb4 module */
+ secprops.max_ssf = 0x7fff;
+ secprops.maxbufsize = M_SASL_MAXBUF;
+- secprops.security_flags |= SASL_SEC_NOPLAINTEXT;
+ if (sasl_setprop (*saslconn, SASL_SEC_PROPS, &secprops) != SASL_OK)
+ {
+ dprint (1, (debugfile,
+--- a/pop_auth.c Fri Sep 08 15:45:57 2006 +0000
++++ b/pop_auth.c Fri Sep 08 17:30:33 2006 +0000
+@@ -46,8 +46,7 @@ static pop_auth_res_t pop_auth_sasl (POP
+ char inbuf[LONG_STRING];
+ const char* mech;
+ const char *pc = NULL;
+- unsigned int len, olen;
+- unsigned char client_start;
++ unsigned int len, olen, client_start;
+
+ if (mutt_sasl_client_new (pop_data->conn, &saslconn) < 0)
+ {
+@@ -74,7 +73,7 @@ static pop_auth_res_t pop_auth_sasl (POP
+ return POP_A_UNAVAIL;
+ }
+
+- client_start = (olen > 0);
++ client_start = olen;
+
+ mutt_message _("Authenticating (SASL)...");
+
+@@ -93,11 +92,11 @@ static pop_auth_res_t pop_auth_sasl (POP
+ return POP_A_SOCKET;
+ }
+
+- if (rc != SASL_CONTINUE)
++ if (!client_start && rc != SASL_CONTINUE)
+ break;
+
+ if (!mutt_strncmp (inbuf, "+ ", 2)
+- && sasl_decode64 (inbuf, strlen (inbuf), buf, LONG_STRING-1, &len) != SASL_OK)
++ && sasl_decode64 (inbuf+2, strlen (inbuf+2), buf, LONG_STRING-1, &len) != SASL_OK)
+ {
+ dprint (1, (debugfile, "pop_auth_sasl: error base64-decoding server response.\n"));
+ goto bail;
+@@ -112,7 +111,10 @@ static pop_auth_res_t pop_auth_sasl (POP
+ mutt_sasl_interact (interaction);
+ }
+ else
++ {
++ olen = client_start;
+ client_start = 0;
++ }
+
+ if (rc != SASL_CONTINUE && (olen == 0 || rc != SASL_OK))
+ break;
+
diff --git a/mail-client/mutt/mutt-1.5.13-r1.ebuild b/mail-client/mutt/mutt-1.5.13-r1.ebuild
new file mode 100644
index 000000000000..ed9ece368925
--- /dev/null
+++ b/mail-client/mutt/mutt-1.5.13-r1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.13-r1.ebuild,v 1.1 2006/09/11 08:08:54 ferdy Exp $
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="a small but very powerful text-based mail client"
+HOMEPAGE="http://www.mutt.org"
+SRC_URI="ftp://ftp.mutt.org/mutt/devel/${P}.tar.gz
+ !vanilla? (
+ mirror://gentoo/${P}-gentoo-patches.tar.bz2
+ )"
+IUSE="berkdb buffysize cjk crypt debug gdbm gnutls gpgme idn imap mbox nls nntp pop sasl smime ssl vanilla"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+RDEPEND="nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.2
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( berkdb? ( >=sys-libs/db-4 ) )
+ imap? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ pop? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ idn? ( net-dns/libidn )
+ gpgme? ( >=app-crypt/gpgme-0.9.0 )
+ smime? ( >=dev-libs/openssl-0.9.6 )
+ app-misc/mime-types"
+DEPEND="${RDEPEND}
+ net-mail/mailbase"
+
+PATCHDIR="${WORKDIR}"/${P}-gentoo-patches
+
+src_unpack() {
+ unpack ${A} && cd "${S}" || die "unpack failed"
+
+ # Fix for bug #146696
+ epatch "${FILESDIR}"/${P}-sasl.patch
+
+ if ! use vanilla ; then
+ if ! use nntp ; then
+ rm "${PATCHDIR}"/07-vvv.nntp-gentoo.patch
+ rm "${PATCHDIR}"/08-mixmaster_nntp.patch
+ fi
+
+ for p in "${PATCHDIR}"/*.patch ; do
+ epatch "${p}"
+ done
+
+ AT_M4DIR="m4" eautoreconf
+ else
+ eautoconf
+ fi
+}
+
+src_compile() {
+ declare myconf="
+ $(use_enable nls) \
+ $(use_enable gpgme) \
+ $(use_enable imap) \
+ $(use_enable pop) \
+ $(use_enable crypt pgp) \
+ $(use_enable smime) \
+ $(use_enable cjk default-japanese) \
+ $(use_enable debug) \
+ $(use_with idn) \
+ --with-curses \
+ --sysconfdir=/etc/${PN} \
+ --with-docdir=/usr/share/doc/${PN}-${PVR} \
+ --with-regex \
+ --disable-fcntl --enable-flock \
+ --enable-nfs-fix --enable-external-dotlock \
+ --with-mixmaster"
+
+ # See Bug #22787
+ unset WANT_AUTOCONF_2_5 WANT_AUTOCONF
+
+ # mutt prioritizes gdbm over bdb, so we will too.
+ # hcache feature requires at least one database is in USE.
+ if use gdbm; then
+ myconf="${myconf} --enable-hcache --with-gdbm --without-bdb"
+ elif use berkdb; then
+ myconf="${myconf} --enable-hcache --with-bdb --without-gdbm"
+ else
+ myconf="${myconf} --disable-hcache --without-gdbm --without-bdb"
+ fi
+
+ # there's no need for gnutls, ssl or sasl without either pop or imap.
+ # in fact mutt's configure will bail if you do:
+ # --without-pop --without-imap --with-ssl
+ if use pop || use imap; then
+ if use gnutls; then
+ myconf="${myconf} --with-gnutls"
+ elif use ssl; then
+ myconf="${myconf} --with-ssl"
+ fi
+ # not sure if this should be mutually exclusive with the other two
+ myconf="${myconf} $(use_with sasl)"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl --without-sasl"
+ fi
+
+ # See Bug #11170
+ case ${ARCH} in
+ alpha|ppc) replace-flags "-O[3-9]" "-O2" ;;
+ esac
+
+ if use buffysize; then
+ ewarn "USE=buffy-size is just a workaround. Disable it if you don't need it."
+ myconf="${myconf} --enable-buffy-size"
+ fi
+
+ if use mbox; then
+ myconf="${myconf} --with-mailpath=/var/spool/mail"
+ else
+ myconf="${myconf} --with-homespool=Maildir"
+ fi
+
+ if ! use vanilla; then
+ # rr.compressed patch
+ myconf="${myconf} --enable-compressed"
+
+ # nntp patch
+ myconf="${myconf} $(use_enable nntp)"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ find ${D}/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ if use mbox; then
+ insinto /etc/mutt
+ newins ${FILESDIR}/Muttrc.mbox Muttrc
+ else
+ insinto /etc/mutt
+ doins ${FILESDIR}/Muttrc
+ fi
+
+ # A newer file is provided by app-misc/mime-types. So we link it.
+ rm ${D}/etc/${PN}/mime.types
+ dosym /etc/mime.types /etc/${PN}/mime.types
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you are new to mutt you may want to take a look at"
+ einfo "the Gentoo QuickStart Guide to Mutt E-Mail:"
+ einfo " http://www.gentoo.org/doc/en/guide-to-mutt.xml"
+ echo
+}