summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-06-12 07:29:15 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-06-12 07:29:15 +0000
commit1fd2d7083419b4a800e25a0be3f712618fa8d51a (patch)
tree78adff2900d909c80cf1d9d6eb743a5cea89f27f /mail-client
parentversion bump, bug 319161 (diff)
downloadgentoo-2-1fd2d7083419b4a800e25a0be3f712618fa8d51a.tar.gz
gentoo-2-1fd2d7083419b4a800e25a0be3f712618fa8d51a.tar.bz2
gentoo-2-1fd2d7083419b4a800e25a0be3f712618fa8d51a.zip
version bump, bug 319161
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail-perl/ChangeLog7
-rw-r--r--mail-client/claws-mail-perl/claws-mail-perl-0.9.18.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/mail-client/claws-mail-perl/ChangeLog b/mail-client/claws-mail-perl/ChangeLog
index 13a5653b9d06..c399f0dc1d1d 100644
--- a/mail-client/claws-mail-perl/ChangeLog
+++ b/mail-client/claws-mail-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/claws-mail-perl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/ChangeLog,v 1.41 2010/05/11 17:51:06 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/ChangeLog,v 1.42 2010/06/12 07:29:15 fauli Exp $
+
+*claws-mail-perl-0.9.18 (12 Jun 2010)
+
+ 12 Jun 2010; <fauli@gentoo.org> +claws-mail-perl-0.9.18.ebuild:
+ version bump, bug 319161
11 May 2010; Brent Baude <ranger@gentoo.org>
claws-mail-perl-0.9.17.ebuild:
diff --git a/mail-client/claws-mail-perl/claws-mail-perl-0.9.18.ebuild b/mail-client/claws-mail-perl/claws-mail-perl-0.9.18.ebuild
new file mode 100644
index 000000000000..f99b3e50c06a
--- /dev/null
+++ b/mail-client/claws-mail-perl/claws-mail-perl-0.9.18.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/claws-mail-perl-0.9.18.ebuild,v 1.1 2010/06/12 07:29:15 fauli Exp $
+
+MY_P="${PN#claws-mail-}_plugin-${PV}"
+
+DESCRIPTION="Plugin to use perl to write filtering rules"
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.7.6
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ pod2man --section=1 --release=${PV} --name=cm_perl cm_perl.pod > cm_perl.1
+
+ cd tools
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doman cm_perl.1
+
+ cd tools
+ exeinto /usr/lib/claws-mail/tools
+ doexe *.pl
+
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ echo
+ elog "The documentation for this plugin is contained in a manpage."
+ elog "You can access it with 'man cm_perl'"
+ echo
+}