summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-04-29 20:57:25 +0000
committerPacho Ramos <pacho@gentoo.org>2010-04-29 20:57:25 +0000
commit158f80f82fa892699ce257f4735246188326d6bf (patch)
treef2f2a2c9b91f2085b6e996783f8ea9249c82ab66 /mail-client
parentApply a patch to set version properly and, then, allow us to use a more futur... (diff)
downloadgentoo-2-158f80f82fa892699ce257f4735246188326d6bf.tar.gz
gentoo-2-158f80f82fa892699ce257f4735246188326d6bf.tar.bz2
gentoo-2-158f80f82fa892699ce257f4735246188326d6bf.zip
Use again fedora patch for compatibility with e-d-s-2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mail-notification/ChangeLog8
-rw-r--r--mail-client/mail-notification/files/mail-notification-5.4-e-d-s.patch102
-rw-r--r--mail-client/mail-notification/mail-notification-5.4-r3.ebuild6
3 files changed, 112 insertions, 4 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index 4e4e42ca1d12..788359efd1e2 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.91 2010/04/21 20:39:04 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.92 2010/04/29 20:57:25 pacho Exp $
+
+ 29 Apr 2010; Pacho Ramos <pacho@gentoo.org>
+ mail-notification-5.4-r3.ebuild, +files/mail-notification-5.4-e-d-s.patch:
+ Use again fedora patch for compatibility with e-d-s-2.30 as
+ evolution-data-server versioning is now fixed. Thanks to Matthew Barnes
+ for his help on this.
*mail-notification-5.4-r3 (21 Apr 2010)
diff --git a/mail-client/mail-notification/files/mail-notification-5.4-e-d-s.patch b/mail-client/mail-notification/files/mail-notification-5.4-e-d-s.patch
new file mode 100644
index 000000000000..073818afed2d
--- /dev/null
+++ b/mail-client/mail-notification/files/mail-notification-5.4-e-d-s.patch
@@ -0,0 +1,102 @@
+--- build/src/mn-evolution-server.c.orig 2008-09-30 15:30:07.756216978 +0200
++++ build/src/mn-evolution-server.c 2008-09-30 15:30:49.950220711 +0200
+@@ -27,6 +27,7 @@
+ #include <stdio.h>
+ #include <libintl.h>
+ #include <gobject/gvaluecollector.h>
++#include <libedataserver/eds-version.h>
+ #include <camel/camel-folder.h>
+ #include <mail/em-folder-view.h>
+ #include <mail/em-format.h>
+@@ -595,7 +596,12 @@
+
+ for (i = 0; i < summary->len; i++)
+ {
++#if EDS_CHECK_VERSION(2,23,5)
++ char *uid = summary->pdata[i];
++ CamelMessageInfo *info = camel_folder_get_message_info(folder, uid);
++#else
+ CamelMessageInfo *info = summary->pdata[i];
++#endif
+
+ if ((camel_message_info_flags(info) & CAMEL_MESSAGE_SEEN) == 0)
+ g_ptr_array_add(*ret, self_camel_message_info_to_dbus_struct(info));
+--- build/src/mn-evolution-folder-tree-server.c.evolution 2010-02-01 10:00:12.128683776 -0500
++++ build/src/mn-evolution-folder-tree-server.c 2010-02-01 10:02:32.809697243 -0500
+@@ -26,5 +26,8 @@
+ #include <dbus/dbus.h>
++#include <libedataserver/eds-version.h>
++#if !EDS_CHECK_VERSION(2,29,0)
+ #include <mail/mail-component.h>
++#endif
+ #include <mail/em-folder-tree.h>
+ #include "mn-evolution-plugin.h"
+ #include "mn-evolution.h"
+@@ -396,7 +399,11 @@ mn_evolution_folder_tree_server_construc
+
++#if EDS_CHECK_VERSION(2,29,0)
++ selfp->tree = em_folder_tree_new();
++#else
+ EMFolderTreeModel *model;
+
+ model = mail_component_peek_tree_model(mail_component_peek());
+ selfp->tree = em_folder_tree_new_with_model(model);
++#endif
+
+ selfp->plug = gtk_plug_new((GdkNativeWindow) selfp->id);
+--- build/src/mn-evolution-server.c.evolution 2010-02-01 10:06:36.484698060 -0500
++++ build/src/mn-evolution-server.c 2010-02-01 10:09:01.946682081 -0500
+@@ -28,9 +28,14 @@
+ #include <gobject/gvaluecollector.h>
+ #include <libedataserver/eds-version.h>
+ #include <camel/camel-folder.h>
++#if EDS_CHECK_VERSION(2,29,0)
++#include <shell/e-shell.h>
++#include <mail/e-mail-browser.h>
++#else
+ #include <mail/em-folder-view.h>
+ #include <mail/em-format.h>
+ #include <mail/em-message-browser.h>
++#endif
+ #include <mail/em-utils.h>
+ #include <mail/mail-session.h>
+ #include <mail/mail-tools.h>
+@@ -568,6 +573,19 @@ mn_evolution_server_open_message (MNEvol
+ folder = self_lookup_folder(folder_uri, err);
+ if (folder)
+ {
++#if EDS_CHECK_VERSION(2,29,0)
++ EShell *shell;
++ EShellBackend *shell_backend;
++ GtkWidget *browser;
++
++ shell = e_shell_get_default ();
++ shell_backend = e_shell_get_backend_by_name (shell, "mail");
++
++ browser = e_mail_browser_new (shell_backend);
++ e_mail_reader_set_folder (E_MAIL_READER (browser), folder, folder_uri);
++ e_mail_reader_set_message (E_MAIL_READER (browser), message_uid);
++ gtk_widget_show (browser);
++#else
+ GtkWidget *browser;
+
+ /* modelled after Evolution's handleuri_got_folder() */
+@@ -578,6 +596,7 @@ mn_evolution_server_open_message (MNEvol
+ em_folder_view_set_folder((EMFolderView *) browser, folder, folder_uri);
+ em_folder_view_set_message((EMFolderView *) browser, message_uid, FALSE);
+ gtk_widget_show(((EMMessageBrowser *) browser)->window);
++#endif
+
+ camel_object_unref(folder);
+ }
+--- src/mn-evolution-plugin.c.evolution 2008-05-22 11:45:35.000000000 -0400
++++ src/mn-evolution-plugin.c 2010-02-01 11:52:06.141664757 -0500
+@@ -204,7 +204,7 @@ connect_to_session_bus (void)
+ }
+
+ int
+-e_plugin_lib_enable (EPluginLib *ep, int enable)
++e_plugin_lib_enable (EPlugin *ep, int enable)
+ {
+ static gboolean enabled = FALSE;
+ GError *err = NULL;
diff --git a/mail-client/mail-notification/mail-notification-5.4-r3.ebuild b/mail-client/mail-notification/mail-notification-5.4-r3.ebuild
index c9202bb09790..4c560d7f074b 100644
--- a/mail-client/mail-notification/mail-notification-5.4-r3.ebuild
+++ b/mail-client/mail-notification/mail-notification-5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.4-r3.ebuild,v 1.1 2010/04/21 20:39:04 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.4-r3.ebuild,v 1.2 2010/04/29 20:57:25 pacho Exp $
EAPI=1
@@ -60,8 +60,8 @@ src_unpack() {
# We are not Ubuntu, and I suspect that this is the cause of #215281
epatch "${FILESDIR}/${P}-remove-ubuntu-special-case.patch"
- # Make it work ok with eds-2.24
- epatch "${FILESDIR}/${P}-e-d-s-2.24.patch"
+ # Make it work ok with eds-2.24 and 2.29
+ epatch "${FILESDIR}/${P}-e-d-s.patch"
# Fix gtkhtml depend to solve building against evo-2.28, see bug #293374
epatch "${FILESDIR}/${P}-evolution-gtkhtml.patch"