summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2006-06-05 16:23:02 +0000
committerAkinori Hattori <hattya@gentoo.org>2006-06-05 16:23:02 +0000
commitdbdc3bf59ba22069bcf14bd9d440e38b47803663 (patch)
tree86897fd2f2f9c6fe5b363f0ad5591eccda3234c2 /mail-client/sylpheed/sylpheed-2.2.5.ebuild
parentadd helpful notice for users #134482 by David Grant (diff)
downloadgentoo-2-dbdc3bf59ba22069bcf14bd9d440e38b47803663.tar.gz
gentoo-2-dbdc3bf59ba22069bcf14bd9d440e38b47803663.tar.bz2
gentoo-2-dbdc3bf59ba22069bcf14bd9d440e38b47803663.zip
new upstream release.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'mail-client/sylpheed/sylpheed-2.2.5.ebuild')
-rw-r--r--mail-client/sylpheed/sylpheed-2.2.5.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/mail-client/sylpheed/sylpheed-2.2.5.ebuild b/mail-client/sylpheed/sylpheed-2.2.5.ebuild
new file mode 100644
index 000000000000..7ff40da56f67
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.2.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.2.5.ebuild,v 1.1 2006/06/05 16:23:02 hattya Exp $
+
+inherit eutils
+
+IUSE="crypt gnome ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.good-day.net/"
+SRC_URI="http://sylpheed.good-day.net/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ia64 ppc ~ppc64 sparc x86"
+SLOT="0"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-2.*.diff
+ automake
+
+}
+
+src_compile() {
+
+ econf \
+ `use_enable crypt gpgme` \
+ `use_enable ipv6` \
+ `use_enable ldap` \
+ `use_enable nls` \
+ `use_enable pda jpilot` \
+ `use_enable spell gtkspell` \
+ `use_enable ssl` \
+ `use_enable xface compface` \
+ || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ einstall
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ insinto /usr/share/applications
+ doins sylpheed.desktop
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+
+}