summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2005-11-13 20:15:21 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2005-11-13 20:15:21 +0000
commitd0050004745bf18ac1bc5912bb39d7a6b69bf629 (patch)
tree8d23b71fa7ac70dd038b1c7335fab37e2942d6bb /mail-client/mozilla-thunderbird
parentstable on alpha wrt bug #112063 (diff)
downloadgentoo-2-d0050004745bf18ac1bc5912bb39d7a6b69bf629.tar.gz
gentoo-2-d0050004745bf18ac1bc5912bb39d7a6b69bf629.tar.bz2
gentoo-2-d0050004745bf18ac1bc5912bb39d7a6b69bf629.zip
Fix a compilation issue using the 32-bit userland with 64-bit kernel on PowerPC.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'mail-client/mozilla-thunderbird')
-rw-r--r--mail-client/mozilla-thunderbird/ChangeLog7
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild12
2 files changed, 17 insertions, 2 deletions
diff --git a/mail-client/mozilla-thunderbird/ChangeLog b/mail-client/mozilla-thunderbird/ChangeLog
index 924403c065d7..9359c52d09c4 100644
--- a/mail-client/mozilla-thunderbird/ChangeLog
+++ b/mail-client/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/mozilla-thunderbird
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.91 2005/10/25 21:55:41 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.92 2005/11/13 20:15:21 hansmi Exp $
+
+ 13 Nov 2005; Michael Hanselmann <hansmi@gentoo.org>
+ mozilla-thunderbird-1.0.7-r2.ebuild:
+ Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ PowerPC.
*mozilla-thunderbird-1.0.7-r2 (26 Oct 2005)
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild
index 4b43ee0df6c3..5344e1a5e9cc 100644
--- a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild,v 1.1 2005/10/25 21:55:41 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild,v 1.2 2005/11/13 20:15:21 hansmi Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic toolchain-funcs eutils mozconfig mozilla-launcher makeedit multilib
@@ -65,6 +65,16 @@ src_unpack() {
# freetype; this enables freetype-2.1.8+ compat.
# https://bugzilla.mozilla.org/show_bug.cgi?id=234035#c65
epatch ${DISTDIR}/mozilla-firefox-1.0-4ft2.patch.bz2
+
+ # Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ # PowerPC, because with that configuration, it detects a ppc64 system.
+ # -- hansmi, 2005-11-13
+ if use ppc && [[ "${PROFILE_ARCH}" == ppc64 ]]; then
+ sed -i -e "s#OS_TEST=\`uname -m\`\$#OS_TEST=${ARCH}#" \
+ ${S}/configure
+ sed -i -e "s#OS_TEST :=.*uname -m.*\$#OS_TEST:=${ARCH}#" \
+ ${S}/security/coreconf/arch.mk
+ fi
}
src_compile() {