summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-03-19 18:45:18 +0000
committerHans de Graaff <graaff@gentoo.org>2008-03-19 18:45:18 +0000
commit8ea34ad645748d98ea50dea28be512b94de8b19e (patch)
treef8db4f95a1dbfb0a96549e830a7c7882555e2630 /mail-client/mail-notification
parentVersion bump (diff)
downloadgentoo-2-8ea34ad645748d98ea50dea28be512b94de8b19e.tar.gz
gentoo-2-8ea34ad645748d98ea50dea28be512b94de8b19e.tar.bz2
gentoo-2-8ea34ad645748d98ea50dea28be512b94de8b19e.zip
Add support for yahoo mail
(Portage version: 2.1.4.4)
Diffstat (limited to 'mail-client/mail-notification')
-rw-r--r--mail-client/mail-notification/ChangeLog9
-rw-r--r--mail-client/mail-notification/mail-notification-5.0-r1.ebuild75
2 files changed, 83 insertions, 1 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index d882ebcaf736..211a1be5adc8 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.62 2008/03/19 04:04:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.63 2008/03/19 18:45:18 graaff Exp $
+
+*mail-notification-5.0-r1 (19 Mar 2008)
+
+ 19 Mar 2008; Hans de Graaff <graaff@gentoo.org>
+ +mail-notification-5.0-r1.ebuild:
+ Shorten description to make repoman happy; add yahoo USE flag for the yahoo
+ mail support based on net-mail/yahoo.
19 Mar 2008; Jeroen Roovers <jer@gentoo.org> mail-notification-5.0.ebuild:
Stable for HPPA too.
diff --git a/mail-client/mail-notification/mail-notification-5.0-r1.ebuild b/mail-client/mail-notification/mail-notification-5.0-r1.ebuild
new file mode 100644
index 000000000000..823b5637c79b
--- /dev/null
+++ b/mail-client/mail-notification/mail-notification-5.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.0-r1.ebuild,v 1.1 2008/03/19 18:45:18 graaff Exp $
+
+inherit autotools eutils gnome2 multilib flag-o-matic versionator
+
+DESCRIPTION="A GNOME trayicon which checks for email, with support for many online and offline mailbox formats."
+HOMEPAGE="http://www.nongnu.org/mailnotify/"
+SRC_URI="http://savannah.nongnu.org/download/mailnotify/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="imap ipv6 ssl sasl gmail evo sylpheed mbox maildir pop mozilla yahoo"
+
+# tests are currently broken and officially not supported upstream:
+# https://bugs.launchpad.net/mail-notification/+bug/182234
+RESTRICT="test"
+
+# gmime is actually optional, but it's used by so much of the package
+# it's pointless making it optional. gnome-keyring is required for
+# several specific access methods, and thus linked to those USE flags
+# instead of adding a keyring USE flag.
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.10
+ >=dev-util/gob-2.0.13
+ >=gnome-base/gnome-panel-2.6
+ >=gnome-base/eel-2.6
+ >=gnome-base/gconf-2.6
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/libglade-2.0
+ >=gnome-base/orbit-2.6
+ >=gnome-base/libbonobo-2.0
+ >=dev-libs/gmime-2.1
+ >=x11-libs/libnotify-0.4.1
+ pop? ( gnome-base/gnome-keyring )
+ imap? ( gnome-base/gnome-keyring )
+ gmail? ( gnome-base/gnome-keyring )
+ yahoo? ( gnome-base/gnome-keyring net-mail/fetchyahoo )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ evo? ( >=mail-client/evolution-2.12 )
+ sylpheed? ( virtual/sylpheed )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35.0"
+
+DOCS="README NEWS AUTHORS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable ssl)"
+ G2CONF="${G2CONF} $(use_enable sasl)"
+ G2CONF="${G2CONF} $(use_enable ipv6)"
+ # ssl, sasl and ipv6 requires either pop3 or imap, else they will be disabled
+ G2CONF="${G2CONF} $(use_enable imap)"
+ G2CONF="${G2CONF} $(use_enable pop pop3)"
+ G2CONF="${G2CONF} $(use_enable gmail)"
+ G2CONF="${G2CONF} $(use_enable yahoo)"
+ G2CONF="${G2CONF} $(use_enable evo evolution)"
+ G2CONF="${G2CONF} $(use_enable sylpheed)"
+ G2CONF="${G2CONF} $(use_enable mozilla)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ sed -i -e 's:gtk-update-icon-cache:true:' ./art/Makefile.in
+}
+
+src_compile() {
+ append-ldflags -Wl,-export-dynamic
+ gnome2_src_compile
+}