summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-02-18 11:41:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-02-18 11:41:25 +0000
commit016185f39f3f4cc63ee113b82e1714c95c4a5b0b (patch)
tree4196b42e08ecdafd85fa2e96564b967f8caef0c0 /lxde-base
parentEbuild cleanup. Thanks to Agostino Sarubbo. Bug #403381 (diff)
downloadgentoo-2-016185f39f3f4cc63ee113b82e1714c95c4a5b0b.tar.gz
gentoo-2-016185f39f3f4cc63ee113b82e1714c95c4a5b0b.tar.bz2
gentoo-2-016185f39f3f4cc63ee113b82e1714c95c4a5b0b.zip
Fix pam support. Thanks to Simon Poirier for investigating this. Bug #403999
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxdm/ChangeLog9
-rw-r--r--lxde-base/lxdm/files/lxdm-0.4.1-missing-pam-defines.patch29
-rw-r--r--lxde-base/lxdm/lxdm-0.4.1-r4.ebuild (renamed from lxde-base/lxdm/lxdm-0.4.1-r3.ebuild)24
3 files changed, 50 insertions, 12 deletions
diff --git a/lxde-base/lxdm/ChangeLog b/lxde-base/lxdm/ChangeLog
index 0559184915cb..21b1f1b9ca09 100644
--- a/lxde-base/lxdm/ChangeLog
+++ b/lxde-base/lxdm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for lxde-base/lxdm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.12 2012/02/04 10:43:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.13 2012/02/18 11:41:25 hwoarang Exp $
+
+*lxdm-0.4.1-r4 (18 Feb 2012)
+
+ 18 Feb 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/lxdm-0.4.1-missing-pam-defines.patch, +lxdm-0.4.1-r4.ebuild,
+ -lxdm-0.4.1-r3.ebuild:
+ Fix pam support. Thanks to Simon Poirier for investigating this. Bug #403999
*lxdm-0.4.1-r3 (04 Feb 2012)
diff --git a/lxde-base/lxdm/files/lxdm-0.4.1-missing-pam-defines.patch b/lxde-base/lxdm/files/lxdm-0.4.1-missing-pam-defines.patch
new file mode 100644
index 000000000000..a59273ccf40d
--- /dev/null
+++ b/lxde-base/lxdm/files/lxdm-0.4.1-missing-pam-defines.patch
@@ -0,0 +1,29 @@
+From 0f9e8e53a8d30f5c8ccfb03edc282148f58bfd30 Mon Sep 17 00:00:00 2001
+From: dgod <dgod.osa@gmail.com>
+Date: Sun, 1 Jan 2012 17:05:22 +0800
+Subject: [PATCH] fix bug introduced from pam detect
+
+---
+ src/lxdm.c | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/src/lxdm.c b/src/lxdm.c
+index b5a90be..07be1e0 100644
+--- a/src/lxdm.c
++++ b/src/lxdm.c
+@@ -25,8 +25,12 @@
+ #include <config.h>
+ #endif
+ #ifndef HAVE_LIBPAM
++#ifdef USE_PAM
++#define HAVE_LIBPAM 1
++#else
+ #define HAVE_LIBPAM 0
+ #endif
++#endif
+
+ #include <stdio.h>
+ #include <stdlib.h>
+--
+1.7.4.1
+
diff --git a/lxde-base/lxdm/lxdm-0.4.1-r3.ebuild b/lxde-base/lxdm/lxdm-0.4.1-r4.ebuild
index b3a18c24c2ad..9318af850587 100644
--- a/lxde-base/lxdm/lxdm-0.4.1-r3.ebuild
+++ b/lxde-base/lxdm/lxdm-0.4.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.4.1-r3.ebuild,v 1.1 2012/02/04 10:43:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.4.1-r4.ebuild,v 1.1 2012/02/18 11:41:25 hwoarang Exp $
EAPI="2"
@@ -26,16 +26,6 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
dev-util/pkgconfig"
-src_configure() {
- econf --enable-password \
- --with-x \
- --with-xconn=xcb \
- $(use_enable gtk3) \
- $(use_enable nls) \
- $(use_enable debug) \
- || die "econf failed"
-}
-
src_prepare() {
# Upstream bug, tarball contains pre-made lxdm.conf
rm "${S}"/data/lxdm.conf || die
@@ -47,6 +37,9 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-configure-add-pam.patch
+ # 403999
+ epatch "${FILESDIR}"/${P}-missing-pam-defines.patch
+
# this replaces the bootstrap/autogen script in most packages
eautoreconf
@@ -57,6 +50,15 @@ src_prepare() {
strip-linguas -i "${S}/po" || die
fi
}
+src_configure() {
+ econf --enable-password \
+ --with-x \
+ --with-xconn=xcb \
+ $(use_enable gtk3) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with pam)
+}
src_install() {
emake DESTDIR="${D}" install || die