summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-01-04 13:48:40 +0000
committerSteve Dibb <beandog@gentoo.org>2007-01-04 13:48:40 +0000
commit0ab52b44cc18d01c55e66e9fd1d40775b07d0a04 (patch)
tree41a7a029c075dc19ecde0839227c6de30e4f565c /kde-misc/tellico
parentDon't run libtoolize, if you need to, what you want is eautoreconf, so fix ha... (diff)
downloadgentoo-2-0ab52b44cc18d01c55e66e9fd1d40775b07d0a04.tar.gz
gentoo-2-0ab52b44cc18d01c55e66e9fd1d40775b07d0a04.tar.bz2
gentoo-2-0ab52b44cc18d01c55e66e9fd1d40775b07d0a04.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'kde-misc/tellico')
-rw-r--r--kde-misc/tellico/ChangeLog9
-rw-r--r--kde-misc/tellico/files/digest-tellico-1.2.73
-rw-r--r--kde-misc/tellico/tellico-1.2.7.ebuild53
3 files changed, 63 insertions, 2 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index 77a626646dd4..0f1bb9d5b56a 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/tellico
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.53 2006/11/18 15:05:08 mattepiu Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.54 2007/01/04 13:48:40 beandog Exp $
+
+*tellico-1.2.7 (04 Jan 2007)
+
+ 04 Jan 2007; Steve Dibb <beandog@gentoo.org> +tellico-1.2.7.ebuild:
+ Version bump
18 Nov 2006; Matteo Azzali <mattepiu@gentoo.org> -tellico-1.1.6.ebuild,
-tellico-1.2.ebuild, -tellico-1.2.2.ebuild, -tellico-1.2.3.ebuild:
diff --git a/kde-misc/tellico/files/digest-tellico-1.2.7 b/kde-misc/tellico/files/digest-tellico-1.2.7
new file mode 100644
index 000000000000..275b5503b791
--- /dev/null
+++ b/kde-misc/tellico/files/digest-tellico-1.2.7
@@ -0,0 +1,3 @@
+MD5 51635d215ac43d8c90125cc24a28fe46 tellico-1.2.7.tar.gz 4684384
+RMD160 49d8fbcf2207d2c97b811ba9386e91b1a463d9ca tellico-1.2.7.tar.gz 4684384
+SHA256 bc5e8d1aa90d8b6d902d0c1e01814a77dac95188f911e3788c81da6cf4197916 tellico-1.2.7.tar.gz 4684384
diff --git a/kde-misc/tellico/tellico-1.2.7.ebuild b/kde-misc/tellico/tellico-1.2.7.ebuild
new file mode 100644
index 000000000000..4ed9ca0e738b
--- /dev/null
+++ b/kde-misc/tellico/tellico-1.2.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-1.2.7.ebuild,v 1.1 2007/01/04 13:48:40 beandog Exp $
+
+inherit kde sgml-catalog
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A collection manager for the KDE environment."
+HOMEPAGE="http://www.periapsis.org/tellico"
+SRC_URI="http://www.periapsis.org/tellico/download/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="calendar cddb yaz"
+
+RDEPEND=">=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.0.19
+ cddb? ( || ( kde-base/libkcddb kde-base/kdemultimedia ) )
+ calendar? ( || ( ( kde-base/ktnef kde-base/libkcal ) kde-base/kdepim ) )
+ media-libs/taglib
+ yaz? ( dev-libs/yaz )"
+
+need-kde 3.4 #Real lowest version is 3.3.1
+
+src_compile() {
+ local myconf="$(use_enable cddb libkcddb) $(use_enable calendar libkcal)"
+ kde_src_compile
+}
+
+pkg_postinst() {
+ einfo "Installing catalog..."
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegatePublic" \
+ "-//Robby Stephenson/DTD Tellico V9.0//EN" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegateSystem" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegateURI" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+}
+
+pkg_postrm() {
+ ${ROOT}/usr/bin/xmlcatalog --noout --del \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+}