summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-12-17 21:24:22 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-12-17 21:24:22 +0000
commitd502244bb8c06c3e606eb7a3779121d9a4725dcd (patch)
treea4e727ea1a1279e5b5ca41dcccba69b9f4aeab21 /kde-frameworks/sonnet
parentVersion bump for apache-2.4.x support, bug #532780. (diff)
downloadgentoo-2-d502244bb8c06c3e606eb7a3779121d9a4725dcd.tar.gz
gentoo-2-d502244bb8c06c3e606eb7a3779121d9a4725dcd.tar.bz2
gentoo-2-d502244bb8c06c3e606eb7a3779121d9a4725dcd.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/ChangeLog7
-rw-r--r--kde-frameworks/sonnet/sonnet-5.5.0.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-frameworks/sonnet/ChangeLog b/kde-frameworks/sonnet/ChangeLog
index fba71a025877..f93e9d57481a 100644
--- a/kde-frameworks/sonnet/ChangeLog
+++ b/kde-frameworks/sonnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-frameworks/sonnet
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/sonnet/ChangeLog,v 1.3 2014/11/14 18:55:37 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/sonnet/ChangeLog,v 1.4 2014/12/17 21:24:22 mrueg Exp $
+
+*sonnet-5.5.0 (17 Dec 2014)
+
+ 17 Dec 2014; Manuel Rüger <mrueg@gentoo.org> +sonnet-5.5.0.ebuild:
+ Version bump.
14 Nov 2014; Manuel Rüger <mrueg@gentoo.org> -sonnet-5.3.0.ebuild:
Cleanup old.
diff --git a/kde-frameworks/sonnet/sonnet-5.5.0.ebuild b/kde-frameworks/sonnet/sonnet-5.5.0.ebuild
new file mode 100644
index 000000000000..6bbc681b3930
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/sonnet/sonnet-5.5.0.ebuild,v 1.1 2014/12/17 21:24:22 mrueg Exp $
+
+EAPI=5
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking capabilities through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS=" ~amd64"
+IUSE="aspell hunspell nls"
+
+RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell)
+ $(cmake-utils_use_find_package hunspell)
+ )
+
+ kde5_src_configure
+}