summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-08-28 19:57:17 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-08-28 19:57:17 +0000
commita32ff2747b08b331f59eb1e6617427c4c52185e4 (patch)
tree1d401fdaf2bd431ac5273cb96f61701426723779 /kde-base
parentStable for HPPA (bug #185823). (diff)
downloadgentoo-2-a32ff2747b08b331f59eb1e6617427c4c52185e4.tar.gz
gentoo-2-a32ff2747b08b331f59eb1e6617427c4c52185e4.tar.bz2
gentoo-2-a32ff2747b08b331f59eb1e6617427c4c52185e4.zip
Added an upstream patch to fix compilation with openexr-1.6.0 as per bug 189798.
(Portage version: 2.1.3.7)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdegraphics-kfile-plugins/ChangeLog8
-rw-r--r--kde-base/kdegraphics-kfile-plugins/files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch25
-rw-r--r--kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.7.ebuild5
3 files changed, 36 insertions, 2 deletions
diff --git a/kde-base/kdegraphics-kfile-plugins/ChangeLog b/kde-base/kdegraphics-kfile-plugins/ChangeLog
index 1a82611c81ff..161bef4e3f9b 100644
--- a/kde-base/kdegraphics-kfile-plugins/ChangeLog
+++ b/kde-base/kdegraphics-kfile-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdegraphics-kfile-plugins
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/ChangeLog,v 1.83 2007/08/11 15:58:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/ChangeLog,v 1.84 2007/08/28 19:57:17 philantrop Exp $
+
+ 28 Aug 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch,
+ kdegraphics-kfile-plugins-3.5.7.ebuild:
+ Added an upstream patch to fix compilation with openexr-1.6.0 as per bug
+ 189798.
11 Aug 2007; Raúl Porcel <armin76@gentoo.org>
kdegraphics-kfile-plugins-3.5.7.ebuild:
diff --git a/kde-base/kdegraphics-kfile-plugins/files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch b/kde-base/kdegraphics-kfile-plugins/files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch
new file mode 100644
index 000000000000..de82dba73000
--- /dev/null
+++ b/kde-base/kdegraphics-kfile-plugins/files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch
@@ -0,0 +1,25 @@
+--- kfile-plugins/exr/kfile_exr.cpp
++++ kfile-plugins/exr/kfile_exr.cpp
+@@ -32,6 +32,7 @@
+ #include <ImfVecAttribute.h>
+ #include <ImfPreviewImage.h>
+ #include <ImfVersion.h>
++#include <ImfCRgbaFile.h>
+
+ #include <iostream>
+
+@@ -226,7 +227,14 @@
+ qcapDateString.setLength(capDateString.size());
+ appendItem( stdgroup, "Capture Date", qcapDateString );
+ }
++ // This define was introduced in EXR 1.6.0
++#ifndef IMF_B44_COMPRESSION
++ // This is the 1.4 and earlier version
+ if ( hasutcOffset(h) ) {
++#else
++ // This is the 1.6.0 and later version
++ if ( hasUtcOffset(h) ) {
++#endif
+ QString UTCOffset;
+ if (utcOffset(h)>0.0) {
+ UTCOffset.append(QString("%1").arg(utcOffset(h)/3600, 0, 'f', 1));
diff --git a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.7.ebuild b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.7.ebuild
index 9688eff27571..46a7dc08eacb 100644
--- a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.7.ebuild
+++ b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.7.ebuild,v 1.7 2007/08/11 15:58:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.7.ebuild,v 1.8 2007/08/28 19:57:17 philantrop Exp $
KMNAME=kdegraphics
KMMODULE=kfile-plugins
@@ -20,6 +20,9 @@ DEPEND="media-libs/tiff
# ps installed with kghostview, pdf installed with kpdf
KMEXTRACTONLY="kfile-plugins/ps kfile-plugins/pdf"
+# cf. bug 189798. Applied unconditonally as it's downwards compatible.
+PATCHES="${FILESDIR}/${P}-openexr-1.6.0.patch"
+
src_compile() {
local myconf="$myconf $(use_with openexr)"
kde-meta_src_compile