summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-12 13:22:45 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-12 13:22:45 +0000
commit7815c24fb925fff5b00857396fb2a04ebdd7c563 (patch)
treee36f686bbd0014bb58cba3d2502095c2f0413724 /kde-base
parentAdding a patch that allows this package to compile with older and newer GCC v... (diff)
downloadgentoo-2-7815c24fb925fff5b00857396fb2a04ebdd7c563.tar.gz
gentoo-2-7815c24fb925fff5b00857396fb2a04ebdd7c563.tar.bz2
gentoo-2-7815c24fb925fff5b00857396fb2a04ebdd7c563.zip
New version.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/arts/ChangeLog7
-rw-r--r--kde-base/arts/arts-3.4.3.ebuild95
-rw-r--r--kde-base/arts/files/digest-arts-3.4.31
-rw-r--r--kde-base/kdeaddons/ChangeLog7
-rw-r--r--kde-base/kdeaddons/files/digest-kdeaddons-3.4.31
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.4.3.ebuild52
-rw-r--r--kde-base/kdeadmin/ChangeLog7
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.4.31
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.4.3.ebuild29
-rw-r--r--kde-base/kdebase/ChangeLog7
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.4.32
-rw-r--r--kde-base/kdebase/kdebase-3.4.3.ebuild135
-rw-r--r--kde-base/kdelibs/ChangeLog7
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.4.31
-rw-r--r--kde-base/kdelibs/kdelibs-3.4.3.ebuild121
15 files changed, 468 insertions, 5 deletions
diff --git a/kde-base/arts/ChangeLog b/kde-base/arts/ChangeLog
index 485735f528c2..be99081e3386 100644
--- a/kde-base/arts/ChangeLog
+++ b/kde-base/arts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/arts
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.181 2005/09/25 21:12:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.182 2005/10/12 13:19:17 greg_g Exp $
+
+*arts-3.4.3 (12 Oct 2005)
+
+ 12 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +arts-3.4.3.ebuild:
+ New version.
*arts-3.5_beta1-r1 (25 Sep 2005)
diff --git a/kde-base/arts/arts-3.4.3.ebuild b/kde-base/arts/arts-3.4.3.ebuild
new file mode 100644
index 000000000000..5d4e05f3af87
--- /dev/null
+++ b/kde-base/arts/arts-3.4.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-3.4.3.ebuild,v 1.1 2005/10/12 13:19:17 greg_g Exp $
+
+inherit kde flag-o-matic eutils
+set-kdedir 3.4
+
+MY_PV=${PV/#3/1}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://multimedia.kde.org/"
+SRC_URI="mirror://kde/stable/${PV}/src/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa esd artswrappersuid jack mp3 nas hardened vorbis"
+
+RDEPEND="$(qt_min_version 3.3)
+ >=dev-libs/glib-2
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libvorbis media-libs/libogg )
+ esd? ( media-sound/esound )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90 )
+ mp3? ( media-libs/libmad )
+ nas? ( media-libs/nas )
+ media-libs/audiofile"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}/arts-1.3.2-alsa-bigendian.patch"
+
+ if (is-flag -fstack-protector || is-flag -fstack-protector-all || use hardened); then
+ epatch ${FILESDIR}/arts-1.4-mcopidl.patch
+ fi
+
+ # Fix amd64 cpu overload & crash bug, kde bug 88474. Applied for 3.5.
+ epatch "$FILESDIR/arts-3.4.1-cpu-overload.patch"
+
+ # Configure patch. Applied for 3.5.
+ epatch "${FILESDIR}/arts-3.4.1-configure.patch"
+
+ # for the configure patch
+ make -f admin/Makefile.common || die
+}
+
+src_compile() {
+ myconf="$(use_enable alsa) $(use_enable vorbis)
+ $(use_enable mp3 libmad) $(use_with jack)
+ $(use_with esd) $(use_with nas)
+ --with-audiofile --without-mas"
+
+ #fix bug 13453
+ filter-flags -foptimize-sibling-calls
+
+ #fix bug 41980
+ use sparc && filter-flags -fomit-frame-pointer
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # moved here from kdelibs so that when arts is installed
+ # without kdelibs it's still in the path.
+ # List all the multilib libdirs
+ local libdirs
+ for libdir in $(get_all_libdirs); do
+ libdirs="${libdirs}:${PREFIX}/${libdir}"
+ done
+
+ dodir /etc/env.d
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${libdirs:1}
+CONFIG_PROTECT=\"${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown\"" > ${D}/etc/env.d/46kdepaths-3.4 # number goes down with version upgrade
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s ${D}/${PREFIX}/bin/artswrapper
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ einfo "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ einfo "and so avoid possible skips in sound. However, on untrusted systems this"
+ einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ einfo "priority, and so is off by default. See bug #7883."
+ einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/kde-base/arts/files/digest-arts-3.4.3 b/kde-base/arts/files/digest-arts-3.4.3
new file mode 100644
index 000000000000..c4b9c3e96697
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-3.4.3
@@ -0,0 +1 @@
+MD5 58585969a9a33784601122c77bd15a1e arts-1.4.3.tar.bz2 945025
diff --git a/kde-base/kdeaddons/ChangeLog b/kde-base/kdeaddons/ChangeLog
index 6968f2c75fb5..47f6bff718a1 100644
--- a/kde-base/kdeaddons/ChangeLog
+++ b/kde-base/kdeaddons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeaddons
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/ChangeLog,v 1.139 2005/10/06 23:31:48 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/ChangeLog,v 1.140 2005/10/12 13:22:12 greg_g Exp $
+
+*kdeaddons-3.4.3 (12 Oct 2005)
+
+ 12 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +kdeaddons-3.4.3.ebuild:
+ New version.
06 Oct 2005; Hardave Riar <hardave@gentoo.org> kdeaddons-3.4.2.ebuild:
Keyworded ~mips.
diff --git a/kde-base/kdeaddons/files/digest-kdeaddons-3.4.3 b/kde-base/kdeaddons/files/digest-kdeaddons-3.4.3
new file mode 100644
index 000000000000..bed159902dd3
--- /dev/null
+++ b/kde-base/kdeaddons/files/digest-kdeaddons-3.4.3
@@ -0,0 +1 @@
+MD5 e927d60e94adba69e78f82d82305f4ce kdeaddons-3.4.3.tar.bz2 1593317
diff --git a/kde-base/kdeaddons/kdeaddons-3.4.3.ebuild b/kde-base/kdeaddons/kdeaddons-3.4.3.ebuild
new file mode 100644
index 000000000000..34e001a6e9cb
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-3.4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.4.3.ebuild,v 1.1 2005/10/12 13:22:12 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE addon modules: plugins for konqueror, noatun etc"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="arts berkdb sdl xmms"
+
+DEPEND="~kde-base/kdepim-${PV}
+ ~kde-base/kdemultimedia-${PV}
+ ~kde-base/kdegames-${PV}
+ arts? ( ~kde-base/arts-${PV} )
+ sdl? ( >=media-libs/libsdl-1.2 )
+ xmms? ( media-sound/xmms )
+ berkdb? ( || ( =sys-libs/db-4.3*
+ =sys-libs/db-4.2* ) )"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Make vimpart use /usr/bin/kvim -- fixes bug 33257.
+ # This should continue to apply to upcoming versions since it's
+ # Gentoo-specific and won't go upstream.
+ epatch "${FILESDIR}/${PN}-3.2.0-kvim.diff"
+
+ # Configure patch. Applied for 3.5.
+ epatch "${FILESDIR}/kdeaddons-3.4-configure.patch"
+
+ # For the configure patch.
+ make -f admin/Makefile.common || die
+}
+
+src_compile() {
+ local myconf="$(use_with sdl) $(use_with xmms)"
+
+ if use berkdb; then
+ if has_version "=sys-libs/db-4.3*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-lib=db_cxx-4.3
+ --with-extra-includes=/usr/include/db4.3"
+ elif has_version "=sys-libs/db-4.2*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-lib=db_cxx-4.2
+ --with-extra-includes=/usr/include/db4.2"
+ fi
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde_src_compile
+}
diff --git a/kde-base/kdeadmin/ChangeLog b/kde-base/kdeadmin/ChangeLog
index 024d12a0b4aa..baab885ef0cb 100644
--- a/kde-base/kdeadmin/ChangeLog
+++ b/kde-base/kdeadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeadmin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.134 2005/10/06 23:33:08 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.135 2005/10/12 13:22:45 greg_g Exp $
+
+*kdeadmin-3.4.3 (12 Oct 2005)
+
+ 12 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +kdeadmin-3.4.3.ebuild:
+ New version.
06 Oct 2005; Hardave Riar <hardave@gentoo.org> kdeadmin-3.4.2.ebuild:
Keyworded ~mips.
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.4.3 b/kde-base/kdeadmin/files/digest-kdeadmin-3.4.3
new file mode 100644
index 000000000000..a9f5f060fa6e
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.4.3
@@ -0,0 +1 @@
+MD5 ded1ff7ea33f6634ee342b671bbe6677 kdeadmin-3.4.3.tar.bz2 1520420
diff --git a/kde-base/kdeadmin/kdeadmin-3.4.3.ebuild b/kde-base/kdeadmin/kdeadmin-3.4.3.ebuild
new file mode 100644
index 000000000000..693a88130f4a
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.4.3.ebuild,v 1.1 2005/10/12 13:22:45 greg_g Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="~kde-base/kdebase-${PV}"
+
+src_compile() {
+ # we only want to compile the lilo config module on x86, but there we want to make sure it's
+ # always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+ # because configure when left to its own devices will build lilo-config or not basd on whether
+ # lilo is present in the path.
+ # so, we make configure build it by removing the configure.in.in file that checks for
+ # lilo's presense
+ if use x86; then
+ echo > ${S}/lilo-config/configure.in.in
+ make -f admin/Makefile.common || die
+ fi
+
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} ksysv"
+
+ kde_src_compile
+}
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 20e944fe60d2..c0c68357625f 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.221 2005/10/06 23:15:54 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.222 2005/10/12 13:21:33 greg_g Exp $
+
+*kdebase-3.4.3 (12 Oct 2005)
+
+ 12 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +kdebase-3.4.3.ebuild:
+ New version.
06 Oct 2005; Hardave Riar <hardave@gentoo.org> kdebase-3.4.2-r1.ebuild:
Keyworded ~mips.
diff --git a/kde-base/kdebase/files/digest-kdebase-3.4.3 b/kde-base/kdebase/files/digest-kdebase-3.4.3
new file mode 100644
index 000000000000..bb8792f66435
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.4.3
@@ -0,0 +1,2 @@
+MD5 7b25feba2774c077601d472dae5352c8 kdebase-3.4.3.tar.bz2 22425835
+MD5 0437cf2231a850d7a1b47d07daca603f kdebase-3.4.3-kubuntu-hal.patch.gz 8441
diff --git a/kde-base/kdebase/kdebase-3.4.3.ebuild b/kde-base/kdebase/kdebase-3.4.3.ebuild
new file mode 100644
index 000000000000..78b1e3a9d54e
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.4.3.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.4.3.ebuild,v 1.1 2005/10/12 13:21:33 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE base packages: the desktop, panel, window manager, konqueror..."
+
+SRC_URI="${SRC_URI} mirror://gentoo/kdebase-3.4.3-kubuntu-hal.patch.gz"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="arts cups java ldap ieee1394 hal lm_sensors logitech-mouse openexr opengl pam samba ssl"
+# hal: enables hal backend for 'media:' ioslave
+
+DEPEND="arts? ( ~kde-base/arts-${PV} )
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ pam? ( kde-base/kdebase-pam )
+ >=dev-libs/cyrus-sasl-2
+ ldap? ( >=net-nds/openldap-2 )
+ cups? ( net-print/cups )
+ ssl? ( dev-libs/openssl )
+ opengl? ( virtual/opengl )
+ openexr? ( >=media-libs/openexr-1.2 )
+ samba? ( >=net-fs/samba-3.0.4 )
+ lm_sensors? ( sys-apps/lm_sensors )
+ logitech-mouse? ( >=dev-libs/libusb-0.1.10a )
+ ieee1394? ( sys-libs/libraw1394 )
+ hal? ( sys-apps/dbus
+ sys-apps/hal )"
+
+RDEPEND="${DEPEND}
+ java? ( >=virtual/jre-1.4 )
+ virtual/eject"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch "${FILESDIR}/kdebase-3.4.1-startkde-gentoo.patch"
+
+ # Configure patch. Applied for 3.5.
+ epatch "${FILESDIR}/kdebase-3.4-configure.patch"
+
+ # Support for hal-0.5, backported from 3.5 branch.
+ epatch "${WORKDIR}/kdebase-3.4.3-kubuntu-hal.patch"
+
+ # For the configure patch.
+ make -f admin/Makefile.common || die
+}
+
+src_compile() {
+ local myconf="--with-dpms
+ $(use_with arts) $(use_with ldap)
+ $(use_with cups) $(use_with opengl gl)
+ $(use_with ssl) $(use_with samba) $(use_with openexr)
+ $(use_with lm_sensors sensors) $(use_with logitech-mouse libusb)
+ $(use_with ieee1394 libraw1394) $(use_with hal)"
+
+ if use pam; then
+ myconf="${myconf} --with-pam=yes"
+ else
+ myconf="${myconf} --with-pam=no --with-shadow"
+ fi
+
+ # the java test is problematic (see kde bug 100729) and
+ # useless. All that's needed for java applets to work is
+ # to have the 'java' executable in PATH.
+ myconf="${myconf} --without-java"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup --no-in-notice" install
+
+ # startup and shutdown scripts
+ insinto ${KDEDIR}/env
+ doins ${FILESDIR}/agent-startup.sh
+
+ exeinto ${KDEDIR}/shutdown
+ doexe ${FILESDIR}/agent-shutdown.sh
+
+ # freedesktop environment variables
+ cat <<EOF > ${T}/xdg.sh
+export XDG_DATA_DIRS="${KDEDIR}/share:/usr/share"
+export XDG_CONFIG_DIRS="${KDEDIR}/etc/xdg"
+EOF
+ insinto ${KDEDIR}/env
+ doins ${T}/xdg.sh
+
+ # x11 session script
+ cat <<EOF > ${T}/kde-${SLOT}
+#!/bin/sh
+exec ${KDEDIR}/bin/startkde
+EOF
+ exeinto /etc/X11/Sessions
+ doexe ${T}/kde-${SLOT}
+
+ # freedesktop compliant session script
+ sed -e "s:@KDE_BINDIR@:${KDEDIR}/bin:g;s:Name=KDE:Name=KDE ${SLOT}:" \
+ ${S}/kdm/kfrontend/sessions/kde.desktop.in > ${T}/kde-${SLOT}.desktop
+ insinto /usr/share/xsessions
+ doins ${T}/kde-${SLOT}.desktop
+
+ # Customize the kdmrc configuration
+ sed -i -e "s:#SessionsDirs=:SessionsDirs=/usr/share/xsessions\n#SessionsDirs=:" \
+ -e "s:#GreetFont=:GreetFont=Sans Serif,24,-1,5,50,0,0,0,0,0\n#GreetFont=:" \
+ -e "s:#StdFont=:StdFont=Sans Serif,12,-1,5,50,0,0,0,0,0\n#StdFont=:" \
+ -e "s:#FailFont=:FailFont=Sans Serif,12,-1,5,75,0,0,0,0,0\n#FailFont=:" \
+ -e "s:#AntiAliasing=:AntiAliasing=true\n#AntiAliasing=:" \
+ ${D}/${KDEDIR}/share/config/kdm/kdmrc || die
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+}
+
+pkg_postinst() {
+ # set the default kdm face icon if it's not already set by the system admin
+ if [ ! -e "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon" ]; then
+ mkdir -p "${ROOT}${KDEDIR}/share/apps/kdm/faces"
+ cp "${ROOT}${KDEDIR}/share/apps/kdm/pics/users/default1.png" \
+ "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon"
+ fi
+
+ mkdir -p ${ROOT}${KDEDIR}/share/templates/.source/emptydir
+
+ echo
+ einfo "To enable gpg-agent and/or ssh-agent in KDE sessions,"
+ einfo "edit ${KDEDIR}/env/agent-startup.sh and"
+ einfo "${KDEDIR}/shutdown/agent-shutdown.sh"
+ echo
+}
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index c562ce742c05..cf4f2a18403a 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.276 2005/10/06 23:07:11 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.277 2005/10/12 13:20:16 greg_g Exp $
+
+*kdelibs-3.4.3 (12 Oct 2005)
+
+ 12 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +kdelibs-3.4.3.ebuild:
+ New version. Add workaround for collision with kdeadmin (#100968).
06 Oct 2005; Hardave Riar <hardave@gentoo.org> kdelibs-3.4.2-r1.ebuild:
Keyworded ~mips.
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.4.3 b/kde-base/kdelibs/files/digest-kdelibs-3.4.3
new file mode 100644
index 000000000000..4e9f447a881b
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.4.3
@@ -0,0 +1 @@
+MD5 0cd7c0c8a81e5d11b91b407a4aaaf3ff kdelibs-3.4.3.tar.bz2 16877867
diff --git a/kde-base/kdelibs/kdelibs-3.4.3.ebuild b/kde-base/kdelibs/kdelibs-3.4.3.ebuild
new file mode 100644
index 000000000000..6780a0f67e3c
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.4.3.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.3.ebuild,v 1.1 2005/10/12 13:20:16 greg_g Exp $
+
+inherit kde flag-o-matic eutils multilib
+set-kdedir 3.4
+
+DESCRIPTION="KDE libraries needed by all kde programs"
+HOMEPAGE="http://www.kde.org/"
+SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa arts cups doc jpeg2k kerberos openexr spell ssl tiff zeroconf"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+RDEPEND="$(qt_min_version 3.3.3)
+ arts? ( ~kde-base/arts-${PV} )
+ app-arch/bzip2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ >=dev-libs/libxslt-1.1.4
+ >=dev-libs/libxml2-2.6.6
+ >=dev-libs/libpcre-4.2
+ media-libs/libart_lgpl
+ net-dns/libidn
+ virtual/utempter
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ alsa? ( media-libs/alsa-lib )
+ cups? ( >=net-print/cups-1.1.19 )
+ tiff? ( media-libs/tiff )
+ kerberos? ( virtual/krb5 )
+ jpeg2k? ( media-libs/jasper )
+ openexr? ( >=media-libs/openexr-1.2 )
+ spell? ( || ( app-text/aspell
+ app-text/ispell ) )
+ zeroconf? ( net-misc/mDNSResponder )
+ virtual/fam
+ virtual/ghostscript"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ # Workaround collision with <=kdeadmin-3.4.1 (bug #100968).
+ rm -f "${ROOT}${KDEDIR}/share/mimelnk/application/x-debian-package.desktop"
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ # Configure patch. Applied for 3.5.
+ epatch "${FILESDIR}/kdelibs-3.4.1-configure.patch"
+
+ # for the configure patch
+ make -f admin/Makefile.common || die
+}
+
+src_compile() {
+ myconf="--with-distribution=Gentoo
+ --enable-libfam $(use_enable kernel_linux dnotify)
+ --with-libart --with-libidn --with-utempter
+ $(use_with alsa) $(use_with arts) $(use_with ssl)
+ $(use_with kerberos gssapi) $(use_with tiff)
+ $(use_with jpeg2k jasper) $(use_with openexr)
+ $(use_enable cups) $(use_enable zeroconf dnssd)"
+
+ if use spell && has_version app-text/aspell; then
+ myconf="${myconf} --with-aspell"
+ else
+ myconf="${myconf} --without-aspell"
+ fi
+
+ myconf="${myconf} --disable-fast-malloc"
+
+ # fix bug 58179, bug 85593
+ # kdelibs-3.4.0 needed -fno-gcse; 3.4.1 needs -mminimal-toc; this needs a
+ # closer look... - corsair
+ use ppc64 && append-flags "-mminimal-toc"
+
+ kde_src_compile
+
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ # Needed to create lib -> lib64 symlink for amd64 2005.0 profile
+ if [ "${SYMLINK_LIB}" = "yes" ]; then
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) ${KDEDIR}/lib
+ fi
+
+ if ! use arts ; then
+ dodir /etc/env.d
+
+ # List all the multilib libdirs
+ local libdirs
+ for libdir in $(get_all_libdirs); do
+ libdirs="${libdirs}:${PREFIX}/${libdir}"
+ done
+
+ cat <<EOF > ${D}/etc/env.d/46kdepaths-${SLOT} # number goes down with version upgrade
+PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${libdirs:1}
+CONFIG_PROTECT="${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown"
+EOF
+ fi
+
+}