summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-01-20 02:18:01 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-01-20 02:18:01 +0000
commit3bbe387834e2a44939b21c68df06e5eda3ebd21b (patch)
treec6129649580e63e36cb9086bb325b5dca2868f16 /kde-base
parentherdstat-1.1.91 has been dropped from the tree (diff)
downloadgentoo-2-3bbe387834e2a44939b21c68df06e5eda3ebd21b.tar.gz
gentoo-2-3bbe387834e2a44939b21c68df06e5eda3ebd21b.tar.bz2
gentoo-2-3bbe387834e2a44939b21c68df06e5eda3ebd21b.zip
Made the ocaml solver compile before the rest of Kalzium because the cmake-based build fails otherwise. Fixes bug 206620.
(Portage version: 2.1.4)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kalzium/ChangeLog6
-rw-r--r--kde-base/kalzium/kalzium-4.0.0.ebuild24
2 files changed, 28 insertions, 2 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index b0b988846ec5..dcf3e692d0b4 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.77 2008/01/17 23:31:30 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.78 2008/01/20 02:18:01 philantrop Exp $
+
+ 20 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org> kalzium-4.0.0.ebuild:
+ Made the ocaml solver compile before the rest of Kalzium because the
+ cmake-based build fails otherwise. Fixes bug 206620.
*kalzium-4.0.0 (17 Jan 2008)
diff --git a/kde-base/kalzium/kalzium-4.0.0.ebuild b/kde-base/kalzium/kalzium-4.0.0.ebuild
index fbc41e037493..63a24a69a8ea 100644
--- a/kde-base/kalzium/kalzium-4.0.0.ebuild
+++ b/kde-base/kalzium/kalzium-4.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.0.0.ebuild,v 1.1 2008/01/17 23:31:30 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.0.0.ebuild,v 1.2 2008/01/20 02:18:01 philantrop Exp $
EAPI="1"
@@ -24,10 +24,32 @@ KMEXTRACTONLY="libkdeedu/kdeeduui libkdeedu/libscience"
pkg_setup() {
use cviewer && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
+ if use solver && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-lang/ocaml built with the ocamlopt useflag"
+ eerror "in order to get a native code ocaml compiler"
+ die "Please install dev-lang/ocaml with ocamlopt support"
+ fi
+ if use solver && ! built_with_use --missing true dev-ml/facile ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-ml/facile built with the ocamlopt useflag"
+ eerror "in order to get the native code library"
+ die "Please install dev-ml/facile with ocamlopt support"
+ fi
+
kde4-meta_pkg_setup
}
src_compile() {
+ if use solver ; then
+ # Compile the solver on its own as the cmake-based build is
+ # currently broken. Fixes bug 206620.
+ cd "${S}/${PN}/src/solver"
+ emake || die "compiling the ocaml resolver failed"
+ mkdir -p "${WORKDIR}/${PN}_build/${PN}/src/"
+ cp * "${WORKDIR}/${PN}_build/${PN}/src/"
+ fi
+
mycmakeargs="${mycmakeargs}
$(cmake-utils_use_with cviewer Eigen)
$(cmake-utils_use_with cviewer OpenBabel2)