summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-04-14 16:21:50 +0000
committerDan Armak <danarmak@gentoo.org>2002-04-14 16:21:50 +0000
commit320d8bbb0313dd6d80f95297199412d60f36f110 (patch)
tree740b431b86815d3b3c575f2200cffc64a68695c8 /kde-base
parentfixed typo (diff)
downloadgentoo-2-320d8bbb0313dd6d80f95297199412d60f36f110.tar.gz
gentoo-2-320d8bbb0313dd6d80f95297199412d60f36f110.tar.bz2
gentoo-2-320d8bbb0313dd6d80f95297199412d60f36f110.zip
disable fast-malloc optimization if `arch`=pcc since it doesn't work there
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/kdelibs-3.0-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/kde-base/kdelibs/kdelibs-3.0-r1.ebuild b/kde-base/kdelibs/kdelibs-3.0-r1.ebuild
index 400cff71ccdc..7e5b3ba4893c 100644
--- a/kde-base/kdelibs/kdelibs-3.0-r1.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.0-r1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0-r1.ebuild,v 1.2 2002/04/06 08:57:49 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0-r1.ebuild,v 1.3 2002/04/14 16:21:50 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde kde.org
#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
-# check --with-dmalloc
# check need for glib >=1.3.3 (we have 1.2.10 only; configure has no glib flag but searches for it)
DESCRIPTION="KDE ${PV} - Libraries"
@@ -66,7 +65,8 @@ src_compile() {
use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
- myconf="$myconf --enable-fast-malloc=full"
+
+ if [ `arch` != ppc ]; then myconf="$myconf --enable-fast-malloc=full"; fi
kde_src_compile configure make