summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-28 10:45:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-28 10:45:53 +0000
commit0717e4c6c93f0b40c06f91f105c9a7270b202c91 (patch)
tree2401b4276d5937e279e3419ade2007c87f4d16b4 /kde-base
parentCheck only for qt3, as qt is no more pertinent. (diff)
downloadgentoo-2-0717e4c6c93f0b40c06f91f105c9a7270b202c91.tar.gz
gentoo-2-0717e4c6c93f0b40c06f91f105c9a7270b202c91.tar.bz2
gentoo-2-0717e4c6c93f0b40c06f91f105c9a7270b202c91.zip
Check only for qt3, as qt is no more pertinent.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdegraphics/ChangeLog6
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.5.2.ebuild20
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.5.3.ebuild20
3 files changed, 23 insertions, 23 deletions
diff --git a/kde-base/kdegraphics/ChangeLog b/kde-base/kdegraphics/ChangeLog
index 2ef2ef69b892..77f31a97dfb7 100644
--- a/kde-base/kdegraphics/ChangeLog
+++ b/kde-base/kdegraphics/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdegraphics
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.261 2006/06/27 21:04:19 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.262 2006/06/28 10:45:53 flameeyes Exp $
+
+ 28 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ kdegraphics-3.5.2.ebuild, kdegraphics-3.5.3.ebuild:
+ Check only for qt3, as qt is no more pertinent.
27 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
kdegraphics-3.4.3-r4.ebuild, kdegraphics-3.5.2.ebuild,
diff --git a/kde-base/kdegraphics/kdegraphics-3.5.2.ebuild b/kde-base/kdegraphics/kdegraphics-3.5.2.ebuild
index d636126d7fb9..56b653ee4af8 100644
--- a/kde-base/kdegraphics/kdegraphics-3.5.2.ebuild
+++ b/kde-base/kdegraphics/kdegraphics-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.2.ebuild,v 1.14 2006/06/27 21:04:19 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.2.ebuild,v 1.15 2006/06/28 10:45:53 flameeyes Exp $
inherit kde-dist eutils
@@ -29,9 +29,9 @@ DEPEND="~kde-base/kdebase-${PV}
RDEPEND="${DEPEND}
tetex? (
|| ( >=app-text/tetex-2
- app-text/ptex
- app-text/cstetex
- app-text/dvipdfm ) )"
+ app-text/ptex
+ app-text/cstetex
+ app-text/dvipdfm ) )"
DEPEND="${DEPEND}
dev-util/pkgconfig"
@@ -50,18 +50,16 @@ pkg_setup() {
die "Please reemerge ${ghostscript} with USE=\"X\"."
fi
done
- # check for qt still until it had a revision bump in both ~arch and stable.
- if use pdf && ! built_with_use app-text/poppler-bindings qt && \
- ! built_with_use app-text/poppler-bindings qt3; then
- eerror "This package requires app-text/poppler-bindings compiled with Qt support."
- eerror "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
- die "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
+ if use pdf && ! built_with_use app-text/poppler-bindings qt3; then
+ eerror "This package requires app-text/poppler-bindings compiled with Qt 3.x support."
+ eerror "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
+ die "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
fi
}
src_compile() {
local myconf="$(use_with openexr) $(use_with pdf poppler)
- $(use_with gphoto2 kamera)"
+ $(use_with gphoto2 kamera)"
use imlib || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kuickshow"
use scanner || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kooka libkscan"
diff --git a/kde-base/kdegraphics/kdegraphics-3.5.3.ebuild b/kde-base/kdegraphics/kdegraphics-3.5.3.ebuild
index 52bb14e47d43..340d8cb51921 100644
--- a/kde-base/kdegraphics/kdegraphics-3.5.3.ebuild
+++ b/kde-base/kdegraphics/kdegraphics-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.3.ebuild,v 1.2 2006/06/27 21:04:19 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.3.ebuild,v 1.3 2006/06/28 10:45:53 flameeyes Exp $
inherit kde-dist eutils
@@ -29,9 +29,9 @@ DEPEND="~kde-base/kdebase-${PV}
RDEPEND="${DEPEND}
tetex? (
|| ( >=app-text/tetex-2
- app-text/ptex
- app-text/cstetex
- app-text/dvipdfm ) )"
+ app-text/ptex
+ app-text/cstetex
+ app-text/dvipdfm ) )"
DEPEND="${DEPEND}
dev-util/pkgconfig"
@@ -50,18 +50,16 @@ pkg_setup() {
die "Please reemerge ${ghostscript} with USE=\"X\"."
fi
done
- # check for qt still until it had a revision bump in both ~arch and stable.
- if use pdf && ! built_with_use app-text/poppler-bindings qt && \
- ! built_with_use app-text/poppler-bindings qt3; then
- eerror "This package requires app-text/poppler-bindings compiled with Qt support."
- eerror "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
- die "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
+ if use pdf && ! built_with_use app-text/poppler-bindings qt3; then
+ eerror "This package requires app-text/poppler-bindings compiled with Qt 3.x support."
+ eerror "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
+ die "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
fi
}
src_compile() {
local myconf="$(use_with openexr) $(use_with pdf poppler)
- $(use_with gphoto2 kamera)"
+ $(use_with gphoto2 kamera)"
use imlib || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kuickshow"
use scanner || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kooka libkscan"