summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2001-11-22 17:32:27 +0000
committerBart Verwilst <verwilst@gentoo.org>2001-11-22 17:32:27 +0000
commit04c9787435ae574479774f67ecc37221a86751cc (patch)
treec730ab2b471318e1e18a0c168c208ed9a44c7ea8 /kde-base
parentnew version (diff)
downloadgentoo-2-04c9787435ae574479774f67ecc37221a86751cc.tar.gz
gentoo-2-04c9787435ae574479774f67ecc37221a86751cc.tar.bz2
gentoo-2-04c9787435ae574479774f67ecc37221a86751cc.zip
Finally, KDE 2.2.2!! :o) Packages are masked for the first days, to make
sure they all work fine... So test test test! :o) Also contains a new version of KDevelop...
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdeaddons/files/digest-kdeaddons-2.2.21
-rw-r--r--kde-base/kdeaddons/kdeaddons-2.2.2.ebuild36
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-2.2.21
-rw-r--r--kde-base/kdeadmin/kdeadmin-2.2.2.ebuild27
-rw-r--r--kde-base/kdeartwork/files/digest-kdeartwork-2.2.21
-rw-r--r--kde-base/kdeartwork/kdeartwork-2.2.2.ebuild13
-rw-r--r--kde-base/kdebase/files/digest-kdebase-2.2.21
-rw-r--r--kde-base/kdebase/kdebase-2.2.2.ebuild67
-rw-r--r--kde-base/kdebindings/files/digest-kdebindings-2.2.21
-rw-r--r--kde-base/kdebindings/kdebindings-2.2.2.ebuild35
-rw-r--r--kde-base/kdegames/files/digest-kdegames-2.2.21
-rw-r--r--kde-base/kdegames/kdegames-2.2.2.ebuild9
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-2.2.21
-rw-r--r--kde-base/kdegraphics/kdegraphics-2.2.2.ebuild27
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-2.2.21
-rw-r--r--kde-base/kdelibs/kdelibs-2.2.2.ebuild68
-rw-r--r--kde-base/kdemultimedia/files/digest-kdemultimedia-2.2.21
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-2.2.2.ebuild50
-rw-r--r--kde-base/kdenetwork/files/digest-kdenetwork-2.2.21
-rw-r--r--kde-base/kdenetwork/kdenetwork-2.2.2.ebuild15
-rw-r--r--kde-base/kdepim/files/digest-kdepim-2.2.21
-rw-r--r--kde-base/kdepim/kdepim-2.2.2.ebuild18
-rw-r--r--kde-base/kdesdk/files/digest-kdesdk-2.2.21
-rw-r--r--kde-base/kdesdk/kdesdk-2.2.2.ebuild9
-rw-r--r--kde-base/kdetoys/files/digest-kdetoys-2.2.21
-rw-r--r--kde-base/kdetoys/kdetoys-2.2.2.ebuild8
-rw-r--r--kde-base/kdeutils/files/digest-kdeutils-2.2.21
-rw-r--r--kde-base/kdeutils/kdeutils-2.2.2.ebuild9
-rw-r--r--kde-base/kdoc/files/digest-kdoc-2.2.21
-rw-r--r--kde-base/kdoc/kdoc-2.2.2.ebuild13
30 files changed, 419 insertions, 0 deletions
diff --git a/kde-base/kdeaddons/files/digest-kdeaddons-2.2.2 b/kde-base/kdeaddons/files/digest-kdeaddons-2.2.2
new file mode 100644
index 000000000000..bc22c188b673
--- /dev/null
+++ b/kde-base/kdeaddons/files/digest-kdeaddons-2.2.2
@@ -0,0 +1 @@
+MD5 9392da0992f4aede5f6a86840e47fef6 kdeaddons-2.2.2.tar.bz2 503808
diff --git a/kde-base/kdeaddons/kdeaddons-2.2.2.ebuild b/kde-base/kdeaddons/kdeaddons-2.2.2.ebuild
new file mode 100644
index 000000000000..75ef09cd4032
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-2.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Addons"
+
+NEWDEPEND=">=kde-base/kdebase-${PV}
+ >=kde-base/kdenetwork-${PV}
+ >=kde-base/kdemultimedia-${PV}
+ >=media-libs/libsdl-1.2"
+
+DEPEND="$DEPEND $NEWDEPEND"
+RDEPEND="$RDEPEND $NEWDEPEND"
+
+src_unpack() {
+
+ base_src_unpack all
+
+ cd ${S}/noatun-plugins
+ for x in `find -iname Makefile.am` `find -iname Makefile.in`; do
+ echo "(Maybe) patching ${x}..."
+ cp ${x} ${x}2
+ sed -e 's:$(kde_libraries)/libnoatun.so:/usr/lib/libnoatun.so:' ${x}2 > ${x}
+ rm ${x}2
+ done
+
+}
+
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --with-extra-includes=/usr/include/noatun"
+ kde_src_compile configure make
+}
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-2.2.2 b/kde-base/kdeadmin/files/digest-kdeadmin-2.2.2
new file mode 100644
index 000000000000..4090b42c5237
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-2.2.2
@@ -0,0 +1 @@
+MD5 5f97fe83d9a2efe3bfb679a679693a45 kdeadmin-2.2.2.tar.bz2 905216
diff --git a/kde-base/kdeadmin/kdeadmin-2.2.2.ebuild b/kde-base/kdeadmin/kdeadmin-2.2.2.ebuild
new file mode 100644
index 000000000000..001cbd3a25e1
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-2.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Administration"
+
+NEWDEPEND=">=app-arch/rpm-3.0.5
+ pam? ( >=sys-libs/pam-0.72 )"
+
+DEPEND="$DEPEND $NEWDEPEND"
+RDEPEND="$RDEPEND $NEWDEPEND"
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use pam && myconf="--with-pam" || myconf="--without-pam"
+
+ kde_src_compile configure make
+
+}
+
+
+
diff --git a/kde-base/kdeartwork/files/digest-kdeartwork-2.2.2 b/kde-base/kdeartwork/files/digest-kdeartwork-2.2.2
new file mode 100644
index 000000000000..80ee8cba8204
--- /dev/null
+++ b/kde-base/kdeartwork/files/digest-kdeartwork-2.2.2
@@ -0,0 +1 @@
+MD5 afaa475ba7d353453a5fa83d59b9f5e9 kdeartwork-2.2.2.tar.bz2 3411968
diff --git a/kde-base/kdeartwork/kdeartwork-2.2.2.ebuild b/kde-base/kdeartwork/kdeartwork-2.2.2.ebuild
new file mode 100644
index 000000000000..008348ff2515
--- /dev/null
+++ b/kde-base/kdeartwork/kdeartwork-2.2.2.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Artwork"
+
+src_install() {
+ dodir $KDEDIR/share/apps/kthememgr/Themes
+ kde_src_install all
+}
diff --git a/kde-base/kdebase/files/digest-kdebase-2.2.2 b/kde-base/kdebase/files/digest-kdebase-2.2.2
new file mode 100644
index 000000000000..a66cb7601fc2
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-2.2.2
@@ -0,0 +1 @@
+MD5 39635e42056ab2afb8e6f2ff761eea38 kdebase-2.2.2.tar.bz2 12890112
diff --git a/kde-base/kdebase/kdebase-2.2.2.ebuild b/kde-base/kdebase/kdebase-2.2.2.ebuild
new file mode 100644
index 000000000000..363554801331
--- /dev/null
+++ b/kde-base/kdebase/kdebase-2.2.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Base"
+
+NEWDEPEND=">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ lame? ( >=media-sound/lame-3.89b )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+DEPEND="$DEPEND $NEWDEPEND"
+RDEPEND="$RDEPEND $NEWDEPEND"
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+ use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+ use motif || myconf="$myconf --without-motif"
+ use lame || myconf="$myconf --without-lame"
+ use cups || myconf="$myconf --disable-cups"
+ use vorbis || myconf="$myconf --without-vorbis"
+ use opengl || myconf="$myconf --without-gl"
+ use ssl || myconf="$myconf --without-ssl"
+
+ kde_src_compile configure make
+
+}
+
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ cd ${D}/${KDEDIR}/bin
+ sed -e "s:^#\!/bin/sh:#\!/bin/sh --login:" \
+ -e "s/LD_BIND_NOW=true//" \
+ startkde > startkde.tmp
+ mv startkde.tmp startkde
+ chmod a+x startkde
+
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/{kde${PV},xsession}
+ cd ${D}/usr/X11R6/bin/wm
+ ln -sf kde${PV} kde
+
+ cd ${D}/${KDEDIR}/share/config/kdm
+ mv kdmrc kdmrc.orig
+ sed -e 's/SessionTypes=/SessionTypes=xsession,/' kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+ dodir ${KDEDIR}/share/templates/.source/emptydir
+
+}
diff --git a/kde-base/kdebindings/files/digest-kdebindings-2.2.2 b/kde-base/kdebindings/files/digest-kdebindings-2.2.2
new file mode 100644
index 000000000000..fc6218286313
--- /dev/null
+++ b/kde-base/kdebindings/files/digest-kdebindings-2.2.2
@@ -0,0 +1 @@
+MD5 9a36231bc47965c26529fd1c15c0abba kdebindings-2.2.2.tar.bz2 2478080
diff --git a/kde-base/kdebindings/kdebindings-2.2.2.ebuild b/kde-base/kdebindings/kdebindings-2.2.2.ebuild
new file mode 100644
index 000000000000..54454c0e2856
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-2.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Bindings"
+
+NEWDEPEND=">=kde-base/kdebase-${PV}
+ >=x11-libs/gtk+-1.2.10-r4
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( dev-lang/jdk )
+ >=x11-libs/gtk+-1.2.6
+ >=dev-libs/glib-1.2.6
+ >=kde-base/kdenetwork-${PV}"
+
+DEPEND="$DEPEND $NEWDEPEND"
+RDEPEND="$RDEPEND $NEWDEPEND"
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use python || myconf="$myconf --without-python"
+ use java && myconf="$myconf --with-java=/opt/java" || myconf="$myconf --without-java"
+
+ kde_src_compile configure
+
+ # the library_path is a kludge for a strange bug
+ LIBRARY_PATH=${QTDIR}/lib LIBPYTHON=\"`python-config`\" make || die
+
+}
+
diff --git a/kde-base/kdegames/files/digest-kdegames-2.2.2 b/kde-base/kdegames/files/digest-kdegames-2.2.2
new file mode 100644
index 000000000000..0b5afd293352
--- /dev/null
+++ b/kde-base/kdegames/files/digest-kdegames-2.2.2
@@ -0,0 +1 @@
+MD5 65b1e9885bdda64597e6e3cdf129cee3 kdegames-2.2.2.tar.bz2 8830976
diff --git a/kde-base/kdegames/kdegames-2.2.2.ebuild b/kde-base/kdegames/kdegames-2.2.2.ebuild
new file mode 100644
index 000000000000..2d3907aee1c4
--- /dev/null
+++ b/kde-base/kdegames/kdegames-2.2.2.ebuild
@@ -0,0 +1,9 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header:
+/home/cvsroot/gentoo-x86/kde-base/kdegames/kdegames-2.2.2.ebuild $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Games"
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-2.2.2 b/kde-base/kdegraphics/files/digest-kdegraphics-2.2.2
new file mode 100644
index 000000000000..e0d35332256b
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-2.2.2
@@ -0,0 +1 @@
+MD5 b9341505c6b9de8f018dd9d1896356e9 kdegraphics-2.2.2.tar.bz2 1650688
diff --git a/kde-base/kdegraphics/kdegraphics-2.2.2.ebuild b/kde-base/kdegraphics/kdegraphics-2.2.2.ebuild
new file mode 100644
index 000000000000..c2b56f339638
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-2.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Graphics"
+
+DEPEND="$DEPEND sys-devel/perl
+ media-gfx/sane-backends
+ tex? ( >=app-text/tetex-1.0.7 )
+ gphoto2? ( =media-gfx/gphoto-2.0_beta1 >=media-libs/libgpio-20010607 )"
+
+RDEPEND="$RDEPEND gphoto2? ( =media-gfx/gphoto-2.0_beta1 >=media-libs/libgpio-20010607 )"
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use gphoto2 && myconf="$myconf --with-gphoto2-includes=/usr/include/gphoto2 --with-gphoto2-libraries=/usr/lib/gphoto2" || myconf="$myconf --without-kamera"
+ use tex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+ kde_src_compile configure make
+
+}
+
+
diff --git a/kde-base/kdelibs/files/digest-kdelibs-2.2.2 b/kde-base/kdelibs/files/digest-kdelibs-2.2.2
new file mode 100644
index 000000000000..6748f63e631c
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-2.2.2
@@ -0,0 +1 @@
+MD5 51ec17dce9c62b50a3c2e97e4511cdcf kdelibs-2.2.2.tar.bz2 5959680
diff --git a/kde-base/kdelibs/kdelibs-2.2.2.ebuild b/kde-base/kdelibs/kdelibs-2.2.2.ebuild
new file mode 100644
index 000000000000..899dbcf6e216
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-2.2.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Libraries"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+COMMONDEPEND=">=sys-devel/gcc-2.95.2
+ virtual/glibc
+ sys-devel/ld.so
+ sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( net-print/cups )
+ >=media-libs/tiff-3.5.5"
+
+DEPEND="$COMMONDEPEND
+ sys-devel/make
+ sys-devel/autoconf
+ sys-devel/automake"
+
+RDEPEND="$COMMONDEPEND
+ ~kde-base/kde-env-${PV}
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python"
+
+need-qt 2.2.4
+
+BASE=/usr/lib/${P}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ myconf="$myconf --disable-libafm"
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+ myconf="$myconf --prefix=${BASE}"
+
+ kde_src_compile configure make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ docinto html
+ dodoc *.html
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/80${P}
+
+}
+
+
diff --git a/kde-base/kdemultimedia/files/digest-kdemultimedia-2.2.2 b/kde-base/kdemultimedia/files/digest-kdemultimedia-2.2.2
new file mode 100644
index 000000000000..2583df8fa359
--- /dev/null
+++ b/kde-base/kdemultimedia/files/digest-kdemultimedia-2.2.2
@@ -0,0 +1 @@
+MD5 76981ca284663093cd0bc37500e10441 kdemultimedia-2.2.2.tar.bz2 4702208
diff --git a/kde-base/kdemultimedia/kdemultimedia-2.2.2.ebuild b/kde-base/kdemultimedia/kdemultimedia-2.2.2.ebuild
new file mode 100644
index 000000000000..aae2337854d5
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-2.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Multimedia"
+
+NEWDEPEND=">=sys-libs/ncurses-5.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-video/xanim-2.80.1
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ nas? ( >=media-libs/nas-1.4.1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
+ slang? ( >=sys-libs/slang-1.4.4 )"
+# tcltk? ( =dev-lang/tcl-tk.8.0.5-r2 )
+
+DEPEND="$DEPEND $NEWDEPEND"
+RDEPEND="$RDEPEND $NEWDEPEND"
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ local myaudio
+ local myinteface
+ myaudio="--enable-audio=oss"
+ myinterface="--enable-interface=xaw,ncurses"
+
+ use alsa && myconf="$myconf --with-alsa" && myaudio="$myaudio,alsa"
+ use nas && myaudio="$myaudio,nas"
+ use esd && myaudio="$myaudio,esd"
+ use motif && myinterface="$myinterface,motif"
+ use gtk && myinterface="$myinterface,gtk"
+ use slang && myinterface="$myinterface,slang"
+# tcl tk does not work: use tcltk && myinterface="$myinterface,tcltk"
+
+ ./configure --host=${CHOST} \
+ --with-xinerama \
+ $myconf $myaudio $myinterface || die
+
+ kde_src_compile make
+
+}
+
+
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-2.2.2 b/kde-base/kdenetwork/files/digest-kdenetwork-2.2.2
new file mode 100644
index 000000000000..aab87698d94b
--- /dev/null
+++ b/kde-base/kdenetwork/files/digest-kdenetwork-2.2.2
@@ -0,0 +1 @@
+MD5 ef664b35f9d8ab083855ac5118b9c7b2 kdenetwork-2.2.2.tar.bz2 3170304
diff --git a/kde-base/kdenetwork/kdenetwork-2.2.2.ebuild b/kde-base/kdenetwork/kdenetwork-2.2.2.ebuild
new file mode 100644
index 000000000000..8b378bbf1aa1
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-2.2.2.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Network"
+
+#src_unpack() {
+#
+# base_src_unpack all patch
+# cd ${S}
+#
+#}
diff --git a/kde-base/kdepim/files/digest-kdepim-2.2.2 b/kde-base/kdepim/files/digest-kdepim-2.2.2
new file mode 100644
index 000000000000..811e8d8c94f3
--- /dev/null
+++ b/kde-base/kdepim/files/digest-kdepim-2.2.2
@@ -0,0 +1 @@
+MD5 55daf69b90108509895814b96fc8b671 kdepim-2.2.2.tar.bz2 2428928
diff --git a/kde-base/kdepim/kdepim-2.2.2.ebuild b/kde-base/kdepim/kdepim-2.2.2.ebuild
new file mode 100644
index 000000000000..1ca998f3fc12
--- /dev/null
+++ b/kde-base/kdepim/kdepim-2.2.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}PIM"
+
+DEPEND="$DEPEND >=dev-libs/pilot-link-0.9.0 sys-devel/perl"
+
+RDEPEND="$RDEPEND >=dev-libs/pilot-link-0.9.0"
+
+src_install() {
+ kde_src_install all
+ docinto html
+ dodoc *.html
+}
diff --git a/kde-base/kdesdk/files/digest-kdesdk-2.2.2 b/kde-base/kdesdk/files/digest-kdesdk-2.2.2
new file mode 100644
index 000000000000..770afd885561
--- /dev/null
+++ b/kde-base/kdesdk/files/digest-kdesdk-2.2.2
@@ -0,0 +1 @@
+MD5 f8080a3269a99f0c22a55ad9cab0682d kdesdk-2.2.2.tar.bz2 1097728
diff --git a/kde-base/kdesdk/kdesdk-2.2.2.ebuild b/kde-base/kdesdk/kdesdk-2.2.2.ebuild
new file mode 100644
index 000000000000..a3b981e450d1
--- /dev/null
+++ b/kde-base/kdesdk/kdesdk-2.2.2.ebuild
@@ -0,0 +1,9 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}SDK"
+
diff --git a/kde-base/kdetoys/files/digest-kdetoys-2.2.2 b/kde-base/kdetoys/files/digest-kdetoys-2.2.2
new file mode 100644
index 000000000000..64e4e9256222
--- /dev/null
+++ b/kde-base/kdetoys/files/digest-kdetoys-2.2.2
@@ -0,0 +1 @@
+MD5 67a90e965301997dc909229f643de22d kdetoys-2.2.2.tar.bz2 1056768
diff --git a/kde-base/kdetoys/kdetoys-2.2.2.ebuild b/kde-base/kdetoys/kdetoys-2.2.2.ebuild
new file mode 100644
index 000000000000..18d85d5851ee
--- /dev/null
+++ b/kde-base/kdetoys/kdetoys-2.2.2.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdetoys/kdetoys-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Toys"
diff --git a/kde-base/kdeutils/files/digest-kdeutils-2.2.2 b/kde-base/kdeutils/files/digest-kdeutils-2.2.2
new file mode 100644
index 000000000000..d99aa69c395d
--- /dev/null
+++ b/kde-base/kdeutils/files/digest-kdeutils-2.2.2
@@ -0,0 +1 @@
+MD5 68c3c86d97c3a95079f81b2c7f4bf35a kdeutils-2.2.2.tar.bz2 1470464
diff --git a/kde-base/kdeutils/kdeutils-2.2.2.ebuild b/kde-base/kdeutils/kdeutils-2.2.2.ebuild
new file mode 100644
index 000000000000..b63b689f33a5
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-2.2.2.ebuild
@@ -0,0 +1,9 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Utilities"
+
diff --git a/kde-base/kdoc/files/digest-kdoc-2.2.2 b/kde-base/kdoc/files/digest-kdoc-2.2.2
new file mode 100644
index 000000000000..6e7ef3767e7d
--- /dev/null
+++ b/kde-base/kdoc/files/digest-kdoc-2.2.2
@@ -0,0 +1 @@
+MD5 8837d2c767c8043bc7e526b75be79561 kdoc-2.2.2.tar.bz2 237568
diff --git a/kde-base/kdoc/kdoc-2.2.2.ebuild b/kde-base/kdoc/kdoc-2.2.2.ebuild
new file mode 100644
index 000000000000..6650d6ce6b2c
--- /dev/null
+++ b/kde-base/kdoc/kdoc-2.2.2.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdoc/kdoc-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Documentation tools"
+
+NEWDEPEND="sys-devel/perl"
+
+DEPEND="$DEPEND $NEWDEPEND"
+RDEPEND="$RDEPEND $NEWDEPEND"