summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-10-19 18:38:42 +0000
committerDan Armak <danarmak@gentoo.org>2005-10-19 18:38:42 +0000
commit4e73e64b5b14187db33c79dd2ec13f7290467d94 (patch)
treefb66a97dd51ac8296aae1e0bda759f57c257397d /kde-base/xparts
parentversion bump thanks to: Aaron in bug #109659. I missed the announcement of t... (diff)
downloadgentoo-2-4e73e64b5b14187db33c79dd2ec13f7290467d94.tar.gz
gentoo-2-4e73e64b5b14187db33c79dd2ec13f7290467d94.tar.bz2
gentoo-2-4e73e64b5b14187db33c79dd2ec13f7290467d94.zip
3.5.0_beta2 ebuilds for kdebindings-meta, package.masked like the rest of kde 3.5.0_beta2
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'kde-base/xparts')
-rw-r--r--kde-base/xparts/ChangeLog7
-rw-r--r--kde-base/xparts/Manifest2
-rw-r--r--kde-base/xparts/files/digest-xparts-3.5.0_beta23
-rw-r--r--kde-base/xparts/xparts-3.5.0_beta2.ebuild37
4 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/xparts/ChangeLog b/kde-base/xparts/ChangeLog
index 6fe3dff7a789..9a37ee7f9c7e 100644
--- a/kde-base/xparts/ChangeLog
+++ b/kde-base/xparts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/xparts
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/xparts/ChangeLog,v 1.9 2005/05/25 21:23:15 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/xparts/ChangeLog,v 1.10 2005/10/19 18:38:42 danarmak Exp $
+
+*xparts-3.5.0_beta2 (19 Oct 2005)
+
+ 19 Oct 2005; Dan Armak <danarmak@gentoo.org> +xparts-3.5.0_beta2.ebuild:
+ New version. Reminder: prerelease versions are permanently package.masked.
*xparts-3.4.1 (25 May 2005)
diff --git a/kde-base/xparts/Manifest b/kde-base/xparts/Manifest
index b49da6caaab0..666d39d3db94 100644
--- a/kde-base/xparts/Manifest
+++ b/kde-base/xparts/Manifest
@@ -1,7 +1,9 @@
MD5 4db956b81bc310d1025aaad7bf1d091c ChangeLog 1887
MD5 6830fc45ae55313b9f8515babcf58b79 files/digest-xparts-3.3.1 71
MD5 6a7b860a285423d0fc6516e274fcaaea files/digest-xparts-3.4.1 221
+MD5 7b7cadef2c4eb7dc5409c01c4e689481 files/digest-xparts-3.5.0_beta2 225
MD5 ffe26fb6d5d193883dfebd69250df2e5 files/no-gtk-glib-check.diff 949
MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
MD5 ca9550c47090fc658c5e454dc7069f9c xparts-3.3.1.ebuild 1244
MD5 14e232766ea82cd9591e2c5be9b94194 xparts-3.4.1.ebuild 1201
+MD5 c2eb22cf3e0adbdee31ac3401e0b03a1 xparts-3.5.0_beta2.ebuild 1191
diff --git a/kde-base/xparts/files/digest-xparts-3.5.0_beta2 b/kde-base/xparts/files/digest-xparts-3.5.0_beta2
new file mode 100644
index 000000000000..2811f330fe0b
--- /dev/null
+++ b/kde-base/xparts/files/digest-xparts-3.5.0_beta2
@@ -0,0 +1,3 @@
+MD5 9b7e5645554e2afe679a14baf74a67de kdebindings-3.4.91-3.4.92.tar.xdelta 451966
+MD5 7e259339d6e431046aca6953926d9258 kdebindings-3.4.91.tar.bz2 7172282
+MD5 cc2c4d8865f3c325bce1e5271d5a82d9 kdebindings-3.4.92.tar.bz2 7172280
diff --git a/kde-base/xparts/xparts-3.5.0_beta2.ebuild b/kde-base/xparts/xparts-3.5.0_beta2.ebuild
new file mode 100644
index 000000000000..75ffa564eaf2
--- /dev/null
+++ b/kde-base/xparts/xparts-3.5.0_beta2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/xparts/xparts-3.5.0_beta2.ebuild,v 1.1 2005/10/19 18:38:42 danarmak Exp $
+
+KMNAME=kdebindings
+KMEXTRACTONLY="dcopc"
+KMCOPYLIB="libdcopc dcopc"
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Allows embedding of generic XParts as KDE KParts"
+KEYWORDS="~amd64" # broken according to upstream - 3.4a1 README
+IUSE="mozilla"
+DEPEND="=dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ mozilla? ( www-client/mozilla )"
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ # Doesn't affect makefile tarballs.
+ # Real solution will be to split this further and make a separate
+ # ebuild for the mozilla xpart.
+ # But since this is officially broken anyway I'm not going to bother...
+ if ! useq mozilla ; then
+ # disable mozilla bindings/xpart, because configure doesn't seem to do so
+ # even when it doesn't detect the mozilla headers
+ cd ${S}/xparts
+ cp Makefile.am Makefile.am.orig
+ sed -e 's:mozilla::' Makefile.am.orig > Makefile.am
+ fi
+ cd ${S} && make -f admin/Makefile.common
+}
+