summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
commit0650db9ab87aa55db42a5157e24d12132d2832ae (patch)
treefb6d626c063029446861ab8305a09ef01b29fd36 /kde-base/step
parentVersion bump. Remove intermediate version. (diff)
downloadgentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.tar.gz
gentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.tar.bz2
gentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.zip
Version bump to KDE SC 4.6.3.
(Portage version: 2.2.0_alpha31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.6.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 31510778f4c2..3329f3061880 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.68 2011/04/06 14:19:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.69 2011/05/07 10:47:53 scarabeus Exp $
+
+*step-4.6.3 (07 May 2011)
+
+ 07 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> +step-4.6.3.ebuild:
+ Version bump KDE SC 4.6.3
*step-4.6.2 (06 Apr 2011)
diff --git a/kde-base/step/step-4.6.3.ebuild b/kde-base/step/step-4.6.3.ebuild
new file mode 100644
index 000000000000..5f235c2db812
--- /dev/null
+++ b/kde-base/step/step-4.6.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.6.3.ebuild,v 1.1 2011/05/07 10:47:53 scarabeus Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ eclass=kde4-base
+else
+ KMNAME="kdeedu"
+ eclass=kde4-meta
+fi
+
+inherit ${eclass}
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+ ${eclass}_src_configure
+}