summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:21:35 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:21:35 +0000
commit3f801aa646c6bf1e1d60d310da2302c2bd9fef66 (patch)
tree6e50112a7a8405c97655dde74a1c9e8217de71bd /kde-base/qyoto
parentremove old (diff)
downloadgentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.tar.gz
gentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.tar.bz2
gentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.zip
[kde-base] Add KDE SC 4.14.3
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.14.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 2f5f37d09f3d..3cfaebc7e2b1 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.131 2014/11/14 19:33:14 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.132 2014/11/16 12:21:25 alexxy Exp $
+
+*qyoto-4.14.3 (16 Nov 2014)
+
+ 16 Nov 2014; Alexey Shvetsov <alexxy@gentoo.org> +qyoto-4.14.3.ebuild:
+ Version bump KDE SC 4.14.3
14 Nov 2014; Manuel Rüger <mrueg@gentoo.org> -qyoto-4.13.3.ebuild,
-qyoto-4.14.1.ebuild:
diff --git a/kde-base/qyoto/qyoto-4.14.3.ebuild b/kde-base/qyoto/qyoto-4.14.3.ebuild
new file mode 100644
index 000000000000..312a9bb4cad0
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.14.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.14.3.ebuild,v 1.1 2014/11/16 12:21:25 alexxy Exp $
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Qyoto"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}