summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commitdcee7201ef2606358a4f2abc45af713ef2555e5a (patch)
treedac1ea20988f395333c20c4985b60f84f2e71a82 /kde-base/qtruby
parentbump to the TeX Live 2011 version (diff)
downloadgentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.gz
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.bz2
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.zip
[kde-base] Version bump KDE SC 4.7.0
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog10
-rw-r--r--kde-base/qtruby/metadata.xml12
-rw-r--r--kde-base/qtruby/qtruby-4.7.0.ebuild76
3 files changed, 98 insertions, 0 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
new file mode 100644
index 000000000000..69cf9f848289
--- /dev/null
+++ b/kde-base/qtruby/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for kde-base/qtruby
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.86 2011/07/27 14:04:31 alexxy Exp $
+
+*qtruby-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +qtruby-4.7.0.ebuild,
+ +metadata.xml:
+ Version bump KDE SC 4.7.0
+
diff --git a/kde-base/qtruby/metadata.xml b/kde-base/qtruby/metadata.xml
new file mode 100644
index 000000000000..94b13108fbad
--- /dev/null
+++ b/kde-base/qtruby/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<use>
+ <flag name="declarative">Compile bindings for <pkg>x11-libs/qt-declarative</pkg>.</flag>
+ <flag name="phonon">Compile bindings for Phonon.</flag>
+ <flag name="qscintilla">Compile bindings for <pkg>x11-libs/qscintilla</pkg>.</flag>
+ <flag name="qwt">Compile bindings for <pkg>x11-libs/qwt</pkg>.</flag>
+ <flag name="webkit">Compile bindings for <pkg>x11-libs/qt-webkit</pkg>.</flag>
+</use>
+</pkgmetadata>
diff --git a/kde-base/qtruby/qtruby-4.7.0.ebuild b/kde-base/qtruby/qtruby-4.7.0.ebuild
new file mode 100644
index 000000000000..043caf43e36b
--- /dev/null
+++ b/kde-base/qtruby/qtruby-4.7.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.7.0.ebuild,v 1.1 2011/07/27 14:04:31 alexxy Exp $
+
+EAPI=4
+
+OPENGL_REQUIRED="always"
+DECLARATIVE_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+USE_RUBY="ruby18"
+# No ruby19 for three reasons:
+# 1) it does not build (yet) - will likely be solved soon
+# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="Qt Ruby bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug phonon qscintilla qwt webkit"
+
+DEPEND="
+ $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
+"
+
+RDEPEND="${DEPEND}
+ !dev-ruby/qt4-qtruby
+"
+
+# Split from kdebindings-ruby in 4.7
+add_blocker kdebindings-ruby
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ local CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}