summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
committerJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
commitc9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f (patch)
tree94015d5f29e37019f20bdced917f52e9b11645da /kde-base/pykde4
parentAdd kde-workspace 4.11.11 SRC_URI, remove obsolete. (diff)
downloadgentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.gz
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.bz2
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.zip
Version bump KDE SC 4.13.3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog8
-rw-r--r--kde-base/pykde4/files/pykde4-4.13.3-pyqt4-4.11.patch14
-rw-r--r--kde-base/pykde4/pykde4-4.13.3.ebuild161
3 files changed, 182 insertions, 1 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 4b6a15c56017..0d65d9d0dc3f 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.292 2014/06/25 04:12:13 jcallen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.293 2014/07/16 17:40:43 johu Exp $
+
+*pykde4-4.13.3 (16 Jul 2014)
+
+ 16 Jul 2014; Johannes Huber <johu@gentoo.org> +pykde4-4.13.3.ebuild,
+ +files/pykde4-4.13.3-pyqt4-4.11.patch:
+ Version bump KDE SC 4.13.3
25 Jun 2014; Jonathan Callen <jcallen@gentoo.org> pykde4-4.13.2.ebuild:
Add python3_4 to PYTHON_COMPAT
diff --git a/kde-base/pykde4/files/pykde4-4.13.3-pyqt4-4.11.patch b/kde-base/pykde4/files/pykde4-4.13.3-pyqt4-4.11.patch
new file mode 100644
index 000000000000..8c322ef2b310
--- /dev/null
+++ b/kde-base/pykde4/files/pykde4-4.13.3-pyqt4-4.11.patch
@@ -0,0 +1,14 @@
+https://bugs.kde.org/show_bug.cgi?id=332223
+
+diff -up pykde4-4.12.3/sip/phonon/backendcapabilities.sip.sip4_15_5 pykde4-4.12.3/sip/phonon/backendcapabilities.sip
+--- pykde4-4.12.3/sip/phonon/backendcapabilities.sip.sip4_15_5 2014-01-18 13:18:35.000000000 -0600
++++ pykde4-4.12.3/sip/phonon/backendcapabilities.sip 2014-03-16 16:56:36.865132943 -0500
+@@ -26,7 +26,7 @@ namespace Phonon
+ {
+ namespace BackendCapabilities
+ {
+-class Notifier : QObject /NoDefaultCtors,PyQt4NoQMetaObject/
++class Notifier : QObject /NoDefaultCtors,PyQtNoQMetaObject/
+ {
+
+ signals:
diff --git a/kde-base/pykde4/pykde4-4.13.3.ebuild b/kde-base/pykde4/pykde4-4.13.3.ebuild
new file mode 100644
index 000000000000..8eafaa731305
--- /dev/null
+++ b/kde-base/pykde4/pykde4-4.13.3.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.13.3.ebuild,v 1.1 2014/07/16 17:40:43 johu Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+PYTHON_REQ_USE="threads"
+OPENGL_REQUIRED="always"
+
+inherit python-r1 portability kde4-base multilib eutils
+
+DESCRIPTION="Python bindings for KDE4"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug doc examples nepomuk test"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} test? ( nepomuk )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt4-4.9.5[${PYTHON_USEDEP},dbus,declarative,script(+),sql,svg,webkit,X]
+ >=dev-python/sip-4.14:=[${PYTHON_USEDEP}]
+ $(add_kdebase_dep kdelibs 'nepomuk?,opengl')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ nepomuk? ( >=dev-libs/soprano-2.9.0 )
+"
+DEPEND="${RDEPEND}
+ dev-lang/python-exec:0[${PYTHON_USEDEP}]
+ sys-devel/libtool
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.13.3-pyqt4-4.11.patch" )
+
+pkg_setup() {
+ kde4-base_pkg_setup
+
+ have_python2=false
+
+ scan_python_versions() {
+ if [[ ${EPYTHON} == python2.* ]]; then
+ have_python2=true
+ fi
+ }
+ python_foreach_impl scan_python_versions
+
+ if ! ${have_python2}; then
+ ewarn "You do not have a Python 2 version selected."
+ ewarn "kpythonpluginfactory will not be built"
+ fi
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+
+ # See bug 322351
+ use arm && epatch "${FILESDIR}/${PN}-4.10.1-arm-sip.patch"
+
+ sed -e 's/kpythonpluginfactory /kpython${PYTHON_SHORT_VERSION}pluginfactory /g' \
+ -i kpythonpluginfactory/CMakeLists.txt || die
+
+ if ${have_python2}; then
+ mkdir -p "${WORKDIR}/wrapper" || die "failed to copy wrapper"
+ cp "${FILESDIR}/kpythonpluginfactorywrapper.c-r1" "${WORKDIR}/wrapper/kpythonpluginfactorywrapper.c" || die "failed to copy wrapper"
+ fi
+ python_copy_sources
+
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ -DWITH_PolkitQt=OFF
+ -DWITH_QScintilla=OFF
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with nepomuk Soprano)
+ -DPYTHON_EXECUTABLE=${PYTHON}
+ -DPYKDEUIC4_ALTINSTALL=TRUE
+ )
+ local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
+ kde4-base_src_configure
+ }
+
+ python_foreach_impl run_in_build_dir configuration
+}
+
+echo_and_run() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ compilation() {
+ local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
+ kde4-base_src_compile
+ }
+ python_foreach_impl run_in_build_dir compilation
+
+ if ${have_python2}; then
+ pushd "${WORKDIR}/wrapper" > /dev/null
+ echo_and_run libtool --tag=CC --mode=compile $(tc-getCC) \
+ -shared \
+ ${CFLAGS} ${CPPFLAGS} \
+ -DEPREFIX="\"${EPREFIX}\"" \
+ -DPLUGIN_DIR="\"/usr/$(get_libdir)/kde4\"" -c \
+ -o kpythonpluginfactorywrapper.lo \
+ kpythonpluginfactorywrapper.c
+ echo_and_run libtool --tag=CC --mode=link $(tc-getCC) \
+ -shared -module -avoid-version \
+ ${CFLAGS} ${LDFLAGS} \
+ -o kpythonpluginfactory.la \
+ -rpath "${EPREFIX}/usr/$(get_libdir)/kde4" \
+ kpythonpluginfactorywrapper.lo \
+ $(dlopen_lib)
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir kde4-base_src_test
+}
+
+src_install() {
+ installation() {
+ emake DESTDIR="${D}" install
+
+ mv "${ED}"/usr/bin/pykdeuic4-{${EPYTHON/python/},${EPYTHON}} || die
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ dosym python-exec /usr/bin/pykdeuic4
+
+ # As we don't call the eclass's src_install, we have to install the docs manually
+ DOCS=("${S}"/{AUTHORS,NEWS,README})
+ use doc && HTML_DOCS=("${S}/docs/html/")
+ einstalldocs
+
+ if ${have_python2}; then
+ pushd "${WORKDIR}/wrapper" > /dev/null
+ echo_and_run libtool --mode=install install kpythonpluginfactory.la "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
+ rm "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
+ popd > /dev/null
+ fi
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${EPREFIX}/usr/share/apps/${PN}/examples"
+ echo
+ fi
+}